Opened 10 years ago

Closed 8 years ago

Last modified 6 years ago

#1133 closed bug (fixed)

cannot delete my gallery pictures

Reported by: enriqueguillen Owned by:
Priority: major Milestone: Legacy Resolved
Component: BW Gallery Keywords: error deleting pics
Cc: micha@…

Description

I go to my gallery: http://www.bewelcome.org/gallery/show/user/enriqueguillen I select all pictures and try to delete them. Then I get this error note, here: http://www.bewelcome.org/gallery/show/user/enriqueguillen/sets

Notice: Undefined index: gallery in /home/bwrox/www.bewelcome.org/build/gallery/gallery.model.php on line 202

Notice: Undefined index: gallery in /home/bwrox/www.bewelcome.org/build/gallery/gallery.model.php on line 208

Warning: Cannot modify header information - headers already sent by (output started at /home/bwrox/www.bewelcome.org/build/gallery/gallery.model.php:202) in /home/bwrox/www.bewelcome.org/lib/handler/posthandler.lib.php on line 121

Change History (6)

comment:1 Changed 9 years ago by midsch

  • Component changed from unknown to BW Gallery
  • follow_up changed from none to review code
  • freq_reported changed from 1 to 2

With single pics it looks ok at first, but they aren't deleted. As gallery pics are public (and associated with [user]names) it's important to allow people to delete pics themselves.

For two clicked pics:

Notice: Undefined index: gallery in /home/bwrox/www.bewelcome.org/build/gallery/gallery.model.php on line 202 Notice: Undefined index: gallery in /home/bwrox/www.bewelcome.org/build/gallery/gallery.model.php on line 208 Warning: Cannot modify header information - headers already sent by (output started at /home/bwrox/www.bewelcome.org/build/gallery/gallery.model.php:202) in /home/bwrox/www.bewelcome.org/lib/handler/posthandler.lib.php on line 121

For all pics:

Notice: Undefined index: gallery in /home/bwrox/www.bewelcome.org/build/gallery/gallery.model.php on line 208 Warning: Cannot modify header information - headers already sent by (output started at /home/bwrox/www.bewelcome.org/build/gallery/gallery.model.php:208) in /home/bwrox/www.bewelcome.org/lib/handler/posthandler.lib.php on line 121

comment:2 Changed 9 years ago by micha

  • Cc micha@… added
  • follow_up changed from review code to test on production

What's the status on this now? We did a major update here. Bug's gone?

comment:3 Changed 9 years ago by midsch

(I don't follow trac-timeline right now, but got a mail from your last post)

I was able to delete pics. So the major bug is fixed/gone, but after pressing delete I get: "Sorry :(

BeWelcome has just suffered an error of some magnitude (i.e. we cannot show you the page you were looking for and something went wrong as we looked for it), which is why you are looking at this error message. We apologise for the inconvenience many times, and humbly request that you send the address of this page to us through the feedback (and hopefully that is not the page that brings up this error ...)."

Can't upload more than one pic at a time, can't delete more than one at a time (same error like above) - the action is always performed only on the first picture. (Ah, and yes, against better knowledge I've allowed javascript from bewelcome.org;)

comment:4 Changed 9 years ago by crumbking

I tested both, multiple upload and deleting (1 pic, 2 pics at a time) I could not reproduce the error message.

Could someone else try?

otherwise we could close the ticket

comment:5 Changed 8 years ago by globetrotter_tt

  • follow_up changed from test on production to none
  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 6 years ago by TimLoal

  • Milestone changed from unassigned to Legacy Resolved
Note: See TracTickets for help on using tickets.