Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#1147 closed bug (fixed)

Problem with the chosen place at signup

Reported by: jeanyves Owned by: planetcruiser
Priority: critical Milestone: 0.5.6 - bugfixing
Component: BW Geo Keywords: geonames cities signup
Cc: lupochen, philipp, jeanyves, micha, jyhegron@…

Description

Very often (and especially in Philippines), people signup in an ADM1 location class instead of signing in a PPL location class

Typical example: LIPA CITY Theu are two records in geonames: one is and ADM1 (this one is not the one to chose) the other is a PPL (this is the one to choose).

When members signup in this place, the ADM1 one is used and it result that because it is not a PPL place, the cities view mecanism doesn't works. The link with addresse sucks and the member cannot be accepted (he just has no city , so no country ...).

I repair manually these problem since several month, but in fact it teh problem is to be fixed at Signup phase. At signup phase, only the location of type PPL should be used.

In addition, this is an other problem, if a place has a name with a ' it is not possible to select it at signup. For example you cannot signup in val d'or in Québec

I think that, both are quite urgent problem, we are probably loosing members

Change History (17)

comment:1 Changed 9 years ago by micha

  • follow_up changed from none to test
  • Milestone changed from unassigned to new design bugfixing
  • Owner set to philipp
  • Priority changed from critical to major

I solved the second problem. It was (as expected) only a problem with escape-functions of php.

The first problem you described is somewhat more tricky but actually Philipp tried to solve it a while ago. I couldn't see that within the Signup Process you could select a ADM1-location. Also for your example only "Lipa City" as PPL shows up. If we really store the ADM1 location that is not even choosen at signup, that's a miracle and we have to check that.

comment:2 Changed 9 years ago by philipp

it is indeed a miracle that's going on there there are two things that are going on here:

1: in case of lipa city I was indeed able to select an adm1 entry through our singup form - although only after entering weird stuff, unfortunately I could not reproduce and thus can't bugtraq right now - lets wait for the next example

2: I have the feeling that in some cases we store the adm1 instead of the city - meaning, a member selects a city but while the whole geo stuff is computet we replace the city by the adm1 region id - only happens very rarely and I have no idea why (and if this really happens or if my assumption is wrong)

this needs more testing and especially reporting of any incident in the real world so that we can hunt this down.

comment:3 Changed 9 years ago by crumbking

I'm not sure but if this is related but

I got on

http://www.bewelcome.org/places/Unknown/Unknown/Hong%20Kong

Notice: Trying to get property of non-object in /home/bwrox/www.bewelcome.org/build/places/templates/teaserCountry.php on line 38 > > Unknown > Hong Kong

Places Hong Kong not found

Also if you search for members "hong kong" you find no result even if we have member(s) there

https://www.bewelcome.org/member/laetitia

comment:4 Changed 9 years ago by crumbking

http://www.bewelcome.org/places/CN/Inner%20Mongolia%20Autonomous%20Region

if you click on the city Qiqian as it show up with one member to go to http://www.bewelcome.org/places/CN/Inner%20Mongolia%20Autonomous%20Region/Qiqian

there is no member?

same here:

http://www.bewelcome.org/places/CN/Jiangsu%20Sheng  there should be 2 members but just one shows up.

comment:5 Changed 9 years ago by crumbking

comment:6 Changed 9 years ago by crumbking

  • Milestone changed from new design bugfixing to Future

comment:7 Changed 7 years ago by jeanyves

  • Cc lupochen philipp jeanyves micha jyhegron@… added; lupochen philipp jeanyves micha removed
  • follow_up changed from test to review code
  • Keywords signup added
  • Milestone changed from Future to 0.5.2-short cleanup and framework
  • Priority changed from major to critical

This ticket is still a problem

We have several members who are signing up (and I dodn't know how) in places like "France" or "Chile" or "USA" as cities. This results in several problem at several place: 1) Profile page has missing data 2) Worst problem, thsi people cannot be accepted because they are not displayed one the accepter page (the accepters page wants a city as a PPL place).

The problem exists since a while and still exist on October first

comment:8 Changed 7 years ago by jeanyves

Nota: they are currently at least 40 people with such problems. I am repairing some of them if I have enough information to find back their real city sometim it is posible with the Zip)

comment:9 Changed 7 years ago by globetrotter_tt

  • Milestone changed from 0.5.2-short cleanup and framework to 0.5.6 - bugfixing

comment:10 Changed 7 years ago by planetcruiser

  • Owner changed from philipp to planetcruiser
  • Status changed from new to accepted

comment:11 Changed 7 years ago by planetcruiser

jeanyves: i really have no idea how to reproduce this. hints welcome.

or if you know a user that has this problem, please give me the user id, so i can look at it. i mean, how did you identify the "40 people" with the problem?

comment:12 follow-up: Changed 7 years ago by crumbking

You could check this user:

http://www.bewelcome.org/member/laetitia

comment:13 in reply to: ↑ 12 Changed 7 years ago by planetcruiser

Replying to crumbking:

You could check this user:

http://www.bewelcome.org/member/laetitia

thanks. but she seems to be a fully accepted member already, so i can't reproduce the error

comment:14 Changed 7 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from accepted to closed

partly fixed via https://gitorious.org/bewelcome/rox/commit/6158d5f45e82cb4e0bd42fc612322892ef876b0c

now we can at least see, contact and approve members with problematic location data in the AdminAccepter? tool. note: only admins with scope "All" will see them

until we know how to reproduce this bug i think i can't do much more. a lot of issues in this ticket have been solved. i will close and open a new ticket for the remaining issue with ADM/PPL signups

comment:15 Changed 7 years ago by planetcruiser

new ticket is #1586

comment:16 Changed 7 years ago by globetrotter_tt

Before deploying this to production, we should better notify all volunteers with accepting rights. (bw-announce mailing list?)

comment:17 Changed 7 years ago by planetcruiser

the list does not exist yet, but i just emailed a list of email addresses of all accepting volunteers to globetrotter_tt

the accepters need to think of a way to find out the missing addresses together with the users

Note: See TracTickets for help on using tickets.