Opened 9 years ago

Closed 6 years ago

#1249 closed improve feature (fixed)

Creating a New thread : make the form more simple

Reported by: jeanyves Owned by: jeanyves
Priority: major Milestone: Legacy Resolved
Component: BW Forum Keywords: forum groups
Cc: lupochen

Description

Requested by Micha:

the new thread form propose by default option to define the visibility of the thread and to connect it to a group

1) These options should be be hidden to make the form less heavy (JY: I plan to allow them to be used with a more options link, I hope it is acceptable)

2) when a new thread is created from the group page, the group should be selected by default

Change History (23)

comment:1 Changed 9 years ago by crumbking

  • Milestone changed from unassigned to Rox Framework, Upgrade

comment:2 Changed 9 years ago by micha

1) This is somewhat acceptable but still I would hear pro's and con's against the current visibility options. It doesn't make sense to me to hide forum threads on a personal level. Groups are a perfect way to share certain "views" (hidden or public or whatever). So, actually I would favour to get rid of the visibility option in total.

2) Yep, that's the way it should be.

Let me add other points:

3) Don't offer any group-dropdown-list in the forums at all. If you want to post a thread in a group, you should go to the group page and create it. Everything else creates a mess and unneeded complexity.

4) Show the language-dropdown hidden, too. It maybe has a use-rate of 1/100.

I will think of more.

comment:3 Changed 9 years ago by globetrotter_tt

  • Component changed from unknown to BW Forum

comment:4 Changed 9 years ago by sitarane

5) When posting from a group, the visibility option should be on "group only" by default.

comment:5 Changed 9 years ago by jeanyves

@Sitarane, your point 5) should already work (or there is a bug). There is a default visibility (I don't remember the field name) in groups which should be reused by forum as the current visibility

@Micha about point 4), the problem is that if you don't display the language possibility, there is a hight risk that the used don't see it at all and start to write a post in a language which will not match the current language. It is a difficult issue.
May be an alternative should be to consider that someone who has set up his preferences for english language will always write in english in the forum and so, to not provide by default, the dropdown language choice for forum new thread.

Note that languages possibilties, even if many of us are easy with english, make a lot of sense in such international community, unless we believe that everybody will speak english but this sound elitist. This point is however another discussion.

comment:6 Changed 9 years ago by micha

  • follow_up changed from none to test

About 4): I agree that we should encourage users to use their own language and others to stick to that language in their answer. However I don't think a dropdown-option to choose from will help a lot with that. Categories in the forum and tags will far better reflect the use of a different language. Groups also play an important role here. The language dropdown should only be relevant if you want to add translations for your post and this is and will ever be really the big exception..

Anyway, right now in the latest version on test we show the language possibility already but hide all other options. Can we proceed with that for now and move the current form to production? I'd love to see an improvement online. The current form is still a mess.

comment:7 Changed 9 years ago by globetrotter_tt

The form is not working.

Got an SQL error

MySQL error!

{{{PException

code: 1000 message: MySQL error! file: /var/www/test.bewelcome.org/lib/db/db_statement_mysql.lib.php line: 291

info[0]: Statement: INSERT INTO forums_tags (tag) VALUES ('test') info[1]: 1062info[2]: Duplicate entry 'test' for key 2}}}

comment:8 Changed 9 years ago by globetrotter_tt

Can't we just dump all this translation/language stuff? I haven't seen anybody else using it. I think most people are smart enough to write in english when they expect "worldwide" answers to their posts. If someone feels to write in his native language only, but wants to have it translated in other languages, she can just do it in the same form.

comment:9 Changed 9 years ago by fake51

I am pro dropping the translation/language stuff - I haven't seen any posts for a while translated. I really don't think most people care enough to put that extra work into it - and translating your 2-3 paragraphs of text does take a while

comment:10 Changed 9 years ago by fake51

Apart from that, the current version does look nice

comment:11 follow-up: Changed 9 years ago by jeanyves

Unfortunately I am not a layout specialist and I have not a lot of idea about how to make it good looking and efficient. The layout needs improvment this is sure, this one is a progress.

About translation, I am absolutely pro keeping them. A way to avoid them to create useless disturbance in the layout is to be find, but BeWelcome is supposed to be an international intercultural project, that why translations are so important.

As far as I know, they are no similar website which are allowing to create profile in several langauges and, among the thousand of forum platform, none of them (for what I know) allow to post in several languages. This is is something which should make BeWelcome a real new thing and should allow to make the difference.

Of course the most involved people in BeWelcome are easy with english and are the one who are the most active in the forum, but BW is, for my opinion, not to be targetted for english speaking people.

20% of people in BeWelcome are french, the reason is that BW is since its beginning full french translated. Am I wrong to believe that offering translations everywhere is one of the keys of BeWelcome ? If so, I must figure this very quickly.

Nota: of course translations make things more complex, result in heavier programs, more bugs, etc,etc ... But if we don't want them, we seriously should consider using an already existing forum system, they are plenty of them

comment:12 in reply to: ↑ 11 Changed 9 years ago by globetrotter_tt

Replying to jeanyves:

20% of people in BeWelcome are french, the reason is that BW is since its beginning full french translated. Am I wrong to believe that offering translations everywhere is one of the keys of BeWelcome ? If so, I must figure this very quickly.

Of course it's good to have the website translated, but i doubt that it makes much sense to have the user content translated, especially by other persons. If somebody wants to write a forum post, blog entry, etc only in french - let it be so, no need to translate it on bewelcome side.

comment:13 Changed 9 years ago by fake51

I checked the use of the forum translations - they are not very used in any way, and it seems that a lot of the 'translations' are actually using wrong language id, such as translations marked as German but containing English.

I think forum translations could be useful, I just don't think they will be useful for us. I don't think that having a forum where translations can be added is really that big of an attraction for the audience - if it was a truly awesome feature, I would expect to have seen it used much more.

Having the site translated, on the other hand, is an obvious bonus.

comment:14 Changed 9 years ago by micha

I can only agree on what Matthias and Peter said. Translations make sense to me in general and I'm glad we offer lots of different languages. But aiming at translating all user's content is totally unrealistic. But for now I would just move the new form forward. I'd check the bug, Matthias mentioned and then move it online..

comment:15 Changed 9 years ago by micha

@matthias: I couldn't reproduce your error. Can you? Would be good to get a detailed bug description here.

comment:16 Changed 9 years ago by globetrotter_tt

What i did:

  1. Writing a title "test entry"
  2. Writing a text "blah blah blah"
  3. Writing tag "test" and clicked on the suggested link "testing"
  4. Choosing geo tag "Europe->Germany->Berlin->Berlin
  5. Language: "deutsch"

I was able to reproduce the bugs again with this settings, and my suggestion is that there is something wrong with the tags.

comment:17 follow-up: Changed 9 years ago by micha

In fact, this bug seems to have something to do with the language you choose. Try "English" and you won't get that error. I'll check it out further. Thanks, Matthias.

comment:18 in reply to: ↑ 17 Changed 9 years ago by globetrotter_tt

Replying to micha:

In fact, this bug seems to have something to do with the language you choose. Try "English" and you won't get that error. I'll check it out further. Thanks, Matthias.

...another good reason to drop the language stuff

comment:19 Changed 9 years ago by micha

I think i fixed it. Wanna try?

comment:20 Changed 9 years ago by globetrotter_tt

Sorry, but i have to report another MySQL error. This time i posted out of a group (cooking), Tags: "xmas, christmas" Language: "armenian"

MySQL error! PException

code: 1000 message: MySQL error! file: /var/www/test.bewelcome.org/lib/db/db_statement_mysql.lib.php line: 291

info[0]: Statement: select * from groups where id={$groupsforum} info[1]: 1064 info[2]: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '}' at line 1

comment:21 Changed 9 years ago by micha

fixed that. try again?

comment:22 Changed 7 years ago by globetrotter_tt

  • follow_up changed from test to none

comment:23 Changed 6 years ago by TimLoal

  • Milestone changed from Rox Framework, Upgrade to Legacy Resolved
  • Resolution set to fixed
  • Status changed from new to closed

Resolved

Note: See TracTickets for help on using tickets.