Opened 9 years ago

Closed 6 years ago

#1276 closed bug (fixed)

Street doesn´t change on Address Update

Reported by: neo82 Owned by: fake51
Priority: major Milestone: new design bugfixing
Component: BW Profile Keywords:
Cc:

Description

when changing your address only the city data is updated. This leads to inconsitent data: the old street in the new town.

Please also check for zipcode and telefon

Change History (6)

comment:1 Changed 9 years ago by fake51

I have no trouble changing my address through edit profile. If you're changing your location through setlocation, then seeing only city data change is expected - it's only supposed to change city/country location.

comment:2 Changed 9 years ago by neo82

  • Priority changed from critical to major

ok, your´re rigth Peter. The problem is after changing the location and clicking 'submit form' the profile page should be shown. At the moment it's not like that and the go press the back button of your browser, the location is updated but the street (if you entered a new one before) isn't. Thats a usablity flow bug not a real bug

comment:3 Changed 9 years ago by fake51

  • Milestone changed from unassigned to new design bugfixing
  • Owner set to fake51

So, if I redirect 'set location' to edit profile after updates, this should be fixed?

comment:4 Changed 9 years ago by neo82

from the usability point yes. I don´t know if data you entered before in the profile page is lost then or not (but I guess you know how to handel that ;))

comment:5 Changed 9 years ago by crumbking

I would say we need this:

  1. while clicking on "update my profile" we "automatic save" the edit profile form.
  2. you set a new location and hit the submit form button in http://www.bewelcome.org/setlocation
  3. you will be redirect to the edit my profile page with an anker at location
  4. we add a green message above the location "Thanks! Your new location is saved! Please also make sure you update your street, house number and zip code! (or somthing like that)

btw. a small bug happenss while updating your house number:

if you leave it empty you can save without problems. (but the old data show up after saving)

If you leave it empty: Same warning should show up like you get when you leave street/zip empty.

comment:6 Changed 6 years ago by TimLoal

  • Resolution set to fixed
  • Status changed from new to closed

Resolving due to age and lack of interest, in recent years.

Please create a new ticket and link to this historical ticket, if you discover bW.org has continuing issues with this issue.

bW Housekeeping

LnP

Note: See TracTickets for help on using tickets.