Opened 9 years ago

Closed 7 years ago

#1279 closed bug (fixed)

Address truncated at single quote during signup

Reported by: jeanyves Owned by: planetcruiser
Priority: blocker Milestone: 0.7
Component: BW General Keywords: signup quote
Cc: micha, lupochen

Description (last modified by planetcruiser)

issue:

  • if single quotes (') are used in name or address during signup, strings appear truncated in profile later

clues:

  • strings are displayed fine during signup steps, only after they are written to the database they are truncated
  • also check address update in profile for same bug

original ticket text:

It results in a generic exception

Input should be escaped

This is critical bug

Change History (10)

comment:1 Changed 9 years ago by jeanyves

  • Owner set to jeanyves

comment:2 Changed 9 years ago by jeanyves

  • follow_up changed from none to test on alpha

comment:3 Changed 9 years ago by jeanyves

  • Owner changed from jeanyves to Micha

I just realized that in fact this bug was probably solved by the urlencode in enc.inc.php (it was done on admincrypted value and not on membercrypted value, this was what was creating the bug).

Since while fixing the line breaks and the \ problem in profile data, I moved it in prod (it has been successfuly tetsed in Alpha). So I think this also solve part of the problem in Signup. It is possible to signup with quote in FullName? (the system doesn 't generate an exception)

But the whole fix is still to be moved since they are still missing escaping which I have also fixed in the signup.model. It works in alpha, The problem is that I miss the overview with the new MOD_MAIL thing (last time I tried to move it on prod I was to revert).

It is to move in production (and to b tested there)

comment:4 Changed 9 years ago by globetrotter_tt

Has anybody tested this already?

comment:5 Changed 7 years ago by jeanyves

  • Cc micha lupochen added; micha lupochen removed

There is still a bug to fix

there is no more exception if someone signup in avenue de la toison d'or it result in avenue de la toison d

comment:6 Changed 7 years ago by globetrotter_tt

  • follow_up changed from test on alpha to review code

comment:7 Changed 7 years ago by planetcruiser

  • Description modified (diff)
  • Milestone changed from unassigned to 0.7
  • Owner changed from Micha to planetcruiser
  • Priority changed from critical to blocker
  • Status changed from new to accepted
  • Summary changed from Signup sucks if quote are use if Name, first name or address to Address truncated at single quote during signup

not fixed yet, street names with single ticks (') are truncated.

i will look into this

comment:8 Changed 7 years ago by planetcruiser

comment by Leonardo Boselli on dev list:

Are data stored as unicode ?
if so is possible to automatically transate on input «'» U+0027 to «’»

U+2019 ??

comment:9 Changed 7 years ago by planetcruiser

looking at this now

comment:10 Changed 7 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from accepted to closed

fixed via:

this fix also prevents exceptions that occurred when including a single quote into any of the chat or phone fields. did no one ever test this??

deployed and tested on alpha

Note: See TracTickets for help on using tickets.