Opened 9 years ago

Closed 7 years ago

Last modified 7 years ago

#1318 closed improve feature (fixed)

fetchback ??

Reported by: bikepunk Owned by: planetcruiser
Priority: trivial Milestone: 0.5.6 - bugfixing
Component: BW Wiki Keywords: fetchback
Cc:

Description

BW Rox version: user agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; el; rv:1.9.1.4) Gecko/20091016 Firefox/3.5.4 request uri: http://www.bewelcome.org/wiki/info/BeVolunteer

this is about any "info" wikipage.

we've got a "fetchback" button. I've tried to understand what is meant for and not any on the dictionnary I've checked were able to tell me the meaning of "fetchback"... that's anoying. Is it a "report" fontion or an "undo" ?

please, make it clear and use an existing word.

thanks in advance

Change History (12)

comment:1 Changed 8 years ago by globetrotter_tt

  • Component changed from BV Wiki to BW Wiki

comment:2 Changed 7 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from new to closed

you are right, this is a wrong term. it's the "revert" function.

fixed via https://gitorious.org/~meinhard/bewelcome/meinhard-fixes/commit/51dbe40d4d1fdf59f5a2aa650fdee702ad4abfd3 - only needs to be deployed now.

comment:3 Changed 7 years ago by planetcruiser

  • Resolution fixed deleted
  • Status changed from closed to reopened

did not make it into production yet

comment:4 Changed 7 years ago by planetcruiser

  • Owner set to planetcruiser
  • Status changed from reopened to assigned

comment:5 Changed 7 years ago by globetrotter_tt

It would be even better to make the link translatable.

comment:6 Changed 7 years ago by globetrotter_tt

  • Milestone changed from unassigned to 0.5.6 - bugfixing

comment:7 Changed 7 years ago by planetcruiser

  • Owner changed from planetcruiser to globetrotter_tt

note: my fix was bogus, because the array keys should not be changed. the renaming needs to be done in the translation tool i suppose

comment:8 Changed 7 years ago by globetrotter_tt

  • follow_up changed from none to move to alpha
  • Priority changed from critical to trivial

I have made the buttons "browse and "fetchback" translatable:

https://gitorious.org/bewelcome/rox/commit/b431ee3ac6447efd549b5a55afe25d95bb1c9b07

I would rename them to "browse this version" and "edit this version"

comment:9 Changed 7 years ago by globetrotter_tt

  • follow_up changed from move to alpha to test on alpha

comment:10 Changed 7 years ago by planetcruiser

  • Owner changed from globetrotter_tt to planetcruiser
  • Status changed from assigned to accepted

will test this

comment:11 Changed 7 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from accepted to closed

sorry if i just force my way in, but i changed the translation of the buttons to "View" and "Revert...", because simplicity is king. ;)

i think a "View" button on a version box in the page history explains itself. "Browse" didn't really hit the nail, because browsing usually means looking at a number of things, not just one. actually the "Page info" button at the bottom of the wiki page should be called "Browse versions", but that's another story. ;)

"Edit this version" also was not precise imho, because the button will revert to the selected version after offering the possibility to edit it. so it should be called "Revert". and a "..." in interfaces usually indicates that a dialogue will follow after clicking the button or menu item. hence i went for the "Revert..." label.

is that cool with everyone? if so, the french translations need to be updated as well. i wonder who could do this.. ;)

comment:12 Changed 7 years ago by bikepunk

cool for me,

the french version says something like : "View this verison" for "View" and "Modify this version" for "Revert" it's not litteral but it's fine for me (it's actually quite clear).

Note: See TracTickets for help on using tickets.