Opened 9 years ago

Closed 8 years ago

Last modified 6 years ago

#1344 closed bug (fixed)

Problem with adminaccepter

Reported by: jeanyves Owned by:
Priority: blocker Milestone: Legacy Resolved
Component: BW Admin Keywords: Accepting
Cc: fake51

Description

There is a problem to fix in ermegency:

Accepting or sending a needmore to a pending member results in 

Fatal error: Class 'Swift_Message_Encoder' not found in /home/bwrox/www.bewelcome.org/htdocs/bw/lib/mailer.php on line 323

The status of the member seems to be changed but the message is not delivered.

The problem with the missing Class is the one to solve but the status of the member is to be updated only after the message is sent (the result of the mail sent is to be tested or the exception is to stop the process)

Change History (6)

comment:1 Changed 9 years ago by jeanyves

Addition:

For the Status updated and the mail not sent:, the problem is that the status is updated before trying to send the mail, a very bad Idea, I change this immediately in test

comment:2 Changed 9 years ago by fake51

Dammit, didn't see that the old bw code uses an outdated version of Swift. I'll roll the changes back and update the bw/lib/mailer.php to use the proper version of Swift

comment:3 Changed 9 years ago by fake51

I've rolled the code back on production, I'll see about updating the mailer to make it work properly

comment:4 Changed 9 years ago by jeanyves

Ok Peter, for myself I just change the order of adminaccepter action: try to send mail and then update (+ I remove some dead code, because it was obviously inapropriated, no need to confuse the peopel who work on new admin accepter)

I will restore the members to their previous status and will re-run the accepting

comment:5 Changed 8 years ago by globetrotter_tt

  • Resolution set to fixed
  • Status changed from new to closed

comment:6 Changed 6 years ago by TimLoal

  • Milestone changed from unassigned to Legacy Resolved
Note: See TracTickets for help on using tickets.