Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#1346 closed bug (fixed)

Forum notification subscribe/ unsubscribe link

Reported by: jeanyves Owned by: jeanyves
Priority: minor Milestone: Legacy Resolved
Component: BW Forum Keywords: forum notification
Cc:

Description

The link from the forum page to subscribe unsubscribe is broken:

http://www.bewelcome.org/forumssubscribe/thread/35 for example instead of http://www.bewelcome.org/forums/subscribe/thread/35

(there is a missing slash).

I fixed it in forums/topic.php on test can someone check it and say it it looks better ?

Nota: this has nothing to do with groups notifications

Change History (8)

comment:1 Changed 9 years ago by globetrotter_tt

  • follow_up changed from test to move to alpha
  • Owner set to globetrotter_tt

Hmm i don't get notifications on test. How should we test it? But as you only added a slash it should work.

comment:2 Changed 9 years ago by jeanyves

For it to work on test we would need a cron runing mailbot on a periodic basis.

But I don't think we should allow test to send mail. The problem is that since test is public (no restriction to connect and to use it), i can imagine that someone could use it for evil purpose with mail. The scenario could be the following:

  • Someone log on test with a known account and teh generic password (easy to guess, it can be found in several volunteer chat)
  • He change the mail address with the one he wants to target
  • He connect with another accound and send a message to this target

The result: test.bewelcome.org could be used to anoyed someone

Thats why I never really try to have mailbot running on test (but if someone has a better proposition, no problem).

So to test the forum notification it has to be moved on Alpha where mailbot can be run manually (and it display a bit about what it does) with an admin account using h t t p : / /alpha.bewelcome.org/bw/mailbot.php

comment:3 Changed 9 years ago by fake51

A better solution would be that we install fakemail http://www.lastcraft.com/fakemail.php and then just allow for browsing of those saved mails. Would make things a whole lot easier and means we don't have to compromise alpha because we don't know if something works or not

comment:4 Changed 9 years ago by jeanyves

  • Owner changed from globetrotter_tt to jeanyves

I look to the fakemail page, it looks like a good solution for the test environment.

Ideally, in addition we will also need a php page to allow each user of test to see which mail where effectively attepted to be delivered

comment:5 Changed 9 years ago by fake51

Yup, the emails should be stored in a place where you can browse them afterwards, so you know what was delivered to where and when.

comment:6 Changed 9 years ago by globetrotter_tt

  • follow_up changed from move to alpha to test on production
  • Resolution set to fixed
  • Status changed from new to closed

I assume it's fixed. The unsubscribe links from the latest forum notifications did all work for me.

comment:7 Changed 8 years ago by globetrotter_tt

  • follow_up changed from test on production to none

comment:8 Changed 6 years ago by TimLoal

  • Milestone changed from unassigned to Legacy Resolved
Note: See TracTickets for help on using tickets.