Opened 9 years ago

Closed 7 years ago

Last modified 6 years ago

#1347 closed bug (fixed)

When you send a message to someone and choose to join your picture, it has no effect

Reported by: jeanyves Owned by: jeanyves
Priority: major Milestone: Legacy Resolved
Component: BW Mail Keywords: picture mailbot
Cc:

Description

The picture is not joined

The problem is in mailbot, the PictureInMail internal function of mailbot has a big stupide bug: it doesn't return its result

I am preparing a fix in test

Change History (7)

comment:1 Changed 9 years ago by jeanyves

  • follow_up changed from test to move to alpha

I made a fix for it on mailbot.php.

I tested it with Florian, I have been able to see that messages.JoinMemberPict is set to yes if the member tick the option but not able to see if the picture was delivered because test env doesn't allow for mailbot to work (thsi si not a problem, and may be it is good, this way we are sure no one will use test.bw.org to send fake messages).

The bug was in mailbot which doesn't return a value for the PictureMail function

So, I think it is ready  to be tested on alpha, but it needs coordination. The way to test it is to send a message to someone ticking the add picture box and to reun manually mailbot.php from alpha before the real mailbot runs (via cron) and process the mail queue.

I need help to test iit

comment:2 Changed 9 years ago by jeanyves

  • follow_up changed from move to alpha to test on alpha

I run test on Alpha with Florian. Positive in that way that the picture is now included.

The layout is as it was before, but this is ugly. Not worst than witout the included picture, but bad if we consider the usual layout of BW.
If someone could help to improve here, I think this is important

comment:3 Changed 9 years ago by globetrotter_tt

Which file is needed to change the layout?

comment:4 Changed 9 years ago by jeanyves

Everything is to do

Currently mailbot format a rough message and send it "as it is".

Note that mailmot.php is not roxed at all. I don't know how to format a message in an acceptable way.

Note that the way Micha did it for the accepter notification (sent by signup) looks to me a good way (except for few details inside but this is not the point). I mean that the method used by signup is probably the good one, mail bot should do the same.

May be we can talk on chat about it

comment:5 Changed 9 years ago by fake51

I started a new tool for emails to keep them in one place and allow separation of business logic and email templating. It's in /tools/email/ - the new admin tools (accepter mainly) use them to a degree, so you can have a look at how that works. Should be easy to setup messages using this tool and sending them is a breeze as well. Will be a whole lot easier if we create a bwrox version of the mailbot but that shouldn't be too long in the making either, as there's something to work from.

comment:6 Changed 7 years ago by jeanyves

  • Resolution set to fixed
  • Status changed from new to closed
  • version set to production

I confirm the problem has been solved since I have seen Sigurdas picture in a message he sent me thru BW

I'm going to close this ticket

comment:7 Changed 6 years ago by TimLoal

  • Milestone changed from unassigned to Legacy Resolved
Note: See TracTickets for help on using tickets.