Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1435 closed bug (fixed)

Invite member - bug using chrome/chromium

Reported by: crumbking Owned by: coroa
Priority: minor Milestone: 0.5.4 - bugfixing
Component: BW Layout Keywords: personal startpage
Cc: lupochen

Change History (16)

comment:1 Changed 7 years ago by globetrotter_tt

  • Owner set to globetrotter_tt
  • Status changed from new to accepted

comment:2 Changed 7 years ago by globetrotter_tt

  • Component changed from unknown to BW Layout
  • follow_up changed from none to test on alpha
  • Milestone changed from unassigned to 0.5.3 - bugfixing

comment:4 Changed 7 years ago by planetcruiser

the problem still occurs for me on alpha

comment:5 Changed 7 years ago by globetrotter_tt

  • Milestone changed from 0.5.3 - bugfixing to 0.5.4 - bugfixing

comment:6 Changed 7 years ago by globetrotter_tt

  • Cc lupochen added

hmmm. Chromium shows me that the link to the stylesheets is:

http://www.bewelcome.org/invite/styles/css/minimal/minimal.css

This is of course not right, but haven't figured out how to change it.

Maybe someone else can help here?

comment:7 follow-up: Changed 7 years ago by coroa

all revolves around the baseuri.

according to chromiums dev tools:
<base id="baseuri" href="">

according to wireshark this is not true:
<base id="baseuri" href="http://localhost/rox/htdocs/" />

interestingly reloading the page again, gives the expected result.

comment:8 in reply to: ↑ 7 Changed 7 years ago by coroa

according to chromiums dev tools:
<base id="baseuri" href="">

ah in the network tab of the dev tools chromium actually still shows the complete tag.

comment:9 Changed 7 years ago by coroa

fun fact: happens if and only if there is a string href="http://localhost/rox/htdocs/whatever" in the messages' text body, it must be with double quotes. single quotes don't count. wtf?

comment:10 Changed 7 years ago by coroa

ups, we found a very very unlikely chromium bug it seems, i put up the minimal example i could come up with to trigger it on

http://www.fsr.physik.uni-potsdam.de/chromium_bug/chromium_bug_get.html
or
http://www.fsr.physik.uni-potsdam.de/chromium_bug/chromium_bug_post.php

where do we want to go from here?

comment:11 Changed 7 years ago by coroa

i filed a bug report with chromium: http://code.google.com/p/chromium/issues/detail?id=104924

how do we work around the issue? we could for a start write the url in the textarea with single quotes. Or without quotes at all.

comment:12 Changed 7 years ago by globetrotter_tt

  • Owner changed from globetrotter_tt to coroa
  • Status changed from accepted to assigned

comment:13 Changed 7 years ago by crumbking

Yeah lets work around the issue. We can't wait for google fixing this :)

comment:14 Changed 7 years ago by coroa

  • follow_up changed from test on alpha to release

ok, fixed on alpha. by commit 890777b.

comment:15 Changed 7 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from assigned to closed

works fine now

comment:16 Changed 7 years ago by globetrotter_tt

  • follow_up changed from release to none
Note: See TracTickets for help on using tickets.