Opened 7 years ago

Closed 4 years ago

#1478 closed improve feature (wontfix)

Advanced search moving the display window ABOVE the SEARCH button

Reported by: jeanyves Owned by:
Priority: major Milestone: unassigned
Component: BW Search Keywords: easy 1.4 1.5 welen
Cc: planetcruiser

Description

In the !Searchmembers page, when you click on the advanced search option a new "widget" with additional options is display.

The problem is that this is confusing since this widget is UNDER the Search button.

Ideally, the widget should go ABOVE it.

Who can tell me how to do this small improvment ?

Change History (11)

comment:1 Changed 7 years ago by crumbking

I suggest to add search button above and below the advanced fields...

crumbking

comment:2 Changed 6 years ago by jsfan

  • Milestone Future deleted

Milestone Future deleted

comment:3 Changed 6 years ago by shevek

  • Cc planetcruiser added
  • Milestone set to unassigned

Actually I like the way it is now. But one fix for 1.2 by planetcruiser added a lot of white space between search field and advanced options. That should be fixed...

comment:4 Changed 6 years ago by planetcruiser

@shevek: i am open for ideas about the white space, as long as the whole page does not jump around again when searching ;)

about this ticket here: wontfix and welen?

comment:5 Changed 6 years ago by shevek

@planetcruiser: Shouldn't it be enough to move the div for the loading message behind the one for the advanced options?

If so I'd like to see that fixed in Rox if not I would add that to my search update.

comment:6 Changed 6 years ago by planetcruiser

i looked at it again and remembered why i set a fixed height for the searchstatus floatbox: the "empty space" is filled with result count and pagination as soon as you get results.. so it's only empty before you search. i don't really see a way around this.

anyway, this is not what this ticket was about.

comment:7 Changed 6 years ago by shevek

  • Keywords easy 1.4 1.5 welen added

The problem is that the div 'searchstatus' is included in the teaser while it should be included after the filter. Should be easy to move.

comment:8 Changed 6 years ago by planetcruiser

you should really open a new ticket for this, because whoever takes this task will be very confused, because it is not mentioned either in ticket title or ticket description.

anyway, i don't understand how moving the spinner will help with the initial blank space though. or do you want to move the pagination/counter as well? please explain. :)

comment:9 Changed 6 years ago by shevek

Actually I wanted to close this ticket anyway ;-)

I have no problem with the initial blank space I was always annoyed by the way the map jumped around. So that's fine.

But if you open the advanced search options a JS sets the display:none to display:block for the filter options. These are shown in a div below the spinner. With the white space for the spinner this looks ugly. If the spinner is moved behind the div for the advanced options that would be fixed.

comment:10 Changed 6 years ago by planetcruiser

ah, now i get it! you want to move the spinner and pagination *underneath* the advanced search options. makes sense of course.

comment:11 Changed 4 years ago by crumbking

  • Resolution set to wontfix
  • Status changed from new to closed

With the new search (bw/search) this is under the advance search.

Note: See TracTickets for help on using tickets.