Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1486 closed improve feature (fixed)

Turn off messaging restriction after sign-up

Reported by: jeanyves Owned by: planetcruiser
Priority: major Milestone: 0.5.5 - bugfixing
Component: BW Mail Keywords: verification contact member
Cc:

Description (last modified by planetcruiser)

Issue:

  • Newly signed up users can not send messages to other users until their profile has been approved

Solution:

  • According to a vote (winner: proposal 1b) this restriction will be lifted, users can send messages straight after sign-up

Original ticket text:

This is extract from a forum thread I created when Trac was not stable:

Provide a preference allowing any member to choose if he allows or not allows interaction with “no yet fully accepted” people

When a newbie has just signup, he can already send message but only to all the members who are allowing “not yet fully accepted people", for others he has a message that he has to wait a bit and be sure he provided complete Name and address information. If a member has already first contacted a not “fully accepted” newbie, this newbie is allowed to contact him (Because we can imagine members wanting to contact newbie and expecting to expect answer)

Benefit I see: The accepters process does not refrain newbies to contact BW people who have chosen the "allow interaction with not yet fully accepted". This should be the way for the BW members asking in CS (or anywhere in the group "I host strangers in facebook" for example) to be contacted via BW. I think it is easy (not a lot of work, not a lot of risks) to implement in current BW, at least I can reasonably see the few changes it implies

It could be even more extended: more options (that CS will never provide IMHO because this is anti-commercial):

A “I allow any websurfer to contact me via BW for a couch request”: New Option allowing people who are not member, providing they just fill their email for the answer, any BW member with public profile who have ticked such preference

B “I agree to be contacted by brand new members regardless if their information for name and addresses are completed” : This is the answer for removing the new member verification

C “I only want to be contacted by BW member who have, like me, provided full information for name and address” : member can only receive request from fully accepted member. This is the current way it works.

D “I want my new contact to be accepted and to prove that they have read my profile by filling some captcha they can only find on my profile page”: this is a restrictive option for paranoid or very demanding host

for now, the idea is to keep the C (current situation) and provide the B

The A IMHO whould be a brand new concept in the hospex work, to be used by experimented peopleThe D goes in the other direction that the one this discussion expects, but keep in mind all these complains we have read in various places "I dislike to be contacted with an unpersonal hey dude, I am coming tommorow in your city, can you host me? I want people to read my profile before"

Change History (19)

comment:1 Changed 7 years ago by jeanyves

In the long (and passionate) discussion http://www.bewelcome.org/forums/s1362 this system I proposed is confirmed to work.

Nota: it was not done on test, without ticket, but done on Alpha. The preference is also visible on production because this is the same database.

I think it will be good to move it on production (the remove member verification is another subject)

comment:2 Changed 7 years ago by globetrotter_tt

  • Milestone changed from unassigned to 0.5.3 - bugfixing

comment:3 Changed 7 years ago by globetrotter_tt

  • Milestone changed from 0.5.3 - bugfixing to 0.5.4 - bugfixing

comment:4 Changed 7 years ago by crumbking

How could we test the ticket? I checked the preferences on alpha. Some new user without address and real name should contact me.

comment:5 Changed 7 years ago by globetrotter_tt

A different decission was taken.

http://www.bewelcome.org/wiki/s1362-Removing_the_new_member_verification

We should act acccording to it.

Last edited 7 years ago by globetrotter_tt (previous) (diff)

comment:6 Changed 7 years ago by globetrotter_tt

  • Milestone changed from 0.5.4 - bugfixing to 0.5.5 - bugfixing

comment:7 Changed 7 years ago by planetcruiser

  • Cc meinhard planetcruiser removed
  • Description modified (diff)
  • Summary changed from Ticket regularisation fro modification for skipping verification step and beeing able to contact members who set their preferences in this way to Turn off messaging restriction after sign-up

comment:8 Changed 7 years ago by planetcruiser

  • Owner changed from jeanyves to planetcruiser
  • Status changed from new to assigned

i received the changed files from jy, will look into merging

comment:9 follow-up: Changed 7 years ago by planetcruiser

this is jy's patch: https://gitorious.org/bewelcome/rox/commit/aaea60b64e71966a463af8735b7fb0755b2f8f6b (deployed to alpha already)

with this patch member's still need to select "All members" in their "Which kind of members can contact you ?" preferences.

but if i understand solution 2 on http://www.bewelcome.org/wiki/s1362-Removing_the_new_member_verification correctly, new members should always be able to contact all members. so, what to do?

  1. change everyone's preference to "All members" via sql query? that's a bit evil though..
  2. leave it like this, and just inform people that this preference is now working properly, i.e. by newsletter and community blog post

comment:10 follow-up: Changed 7 years ago by globetrotter_tt

But the decission was for Proposition 1b: Progressive dumping

so all what needs to be done is changin the status of a new member after signup from pending to active or?

Last edited 7 years ago by globetrotter_tt (previous) (diff)

comment:11 Changed 7 years ago by globetrotter_tt

Ah no, sorry. It's written:

"We turn off the restriction but keep reviewing for three month. If after that period no increase in spam has occurred, we stop the reviewing altogether."

So when reviewing stays for three month, status after signup should be "pending"

Last edited 7 years ago by globetrotter_tt (previous) (diff)

comment:12 in reply to: ↑ 9 Changed 7 years ago by crumbking

Replying to planetcruiser:

this is jy's patch: https://gitorious.org/bewelcome/rox/commit/aaea60b64e71966a463af8735b7fb0755b2f8f6b (deployed to alpha already)

with this patch member's still need to select "All members" in their "Which kind of members can contact you ?" preferences.

but if i understand solution 2 on http://www.bewelcome.org/wiki/s1362-Removing_the_new_member_verification correctly, new members should always be able to contact all members. so, what to do?

  1. change everyone's preference to "All members" via sql query? that's a bit evil though..
  2. leave it like this, and just inform people that this preference is now working properly, i.e. by newsletter and community blog post

I would go for B. But we should make sure that a new member who write to a member with preference "not all members" gets a "sorry you tried to contact a member who prefers to be contacted only by people with full address" or something similar ;)

Last edited 7 years ago by crumbking (previous) (diff)

comment:13 follow-up: Changed 7 years ago by globetrotter_tt

Neither A nor B. We only need to allow pending members to write messages.

comment:14 in reply to: ↑ 13 Changed 7 years ago by planetcruiser

Replying to globetrotter_tt:

Neither A nor B. We only need to allow pending members to write messages.

but what about people that explicitly only allowed "Approved members" to contact them? will we just ignore their preference without letting them know? i would feel very uncomfortable with that.

according to the db 14308 members have set "Approved members", only 411 have set "All members".

either way, if we allow pending members to send messages without any restrictions we need to remove the "Which kind of members can contact you ?" part from the preferences.

comment:16 in reply to: ↑ 10 ; follow-up: Changed 7 years ago by planetcruiser

Replying to globetrotter_tt:

But the decission was for Proposition 1b: Progressive dumping

so all what needs to be done is changin the status of a new member after signup from pending to active or?

argh, you are right. how could i not see this? :) this ticket is in fact invalid, because there will not be a "Pending" user status any longer. so the whole preference will be obsolete

comment:17 in reply to: ↑ 16 Changed 7 years ago by planetcruiser

Replying to planetcruiser:

Replying to globetrotter_tt:

But the decission was for Proposition 1b: Progressive dumping

so all what needs to be done is changin the status of a new member after signup from pending to active or?

argh, you are right. how could i not see this? :) this ticket is in fact invalid, because there will not be a "Pending" user status any longer. so the whole preference will be obsolete

no, wait, according to the vote we will still review new members for 3 months, but allow them to send messages straight away. so the 'Pending' status stays for now. darn, this is complicated! :)

comment:18 Changed 7 years ago by planetcruiser

  • follow_up changed from review code to test on alpha
  • Resolution set to fixed
  • Status changed from assigned to closed

messaging of pending members allowed via https://gitorious.org/bewelcome/rox/commit/c355c00e763f59d40436ec3ff5eb707b7916a8a6

tested on alpha with 1 new pending user

comment:19 Changed 7 years ago by planetcruiser

"Which kind of members can contact you ?" preference deactivated via db update

Note: See TracTickets for help on using tickets.