Opened 10 years ago

Closed 9 years ago

#150 closed bug (worksforme)

Errors on pages if not logged in (no IdMember / Username)

Reported by: midsch Owned by: jaliste
Priority: major Milestone: 0.1.4
Component: BW General Keywords: easy, hot
Cc:

Description (last modified by philipp)

Server: http://test.bewelcome.org/ and http://alpha.bewelcome.org/ IF NOT LOGGED IN:

Notice: Undefined index: IdMember? in /var/www/test_html/modules/user/lib/user.lib.php on line 176
Notice: Undefined index: Username in /var/www/test_html/templates/apps/rox/teaser_main.php on line 32

Change History (20)

comment:1 Changed 10 years ago by philipp

  • Description modified (diff)

comment:2 Changed 10 years ago by philipp

  • Description modified (diff)

comment:3 Changed 10 years ago by philipp

  • Component changed from BV Forum to BW General

comment:4 Changed 10 years ago by jaliste

What we should do in this case?
Clearly the main rox web page is for logged users!!!!! Why test.bw.org/ is not the home page? we could just do the
Home link to go to test.bw.org/ when the user is not logged in and that will fix this.

What do you think?

comment:5 Changed 10 years ago by philipp

either we point the link for not logged in users to test.bw.org as you suggested or we don't display it at all (which would be preferable)

I can't reproduce the second error with the lost password. maybe this has been solved now?

comment:6 Changed 10 years ago by philipp

  • Keywords easy hot added

comment:7 Changed 10 years ago by philipp

  • Milestone changed from 0.1-outreach-release to 0.1.1-outreach-bugfixing

comment:8 Changed 10 years ago by jaliste

  • Milestone changed from 0.1.1-outreach-bugfixing to 0.1-outreach-release
  • Owner set to jaliste
  • Status changed from new to assigned

Taking. After asking the mailing list, I will erase the home menu item when the user is not logged in.

comment:9 Changed 10 years ago by micha

Well go ahead, José! It's the last bug on the list ;)

BeReady? to celebrate!

comment:10 Changed 10 years ago by anonymous

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in [3294]. Now we only show the "home menu" when the user is logged in.

comment:11 Changed 10 years ago by steinwinde

  • Resolution fixed deleted
  • Status changed from closed to reopened

This bug is not fixed. E. g. start with the startpage http://test.bewelcome.org, click on "Signup" and click on "Home". You get these messages:

"Notice: Undefined index: IdMember? in /var/www/test_html/modules/user/lib/user.lib.php on line 176"

"Notice: Undefined index: Username in /var/www/test_html/templates/apps/rox/teaser_main.php on line 32"

Additionally you get a title "Recent visitors of your profile". But you're not logged in.

comment:12 Changed 10 years ago by steinwinde

  • Resolution set to fixed
  • Status changed from reopened to closed

Hopefully fixed with r3295.

comment:13 Changed 10 years ago by tobixen

This error is still present both on alpha and test. Going i.e. to http://alpha.bewelcome.org/main without being logged in will cause errors.

comment:14 Changed 10 years ago by tobixen

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:15 Changed 10 years ago by jaliste

  • Status changed from reopened to new

This bug was closed because we have no links to rox/main when the user is no logged in. But you are right, we should change the behavior of main to redirect to start if the user is no logged in.

comment:16 Changed 10 years ago by jaliste

  • Status changed from new to assigned

comment:17 Changed 10 years ago by steinwinde

  • Milestone changed from 0.1-outreach-release to 0.1.1-outreach-bugfixing

As this is not release critical for our first release, I correct the milestone.

comment:18 Changed 9 years ago by micha

  • follow_up set to none
  • Milestone changed from 0.1.1-outreach-bugfixing to 0.1.2 - more improvements & bugfixing

comment:19 Changed 9 years ago by feuerdaemon

  • freq_reported set to 1
  • show_on_bw set to 0

I've just tryed to reproduce this error. I didn't get any errors on test.bw.

comment:20 Changed 9 years ago by philipp

  • Resolution set to worksforme
  • Status changed from assigned to closed

can't reproduce either, closing

Note: See TracTickets for help on using tickets.