Opened 7 years ago

Closed 7 years ago

#1565 closed bug (fixed)

Second name can not be added or removed, post code can not be added

Reported by: planetcruiser Owned by: planetcruiser
Priority: blocker Milestone: 0.5.6 - bugfixing
Component: BW Profile Keywords:
Cc:

Description (last modified by planetcruiser)

Issue:

  • If you have no second name in your profile, you can not add one
  • If you have a second name in your profile, you can not remove it

Reproduce:

  1. Edit your profile
  2. Add a second name (if you don't have one)
  3. Save profile
  4. Edit profile again
  5. Second name does not appear

Solution:

  1. Show second name if it was added
  2. Show no second name if it was removed

Clues:

Change History (9)

comment:1 Changed 7 years ago by planetcruiser

  • Milestone changed from unassigned to 0.5.6 - bugfixing

should be easy to fix, just needs checking where in the insert chain the second name gets lost

comment:2 Changed 7 years ago by steinwinde

  • Owner set to steinwinde
  • Status changed from new to assigned

comment:3 Changed 7 years ago by planetcruiser

  • Description modified (diff)
  • freq_reported changed from 1 to 3
  • Priority changed from minor to blocker
  • Summary changed from Second name can not be added or removed to Second name can not be added or removed, post code can not be added

this also seems to happen for post codes, which is difficult to reproduce, because post codes are mandatory now. but people that didn't have post codes entered in the past now can't add them. this results in them not being able to change their current address. *eek* this makes this ticket a blocker.

comment:4 Changed 7 years ago by planetcruiser

steinwinde: any luck here? the milestone is due in 2 days and especially the postcode issue is urgent now

comment:5 Changed 7 years ago by steinwinde

  • Owner steinwinde deleted

comment:6 Changed 7 years ago by planetcruiser

steinwinde: how can i understand this? you won't work on it? if so, please assign to me

comment:7 Changed 7 years ago by steinwinde

  • Owner set to planetcruiser

comment:8 Changed 7 years ago by planetcruiser

  • follow_up changed from none to test on alpha

comment:9 Changed 7 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from assigned to closed

successfully tested on alpha with second name for planetcruiser and zip code for meinhard_test

Note: See TracTickets for help on using tickets.