Opened 7 years ago

Closed 6 years ago

#1570 closed bug (wontfix)

Adding a language not working

Reported by: planetcruiser Owned by:
Priority: trivial Milestone: unassigned
Component: BW Profile Keywords: easy
Cc:

Description

Issue:

  • When form input errors occur, a language that has been added to the profile is not being saved
  • A notice like this is shown: "Notice: Undefined property: stdClass::$Name in /home/www/www.bewelcome.org-4634187/build/members/templates/editprofile_form.php on line 77"

Reproduce:

  1. Edit profile http://www.bewelcome.org/editmyprofile
  2. At "Spoken language" select a new language
  3. Click "Add Language"
  4. Empty "Birth date" field (or any other mandatory field)
  5. Press "Submit"
  6. Added language is not displayed, instead PHP notice is shown

Solution:

  • Display newly added language, also when form validation errors occur

Change History (5)

comment:1 Changed 6 years ago by jsfan

  • Milestone Future deleted

Milestone Future deleted

comment:2 Changed 6 years ago by planetcruiser

  • Keywords easy added
  • Milestone set to unassigned

comment:3 Changed 6 years ago by shevek

Can't see any notice instead the field for the new language is left empty. Changing priority to trivial?

comment:4 Changed 6 years ago by planetcruiser

  • Priority changed from minor to trivial

sure, this was before notices were hidden on www.

comment:5 Changed 6 years ago by planetcruiser

  • Resolution set to wontfix
  • Status changed from new to closed

actually, why bother? -> welen

Note: See TracTickets for help on using tickets.