Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1571 closed bug (fixed)

Browse by country member counters wrong

Reported by: planetcruiser Owned by:
Priority: major Milestone: 0.5.7 - bugfixing
Component: BW Search Keywords:
Cc:

Description

Issue:

  • The numbers stated behind the region and cities when browsing a country are almost always incorrect

Reproduce:

  1. Go to Find members -> browse countries (http://www.bewelcome.org/places)
  2. Click "Lebanon (8)"
  3. 8 members are shown
  4. Click "Mohafazat Beyrouth (9)" -> this already is more than 8, duh ;)
  5. 5 members are shown
  6. Click "Beirut (9)"
  7. 5 members are shown
  8. Go back to "Libanon" (http://www.bewelcome.org/places/LB)
  9. Click on "Mohafazat Liban-Nord (3)"
  10. 3 members are shown, member counters for Tripoli and Batroun are correct

Solution:

  • Show the correct member number in brackets

Clues:

  • The number of members in brackets when browsing regions and cities seems to be always higher than the number of actual members. Maybe deleted or deactivated members are also counted in the SQL query?

Change History (3)

comment:1 Changed 7 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from new to closed

solved via #1591 :)

comment:2 Changed 7 years ago by planetcruiser

  • Milestone changed from unassigned to 0.5.7 - bugfixing

comment:3 Changed 7 years ago by planetcruiser

note that members are now counted in real-time instead of read from the counter in regions.NbMembers?, because the regions table is being decommissioned. this might put some extra strain on database queries, but so far the counting queries execute very fast

see https://gitorious.org/bewelcome/rox/commit/cef3cf8e2244ba364b260ea7468663ba1221471e for a related commit

Note: See TracTickets for help on using tickets.