Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1573 closed improve feature (fixed)

[BW messages] Delete and Spam button missing

Reported by: bikepunk Owned by: micha
Priority: major Milestone: 0.5.6 - bugfixing
Component: BW Mail Keywords:
Cc:

Description (last modified by planetcruiser)

http://www.bewelcome.org/messages/xxxxx

When you read a message from your inbox on BeWelcome, there is no way to delete or spam it directly. At the moment, you have to go to http://www.bewelcome.org/messages/received to pick the messages you want to delete.

Change History (14)

comment:1 Changed 7 years ago by globetrotter_tt

I agree. The "mark spam" buttom should also be included.

comment:2 Changed 7 years ago by micha

  • Milestone changed from unassigned to 0.5.6 - bugfixing
  • Owner set to micha
  • Status changed from new to assigned

comment:3 Changed 7 years ago by micha

  • follow_up changed from none to review code

just pushed my fix to the development branch: 5f1518f

comment:4 Changed 7 years ago by micha

  • Status changed from assigned to accepted

comment:5 Changed 7 years ago by planetcruiser

  • Description modified (diff)
  • Summary changed from [BW messages] Delete button missing to [BW messages] Delete and Spam button missing

comment:6 Changed 7 years ago by planetcruiser

@micha: great work! i just deployed your commit to alpha. for me the spam button still reads "mark as spam" when the mail is already in the spam folder.

i tested with a user with "ActiveHidden" status, not sure if that could influence this.

will do code review later.

comment:7 Changed 7 years ago by micha

@planetcruiser: you're right about the "mark as spam"-thing. I missed an uppercase. I just committed a fix: 34ace49

comment:8 Changed 7 years ago by globetrotter_tt

Probably this need to go in an extra ticket, but i get following error when i click one of the buttons and no message is ticked:

Notice: Undefined variable: result in /home/www/alpha.bewelcome.org-b079321/build/messages/messages.ctrl.php on line 292

comment:9 Changed 7 years ago by micha

This COULD go into an extra ticket but i think i'll just fix it. Will do so tomirrow..

comment:10 Changed 7 years ago by globetrotter_tt

  • follow_up changed from review code to test on alpha

Have you fixed it, or should i open an extra ticket for it?

comment:11 Changed 7 years ago by crumbking

I tested on alpha.

The new buttons in the message view seems to work.

The errors while not ticking a message doesn't work yet. On all tabs (m received, m send, spam)

comment:12 follow-up: Changed 7 years ago by micha

Ok, commited a proper fix now (52b27b9). I also found out that no results show up anywhere when you use the mailbox-buttons. I suggest we should add proper notifications on what happened after you click a button there. (E.g.: "X messages marked as spam."). But THIS should really go into a new ticket. Who volunteers?

comment:13 in reply to: ↑ 12 Changed 7 years ago by crumbking

  • follow_up changed from test on alpha to none
  • Resolution set to fixed
  • Status changed from accepted to closed

Replying to micha:

Ok, commited a proper fix now (52b27b9). I also found out that no results show up anywhere when you use the mailbox-buttons. I suggest we should add proper notifications on what happened after you click a button there. (E.g.: "X messages marked as spam."). But THIS should really go into a new ticket. Who volunteers?

I tested on alpha. Seems to work now. No error messages in all tabs. Yes (error) notifications should go in a new ticket. I open one...

Note: See TracTickets for help on using tickets.