Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1587 closed task (fixed)

Report comment needs reimplementation

Reported by: planetcruiser Owned by: globetrotter_tt
Priority: critical Milestone: 0.5.9 - bugfixing
Component: BW Profile Keywords:
Cc:

Description (last modified by planetcruiser)

Issue:

  • Report comment on a user's comment page marks comment on first click, without the reporter entering a reason for a flag, and then redirects to feedback page
  • This is far from expected behaviour, so currently the button has been removed

Solution:

  1. Show "Report comment" button again
  2. On click display form to enter reason for flag (new page or in-line)
  3. Flag comment *after* user presses submit, so it shows in http://www.bewelcome.org/admin/comments and/or http://www.bewelcome.org/bw/admin/admincomments.php
  4. Send notification mail to abuse email address

Clues:

  • According to matthias the admin comment tools only partly work, this might need an extra ticket

Related tickets:

Change History (14)

comment:1 Changed 7 years ago by globetrotter_tt

related tickets: #1334 & #1299

comment:2 Changed 7 years ago by planetcruiser

  • Milestone changed from 0.5.7 - bugfixing to 0.5.8 - bugfixing

realistically we won't get this done until monday - moving to next milestone

comment:3 Changed 7 years ago by micha

  • follow_up changed from none to review code

The only way to get the task (show the given feedback for comments that are to be checked by admins) done is by:

creating another column in the DB like: feedbacks.IdComment? - so that a single feedback can be related to a specific comment.

OR

creating another table like 'feedbacks_to_comments'.

Any preference on this?

comment:4 Changed 7 years ago by planetcruiser

  • follow_up changed from review code to none

micha: this ticket is actually for the next milestone. do you want to try to solve it for this milestone?

about your question: i think a new table is better. how about "comments_reports"? then it's clear that these are reports related to comments. fields:

  • id: int(11), auto-increment, index
  • commentId: int(11)
  • reason: text

maybe the table could automatically be created if missing? is this a good idea? i think we do this with other tables, don't we? is there a framework for this?

comment:5 Changed 7 years ago by planetcruiser

  • Description modified (diff)

also see if issues in #1299 are solved once this ticket is done

comment:6 Changed 7 years ago by planetcruiser

micha, do you commit to doing this within the next 2 weeks until the milestone is released? if not, please assign it to the next milestone or set it to milestone unassigned, because 0.5.8 is a bit crowded. 5 tickets per milestone has proven to be a realistic aim at current pace.

comment:7 Changed 7 years ago by planetcruiser

  • Milestone changed from 0.5.8 - bugfixing to 0.5.9 - bugfixing

moving to next milestone again *sigh*

comment:8 Changed 7 years ago by planetcruiser

  • Owner set to planetcruiser
  • Status changed from new to accepted

will look into this over the next few days

comment:9 Changed 7 years ago by planetcruiser

  • Cc micha globetrotter_tt removed
  • Description modified (diff)

comment:10 Changed 7 years ago by planetcruiser

"report comment" now a flag: https://gitorious.org/bewelcome/rox/commit/6526935dccf4126ac37becaf893031affb3398d3

the rest is work in progress..

comment:11 Changed 7 years ago by planetcruiser

  • Owner changed from planetcruiser to globetrotter_tt
  • Status changed from accepted to assigned

ok, i think this is pretty much done. i implemented the following:

  • all comments now have a flag icon
  • when clicking flag user gets to feedback form with "comment problem" preselected
  • after sending form, comment is marked as problematic and user gets back to the comment page they came from
  • an feedback email is sent to otrs containing the user's report text, an admin link for the problematic comment and a link to the page the comment was found on
  • the problematic comment appears on http://alpha.bewelcome.org/bw/admin/admincomments.php, and after this goes live on http://www.bewelcome.org/bw/admin/admincomments.php
  • comments can be updated, deleted and marked as checked by admins on the admincomments.php page
  • volunteers with comment admin rights see a "Reported comments (?)" at the top of the page

commits:

please test! :)

comment:12 Changed 7 years ago by crumbking

seems to work as described.... (tested locally as I do not have comments rights on alpha)

minor thing: after sending the feedback the user gets back to the comments page. Maybe a notification "Thank you. This comment is reported...." or something similar would be great as it seems nothing changed on the comment page.

comment:13 Changed 7 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:14 Changed 7 years ago by planetcruiser

Note: See TracTickets for help on using tickets.