Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#1590 closed task (fixed)

Allow opt-out of profile visit tracking

Reported by: planetcruiser Owned by: planetcruiser
Priority: critical Milestone: 1.1
Component: BW Profile Keywords:
Cc: midsch, james.oder.dave@…, jsfan

Description (last modified by planetcruiser)

Issue:

Solution:

  • Add preference "Show profile visits (Yes / No)" with explanatory text next to it (needs writing)
  • If no, my visits to other profiles and other people's visits to my profile should not be tracked any longer, pages and page sections listing profile visits should also disappear
  • Implement code that reads these preferences in different modules (see comment:3 for relevant code sections)

Clues:

Change History (17)

comment:1 Changed 5 years ago by TimLoal

  • Priority changed from critical to major

comment:2 Changed 5 years ago by jsfan

  • Milestone Future deleted

Milestone Future deleted

comment:3 Changed 5 years ago by mahouni

  • Milestone set to unassigned
  • Priority changed from major to critical
  • Type changed from improve feature to developer task

Until there is no opt-out of the profile visit tracking (or even better: an opt-in for people who want to allow only visitors who accept to be tracked), please:
comment out line 264 of build/members.members.ctrl.php to diable profile visit tracking.

//$member->recordVisit($logged_member);

Best and easy solution of course:
remove the profile visit tracking:
https://gitorious.org/~mahouni/bewelcome/mahouni-rox/commits/goodbye_profilevisittracking

comment:4 Changed 5 years ago by planetcruiser

  • Description modified (diff)
  • Owner set to planetcruiser
  • Status changed from new to accepted

i just modified the solution to let the user switch off the feature entirely

i can work on this for the next release.

Last edited 5 years ago by planetcruiser (previous) (diff)

comment:5 Changed 5 years ago by midsch

  • Cc midsch added

comment:6 Changed 5 years ago by James_Oder_Dave

  • Cc james.oder.dave@… added

comment:7 Changed 5 years ago by jsfan

  • Milestone changed from unassigned to 1.0-sec

comment:8 Changed 5 years ago by jsfan

  • Cc jsfan added

comment:9 Changed 5 years ago by planetcruiser

new related ticket: #1763 (preferences change position when changed)

comment:10 Changed 5 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from accepted to closed

feature deployed to alpha for testing.

implemented via:

translations added for EN and DE:

  • PreferenceShowProfileVisits
  • PreferenceShowProfileVisitsYes
  • PreferenceShowProfileVisitsNo
  • PreferenceShowProfileVisitsDes

the note in the preferences is needed because the setting is already visible on www as well (can't be avoided with current way preferences are implemented). the note will disappear after release.

comment:12 Changed 5 years ago by sitarane

The specifics of this is still being discussed on BW. http://www.bewelcome.org/wiki/s2927-profile_visitors_feature

Shouldn't wait for the dust to settle there first?

comment:13 Changed 5 years ago by jsfan

I'd vote for "patch and see". I reckon if we can just silence the vocal privacy paranoid minority, this will be old news overnight and nothing will really change for most people. My 2c worth...

comment:14 Changed 5 years ago by James_Oder_Dave

I agree with jsfan

comment:15 Changed 5 years ago by midsch

I've checked it on alpha and was able to use the setting. I can't see the visitor list anymore. I've visited profiles polyglot, sitarane, planetcrusier, jsfan, James_Oder_Dave and expect not to show up on their visitor lists. Can't prove that though.

(ps: >privacy paranoid minority
I refer to me in this way as well, but I doubt everyone will do so. And even if someone thinks "privacy awareness" is a clinical case, it's a matter how we want to treat ill persons. Not taking them serious is difficult.)

comment:16 Changed 5 years ago by planetcruiser

sitarane: because i am such a DRY person: http://www.bewelcome.org/forums/s2927-profile_visitors_feature/#post16083 - i firmly believe this first step is helping the dust to settle quicker. :)

jsfan: "privacy paranoid minority" is a harsh term. let's say "privacy aware members" ;) everybody is entitled to their privacy, and i think this opt-out guarantees that privacy aware members (hehe) feel comfortable. i personally simply don't put things that i have to conceal from other people's eyes on the internet, or at least not in connection with my real identity and not unencrypted.

midsch: i just briefly switched on "profile visitors" and didn't see a visit since 19 hours ago. so for me this is working.

comment:17 Changed 5 years ago by jsfan

@midsch: I can confirm that you visit was not shown.

@planetcruiser: I refer to myself as a a "privacy paranoid" but I've still got nothing on some people. To me "privacy aware" would mean less paranoid than I am myself. :P I also believe that the best information security is to not entrust the information to any electronic form of storage (even less so a networked one) and as little human beings as possible.

Last edited 5 years ago by jsfan (previous) (diff)
Note: See TracTickets for help on using tickets.