Opened 6 years ago

Closed 4 years ago

#1614 closed bug (wontfix)

Database table geonames_cache inconsistent

Reported by: planetcruiser Owned by:
Priority: minor Milestone: unassigned
Component: BW Geo Keywords:
Cc:

Description

Issue:

  • We have places in geonames_cache that have a parentCountryId=0, although a fk_countrycode is set
  • This leads to unexpected behaviour during sign-up and possibly in member search

Solution:

  1. Add missing parentCountryId values via SQL query
  2. Fix geonames import script

Clues:

  • Find broken locations via:
    SELECT * 
    FROM geonames_cache
    WHERE parentCountryId = 0
    AND fcode NOT LIKE  "PC%"
    
  • Make sure manual fixes of geonames_cache are not overwritten by geonames import script
  • Compare geonames_cache with geonames_countries
  • Priority is low, because this only hits very few members

Related ticket:

Change History (2)

comment:1 Changed 5 years ago by jsfan

  • Milestone Future deleted

Milestone Future deleted

comment:2 Changed 4 years ago by shevek

  • Milestone set to unassigned
  • Resolution set to wontfix
  • Status changed from new to closed

The site is being migrated to a full copy of geonames in the next few months. Therefore closing as it will not matter anymore.

Note: See TracTickets for help on using tickets.