Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#1615 closed bug (fixed)

Broken special characters during location update

Reported by: planetcruiser Owned by:
Priority: minor Milestone: 1.2
Component: BW Profile Keywords:
Cc: mahouni

Description

Reproduce:

  1. Go to http://www.bewelcome.org/setlocation
  2. Type "Hagåtña" as location
  3. Search location
  4. Click on first hit "Hagåtña, Guam / Hagåtña Municipality"
  5. Click "Save Location"
  6. "Choosen location" is displayed as "Hag%C3%A5t%C3%B1a, Guam / undefined"

Solution:

  1. Display chosen location as "Hagåtña"
  2. Display "Hagåtña Municipality" instead of "undefined"

Clues:

  • This is possibly borked in the JS or AJAX/JSON response
  • Priority low, because no functionality is harmed

Change History (5)

comment:1 Changed 7 years ago by planetcruiser

  • Cc mahouni added

mahouni: if you are really bored, i think this one would be nice to have fixed. since you are the official bw character encoding expert now.. ;)

comment:2 Changed 6 years ago by TimLoal

  • Component changed from BW Geo to BW Profile

comment:3 Changed 6 years ago by jsfan

  • Milestone Future deleted

Milestone Future deleted

comment:4 Changed 6 years ago by planetcruiser

  • Milestone set to unassigned
  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 6 years ago by planetcruiser

  • Milestone changed from unassigned to 1.2

making sure it gets mentioned in the changelog

Note: See TracTickets for help on using tickets.