Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#1623 closed improve feature (fixed)

add group name to Recent Forum Posts on the main (internal) page

Reported by: crumbking Owned by: crumbking
Priority: minor Milestone: 0.5.9 - bugfixing
Component: BW Layout Keywords:
Cc:

Description

  • at the moment, from the main page, you're not able to see to which group the recent posts belong to
  • see also:

http://www.bewelcome.org/groups/571/forum/s2238-add_group_name_to_Recent_Forum_Posts_on_the_main_page

Change History (14)

comment:1 follow-up: Changed 7 years ago by crumbking

  • Milestone changed from unassigned to 0.5.9 - bugfixing

should be work with https://gitorious.org/bewelcome/rox/commit/108360278470e2ff24bd10ccc740cf5f2f68a92b

https://gitorious.org/bewelcome/rox/commit/f043e8492f42341b77685dda0b121fa5e2bfa918

I'm not sure if it's the right place for function short_name. Please move to the relevant file if needed...

test and move to alpha ...

Actually it's not a bug but a user wish :)

comment:2 in reply to: ↑ 1 ; follow-up: Changed 7 years ago by planetcruiser

cool, nice new feature. :)

Replying to crumbking:

should be work with https://gitorious.org/bewelcome/rox/commit/108360278470e2ff24bd10ccc740cf5f2f68a92b

https://gitorious.org/bewelcome/rox/commit/f043e8492f42341b77685dda0b121fa5e2bfa918

I'm not sure if it's the right place for function short_name. Please move to the relevant file if needed...

we use string shortening in the "last comments" list on profiles (see your second comment on http://www.bewelcome.org/members/crumbking) - i don't know how it's done there, but i think it's good not to reinvent the wheel and use the same function. could you look into that please?

test and move to alpha ...

deployed to alpha. comments:

  • i don't think the word "Group:" needs to be there, because it's pretty clear. "by User in Some Group - 2 hours ago" is nice and clean. how about that?
  • having the full group name when hovering over the link would be nice. the "title" property could be used: <a href="group" title="very very long group name">group name</a>

Actually it's not a bug but a user wish :)

well, i think it's good to mix some small enhancements in with the bug fixing. ;)

comment:3 in reply to: ↑ 2 Changed 7 years ago by crumbking

Replying to planetcruiser:

Agree with all your points. I will look into it.

comment:4 Changed 7 years ago by planetcruiser

hm, any chance this could be done until tomorrow? ;) i was planning to release 0.5.9 today, but i can wait until noon tomorrow

comment:6 follow-up: Changed 7 years ago by planetcruiser

comment:7 in reply to: ↑ 6 Changed 7 years ago by crumbking

Replying to planetcruiser:

cool! but let's leave the dash where it is: https://gitorious.org/bewelcome/rox/commit/b4ff8b358db7d6c84edb2ce33f24ad4a245bf3d1

Thought we could save some space for longer usernames ;-) But it's okay like that ...

comment:8 Changed 7 years ago by crumbking

I will ask for translations for the word "in". English and German done.

comment:11 Changed 7 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from new to closed

i think this ticket is done..

comment:12 follow-up: Changed 7 years ago by crumbking

Well, I added the test to avoid that it's shown in recent forum posts in the group overview page.

Like: http://alpha.bewelcome.org/groups/70

As the group info is there useless we should leave the test.

Last edited 7 years ago by crumbking (previous) (diff)

comment:13 in reply to: ↑ 12 Changed 7 years ago by planetcruiser

Replying to crumbking:

Well, I added the test to avoid that it's shown in recent forum posts in the group overview page.

Like: http://alpha.bewelcome.org/groups/70

As the group info is there useless we should leave the test.

ah, i see. maybe a comment for a test that is not obvious will help next time. ;)

i implemented this exception via:

reasons:

  • templates should never contain too much logic (well, all is lost regarding that one in bw-rox, but still)
  • now it's obvious what the test is doing, with a bit of code digging
  • this switch can be reused in other places if needed

comment:14 Changed 7 years ago by crumbking

Great!

Good that you checked that.... I always look through my designer glasses ;-)

Note: See TracTickets for help on using tickets.