Attachments (3)

997.png (119.1 KB) - added by shevek 6 years ago.
Original map tiles
1.png (83.4 KB) - added by shevek 6 years ago.
New map tile
36225.png (102.3 KB) - added by shevek 6 years ago.
Style 36225

Download all attachments as: .zip

Change History (82)

comment:1 Changed 7 years ago by planetcruiser

  • Description modified (diff)

comment:2 Changed 7 years ago by planetcruiser

  • Description modified (diff)

comment:3 Changed 7 years ago by planetcruiser

  • Description modified (diff)

comment:4 Changed 7 years ago by planetcruiser

a little bit off-topic, but somehow related: ;) maybe once osm migration is done #1264 will be easier to achieve

comment:5 Changed 7 years ago by planetcruiser

  • Owner set to toub
  • Status changed from new to assigned

comment:6 Changed 6 years ago by toub

  • Status changed from assigned to accepted

comment:7 Changed 6 years ago by toub

Work in progress, live demo here: http://rox.mishk.org/

comment:8 Changed 6 years ago by toub

Please test!

comment:9 Changed 6 years ago by toub

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:10 Changed 6 years ago by globetrotter_tt

  • Resolution fixed deleted
  • Status changed from closed to reopened

I noticed that the "Textview" does not work anymore. Mapview works fine from what i have tested, but when i want to switch to textview, i see only "loading..." and nothing happens.

comment:11 Changed 6 years ago by toub

Textview is back. Thanks for reporting.

comment:12 Changed 6 years ago by toub

Fixed. To be tested and review.

Commited to: https://gitorious.org/~toub/bewelcome/osm-rox Live demo here: http://rox.mishk.org/

comment:13 Changed 6 years ago by toub

  • Owner changed from toub to planetcruiser
  • Status changed from reopened to assigned

comment:14 Changed 6 years ago by globetrotter_tt

  • Milestone changed from unassigned to 0.9 - OSM

comment:15 Changed 6 years ago by mahouni

I tried to run that branch (commit: 29cadb1) locally, but the map isn't loading. Only me or anyone else having this issue? In an earlier version the map worked quite well for me.

comment:16 follow-up: Changed 6 years ago by toub

Did you try to refresh your browser cache?

Do you have the same problem here: http://rox.mishk.org/searchmembers ?

Witch browser do you use?

comment:17 in reply to: ↑ 16 Changed 6 years ago by mahouni

Replying to toub:

Did you try to refresh your browser cache?

Do you have the same problem here: http://rox.mishk.org/searchmembers ?

Witch browser do you use?

.

It works well on your website rox.mishk.org.

It's just the local branch which is not working. I am using firefox 12.0 on Linux Mint, and refresh browser cache didn't help. I guess there is something wrong with my installation... will have to look at it again later, because I couldn't find anything today. Anyway I will first study the new osm code now...

Last edited 6 years ago by mahouni (previous) (diff)

comment:18 Changed 6 years ago by globetrotter_tt

I can confirm mahouni's problem. I have pulled your osm-rox master branch and the map is not loading. (i tried with all common browsers)

comment:19 Changed 6 years ago by mahouni

there are 2 unresolved merge conflicts in the file "INSTALL" . this of course isn't causing the problem, but maybe something else got lost while resolving that merge conflict?

comment:20 Changed 6 years ago by mahouni

yeah, it works!!
Ready for osm-rox now!

It had nothing to do with the new osm-rox code. But for my local setting the way how main.js gets the pagename does not work overall (haven't noticed it yet...).

my local environment is configured differently: my url to BWRox is http://localhost/bewelcome/htdocs/

on line 40 in the file main.js:

var currentPage = req.substring(1, req.length);

currentPage has the value "bewelcome/htdocs/pagename"

I added the following line, but this is just a temporarily workaround that works for me:

var currentPage = req.substring(1, req.length);
currentPage = currentPage.replace("bewelcome/htdocs/", "");

Need to check how the variable retrieval from request is done on other parts of BWRox, and then create a new ticket for fixing that function of main.js, so that it works also for different request paths than "/pagename".
Or maybe I should setup BWRox according to the standard INSTALL instructions ;)

comment:21 Changed 6 years ago by toub

I just pull the last rox develop branch, refactored a bit my code, and updated the documentation (/htdocs/script/map/map-documentation.txt => maybe not the best place, but at least it is visible).

Is the map working for you now? There was an unused "develop" branch, maybe that is was the problem? I removed it, use the master one to merge my modifications to your local branch:

git remote add toub git://gitorious.org/~toub/bewelcome/osm-rox.git git pull toub master

So, are we ready for the switch? What are the next steps?

comment:22 Changed 6 years ago by planetcruiser

  • Milestone changed from 0.9 to unassigned

toub is travelling until end of september, let's reschedule this once he is back

comment:23 Changed 6 years ago by planetcruiser

  • Milestone changed from unassigned to 1.0

1.0 is the new osm release

comment:24 Changed 6 years ago by toub

Fixed, merged with develop branch, then pushed to a new temporary branch named "osm": https://gitorious.org/bewelcome/rox/commits/osm

Ready for tests and review.

comment:25 Changed 6 years ago by crumbking

Tested locally in develop. Ready for alpha.

comment:26 Changed 6 years ago by sitarane

What to test? I made a couple of mapsearchs and they are populated correctly. On alpha.

comment:27 Changed 6 years ago by toub

Did various tests on alpha, looks ok.

comment:28 Changed 6 years ago by globetrotter_tt

  • Resolution set to fixed
  • Status changed from assigned to closed

tested on alpha. found all locations i was looking for.

comment:29 Changed 6 years ago by mahouni

  • Resolution fixed deleted
  • Status changed from closed to reopened

"search using map boundaries" is broken. the search window and the map boundaries are not equal.

Tested on alpha rev. 73ca6c6 with firefox 16.

comment:30 Changed 6 years ago by globetrotter_tt

i can confirm this. apparently "search using map boundaries" does not work when you zoom in too close.

comment:32 Changed 6 years ago by toub

I don't know at all the code on server side.

If I understand, searchmembers.model.php->search() is called by searchmembers.ctrl.php.

We have a strange function here:

private function generateMapSearchCond(&$vars) {

$where = '1=1'; initialise condition

preset latitudes $latSW = intval($this->GetParam?($vars, "bounds_sw_lat")); $latNE = intval($this->GetParam?($vars, "bounds_ne_lat"));

preset longitudes $longSW = intval($this->GetParam?($vars, "bounds_sw_lng")); $longNE = intval($this->GetParam?($vars, "bounds_ne_lng"));

Do we really have to convert the lat and lng to integers (instead of keep the real values).

This is called here:

map boundaries for search

if($this->GetParam?($vars, "mapsearch")) {

$where .= ' AND ' . $this->generateMapSearchCond($vars);

}

comment:33 Changed 6 years ago by toub

I just did a quick test locally, and removing "intval" looks to fix the bug.

But as I don't know the code, maybe better wait for Christian to be sure there is nothing hidden here.

comment:34 Changed 6 years ago by toub

Fixed by Christian (by replacing intval by floatval): to deploy on alpha.

https://gitorious.org/bewelcome/rox/commit/c2fa021c8797ffda60609785461413315985d73b

comment:35 Changed 6 years ago by jsfan

Deployed on alpha. Please test and close if fixed.

comment:36 Changed 6 years ago by toub

Ok on alpha.

I think we can close the ticket.

comment:37 Changed 6 years ago by mahouni

  • Resolution set to fixed
  • Status changed from reopened to closed

yep, it's working again!

comment:38 Changed 6 years ago by crumbking

Works! But while not logged in a search for Berlin, Paris takes more than 10 seconds...

Logged in works.

comment:39 Changed 6 years ago by jsfan

Patchset 6271228 deployed on alpha.

comment:40 follow-up: Changed 6 years ago by planetcruiser

  • Resolution fixed deleted
  • Status changed from closed to reopened

i disagree with the change made in https://gitorious.org/bewelcome/rox/commit/6271228 (change initial zoom level from 1 to 2) for the following reasons:

  • on www we are currently showing the whole world when coming to the search page and we should continue to do so in order to show that we are a global project. especially having most of the usa out of the picture, like suggested by this commit, is not wise.
  • the "strange boxes on antarctica" are current territorial claims and no error. i agree that the boxes look irritating and we can only hope that cloudmade will render them better in future. maybe we should raise a ticket at their tracker for this.
  • there has been no discussion about this pretty prominent change. at least none that is referenced in this ticket. (i may have missed it during my absence)

suggestion: revert this commit. vetos?

comment:41 in reply to: ↑ 40 ; follow-up: Changed 6 years ago by crumbking

Veto :-)

Replying to planetcruiser:

i disagree with the change made in https://gitorious.org/bewelcome/rox/commit/6271228 (change initial zoom level from 1 to 2) for the following reasons:

  • on www we are currently showing the whole world when coming to the search page and we should continue to do so in order to show that we are a global project. especially having most of the usa out of the picture, like suggested by this commit, is not wise.

Well not showing some parts of the world does not say anything about our "global project". Maybe default the map more to the usa or any random country.

  • the "strange boxes on antarctica" are current territorial claims and no error. i agree that the boxes look irritating and we can only hope that cloudmade will render them better in future. maybe we should raise a ticket at their tracker for this.

Disagree. Don't show something "visual broken" on the page just because other services does not render right. If we have the option to avoid this visual broken map we should do so. We could raise a ticket at cloudmade and when it's fixed we will zoom out in BW, too.

  • there has been no discussion about this pretty prominent change. at least none that is referenced in this ticket. (i may have missed it during my absence)

I exchanged some mails with toub and talked with people in IRC.

comment:42 in reply to: ↑ 41 Changed 6 years ago by planetcruiser

Replying to crumbking:

Veto :-)

argh. ;)

Well not showing some parts of the world does not say anything about our "global project". Maybe default the map more to the usa or any random country.

or the country or continent the user is currently at? that would make a lot of sense, but is also some more work.

  • the "strange boxes on antarctica" are current territorial claims and no error. i agree that the boxes look irritating and we can only hope that cloudmade will render them better in future. maybe we should raise a ticket at their tracker for this.

Disagree. Don't show something "visual broken" on the page just because other services does not render right. If we have the option to avoid this visual broken map we should do so. We could raise a ticket at cloudmade and when it's fixed we will zoom out in BW, too.

well, it's not broken. those lines are 100% correct. maybe a little bit too thick, that's all.

however, form should follow function. showing some arbitrary part of the world just because of a few lines that are a little bit to opaque does not exactly serve the purpose of hospitality.

  • there has been no discussion about this pretty prominent change. at least none that is referenced in this ticket. (i may have missed it during my absence)

I exchanged some mails with toub and talked with people in IRC.

the dev list is the official (?) place for announcements and decision making. i would have surely object in the progress if i would have known about these plans.

ok, so how can we find a compromise? or shall we set up a little poll like for the bw-symfony name?

comment:43 follow-ups: Changed 6 years ago by globetrotter_tt

Is this discussion only about the default zoom level for the map search? If yes, I'd like to see the whole world map there. Can't see anything broken there btw. Can someone enlighten me, please?

comment:44 in reply to: ↑ 43 Changed 6 years ago by planetcruiser

Replying to globetrotter_tt:

Is this discussion only about the default zoom level for the map search? If yes, I'd like to see the whole world map there. Can't see anything broken there btw. Can someone enlighten me, please?

yes, see comment:41 - crumbking changed the default map view from level 1 (whole world) to level 2 (afrika, europe, parts of asia and americas).

comment:45 in reply to: ↑ 43 Changed 6 years ago by crumbking

Replying to globetrotter_tt:

Is this discussion only about the default zoom level for the map search? If yes, I'd like to see the whole world map there. Can't see anything broken there btw. Can someone enlighten me, please?

So what you see on alpha is level 2. Hit the zoom out once (-) and you see what planetcruiser would like to be visible as default. (level 1)

comment:47 follow-up: Changed 6 years ago by crumbking

Replying to planetcruiser:

Replying to crumbking:

Veto :-)

argh. ;)

hihi, I don't care about errors but more about the visual aspects ;-)

Well not showing some parts of the world does not say anything about our "global project". Maybe default the map more to the usa or any random country.

or the country or continent the user is currently at?

+1 but only if we get this done in a week or so ;-)

  • the "strange boxes on antarctica" are current territorial claims and no error. i agree that the boxes look irritating and we can only hope that cloudmade will render them better in future. maybe we should raise a ticket at their tracker for this.

Disagree. Don't show something "visual broken" on the page just because other services does not render right. If we have the option to avoid this visual broken map we should do so. We could raise a ticket at cloudmade and when it's fixed we will zoom out in BW, too.

well, it's not broken. those lines are 100% correct. maybe a little bit too thick, that's all.

however, form should follow function. showing some arbitrary part of the world just because of a few lines that are a little bit to opaque does not exactly serve the purpose of hospitality.

as compromise lets fit the color of the ocean and the borders color of those lines. like here: http://maps.cloudmade.com/ Than you see those lines only on the continent. I could live with that ;-)

  • there has been no discussion about this pretty prominent change. at least none that is referenced in this ticket. (i may have missed it during my absence)

I exchanged some mails with toub and talked with people in IRC.

the dev list is the official (?) place for announcements and decision making. i would have surely object in the progress if i would have known about these plans.

next time dev list: +1

ok, so how can we find a compromise? or shall we set up a little poll like for the bw-symfony name?

na, way to complex for such a small change.

Let's try 3 options, start with one:

  1. color fit of ocean and border colors of the tiles/pictures
  2. find a solution where we set the map to the users country/continent (browser data?!?)
  3. small vote on the ticket ( +1 level 1 or level 2)
  4. be a dictator of the release and get this ready ;-)

I do a research for 1. now.

comment:48 Changed 6 years ago by mahouni

I would support a global map without borders :p

Other suggestion (would need some work on the code): We could set the minZoom level of the current base map tile (fresh, id 997) to zoom level 6, and add another tile layer (the original with id 1, ocean colour border lines) with maxZoom level 5.

comment:49 Changed 6 years ago by jsfan

I think this is a bit overrated. I believe most people will not even look at the map before they search. However, as we need to make a decision one way or another, I'd suggest to go with level 1. I don't have anything against removing borders but don't think it's necessary. I reckon that matching them with the ocean's colour is not a good idea because it means the continents get "cut up".

comment:50 in reply to: ↑ 47 ; follow-up: Changed 6 years ago by planetcruiser

Replying to crumbking:

  1. small vote on the ticket ( +1 level 1 or level 2)

i like the mini vote in this ticket approach. let's use the poll thingy in comment:46 - cool, i didn't know trac can do that! :)

comment:51 Changed 6 years ago by planetcruiser

ok, for email readers. crumbking, jsfan, mahouni, toub:

please go to http://trac.bewelcome.org/ticket/1635#comment:46 and cast your vote.

i want to get done with this and move forward with the release. ;)

comment:52 Changed 6 years ago by mahouni

I am okay with both options (level 1 or level 2) and would abstain from voting.

+1 for a fast decision and we can still get back to it later.

jsfan: I think that the regions/continents level of "The Original" map look nicer than "Fresh". Have a look at the map styles (id 997 and id 1): http://maps.cloudmade.com/editor

comment:53 Changed 6 years ago by planetcruiser

mahouni: interesting hint. a compromise could be to create our own bw style based on what we currently have and reduce opacity of the national borders so they are less annoying, like in id 44094 on http://maps.cloudmade.com/editor for example. crumbking, could you look into that?

we can just select our preferred style id when including the map i assume?

comment:54 Changed 6 years ago by globetrotter_tt

  • Description modified (diff)

comment:55 in reply to: ↑ 50 Changed 6 years ago by globetrotter_tt

Replying to planetcruiser:

Replying to crumbking:

  1. small vote on the ticket ( +1 level 1 or level 2)

i like the mini vote in this ticket approach. let's use the poll thingy in comment:46 - cool, i didn't know trac can do that! :)

I put the mini poll in the ticket description, so it does not gte lost in the comments.

btw: trac can do a lot more... have a look in the admin backend and RTFM ;-)

comment:56 Changed 6 years ago by mahouni

yes, I think we could just fork one of these styles and edit it. The problem is, that it doesn't seem to be possible to edit these ocean territory lines with the integrated web editor on cloudmade.

The id (997) is in the link when the map is initiated in the builder scripts:
builder/BWGeosearchMapBuilder.js on line 23:

this.cloudmadeUrl = 'http://{s}.tile.cloudmade.com/' + this.cloudmadeApiKey + '/997/256/{z}/{x}/{y}.png';

And it should be possible to display different styles for different zoom levels. Probably there is also an option to define the map extent and cut antarctica. (Or do we have already some members there?)

comment:57 Changed 6 years ago by crumbking

I would say if we choose id=1 "the original" it would fix the issue. That is the default map when visiting cloudmade.com And they match the country border color with the oceans.

Should we go go for it together with zoom level 1?

comment:58 Changed 6 years ago by shevek

While I don't like the waste of map space: ID 1 and zoom level 1.

comment:59 Changed 6 years ago by planetcruiser

ok, the poll shows that most of the people want the whole world! ;)

i reverted crumbking's commit: https://gitorious.org/bewelcome/rox/commit/977842c54f5887298ce3257e4ddeca3fb65d19fc

toub, is there any particular reason why you chose style id 997? any objections if we change it to 1? does cloudmade have a "terrain" or physical map option, like our current map on www is using? i think that's much prettier.

mahouni, how did they remove the ocean territory lines on id 1? when you zoom in they reappear by the way. maybe they modified the thickness or something? just guessing..

comment:60 Changed 6 years ago by shevek

The color of the borders changes somewhere between country and county zoom level from ocean color to lilac. That's when the ocean territory lines reappear.

comment:61 Changed 6 years ago by crumbking

I have read somewhere in the FAQ that you have to clone a basic map with a given border style. It's not yet possible to style the borders with the editor.

Regarding the "landscape" this should be possible to edit through the cloudmade editor.

Anyway all the details we could do later on without any code change. I suggest to clone id=1 as this is the cloudmade "default" and may change in future.

We should use our own clone which we can style later on as preferred.

comment:62 Changed 6 years ago by planetcruiser

small fix via https://gitorious.org/bewelcome/rox/commit/095770896de80f35a7625b7c0c9e7b34e8455b89 - correct naming of map providers in layer selection

comment:63 Changed 6 years ago by planetcruiser

  • Status changed from reopened to accepted

will look into changing the style id and a few remaining small other things next

comment:64 Changed 6 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from accepted to closed

a couple of patches today, mainly visual fine-tuning:

browser cache clearing or shift-reload needed.

i am closing this beast now. :)

Changed 6 years ago by shevek

Original map tiles

Changed 6 years ago by shevek

New map tile

comment:65 follow-up: Changed 6 years ago by shevek

Sorry but with the chosen tiles the map is very unreadable.

Old tiles for Heidelberg:

Original map tiles

New tiles:

New map tile

I'd prefer to revert that change.

Last edited 6 years ago by shevek (previous) (diff)

comment:66 in reply to: ↑ 65 Changed 6 years ago by planetcruiser

Replying to shevek:

Sorry but with the chosen tiles the map is very unreadable.

I'd prefer to revert that change.

i agree, when zoomed in 997 looks much better. feel like cloning 997 and making the antarctic and ocean lines less visible? otherwise, discuss this with crumbking. :)

comment:67 Changed 6 years ago by shevek

I try my luck with cloning 997 and work on the lower zoom levels. But seems that that is pretty resource hungry so has to wait till I get home...

comment:68 Changed 6 years ago by shevek

Unfortunately cloudmade doesn't support editing borders at all. So the only option would be to either find a map style that has both nice borders and nice tiles or to go with the one that offers the better view when searching: 997.

Changed 6 years ago by shevek

Style 36225

comment:69 Changed 6 years ago by shevek

I checked some style but couldn't find one that was decent looking for city level while having nice borders. Pretty strange. Found this one while checking:

Style 36225

I'd suggest to use that one as it is rather clean and has a public transport overlay (comes in handy for some cities).

comment:70 Changed 6 years ago by planetcruiser

we are not the only people unhappy about not being able to style borders: http://support.cloudmade.com/forums/general/posts/3695/show - so weird, why don't they think that's important?

here they say that they will allow this soon, but nothing has happened there in more than a year: http://support.cloudmade.com/forums/web-maps-studio/posts/791/show

so, yeah, i am also sypporting reverting back to 997, and later possibly our own clone of it. alternatively we could use 36225, which does not seem to be very different to 997.

what we *could* do is to show style 1 when in zoom level 1 and style 997 when zooming in. it shouldn't be more than 5 lines of js for that, but i am not really into this, as 997 was fine for me from the beginning.

another problem i have with style 1 is that for example russia's republic borders make it look like several countries.

revert to 997 for the 1.2 release?

comment:72 Changed 6 years ago by planetcruiser

sorry, i want to move on and release soon, so i just reverted back to 997: https://gitorious.org/bewelcome/rox/commit/8e364fd26f49a6235ff41f4f047384de3ac12f89

form follows function - usability over pretty looks. ;) i don't like the blocks on antarctica and the thick black lines separating people from each other on the continents either, but i see no other pragmatic choice to solve this at the moment.

comment:73 follow-up: Changed 6 years ago by shevek

I'd prefer 36225! The reason is that if you look closely enough there are a lot of dotted lines on 997 that most likely noone knows the meaning of (and there is no legend to find out) which aren't there in 36225.

comment:74 Changed 6 years ago by toub

In the future, we should generate our own layers, so we can have them unique, and exactly as we want.

However, this is a very interesting topic, but really not the priority.

comment:75 in reply to: ↑ 73 Changed 6 years ago by planetcruiser

Replying to shevek:

I'd prefer 36225!

only if we create our own clone, because the author of 36225 could just change their style without us knowing about it.

but i can't be bothered right now to do that clone. shevek, if you feel like it and manage to get this done by tonight, we can take it into the release. it would be nice to have a bw style in fact.

comment:76 Changed 6 years ago by shevek

Clone's done. Took 5 seconds :-)

Clone named bewelcome.org (ID: 80892).

comment:77 Changed 6 years ago by planetcruiser

thanks. but why does uzbekistan(?) have such a thick borders when zooming out to 1 or 2?

maybe we should clone from 997 and add the train lines ourselves to avoid more surprises. i mean we don't know what else the author of 36225 has changed.

see, in software development never anything takes just 5s. :-P

i just noticed that the "fresh" style, so also our clone doesn't have country names. why on earth would they remove them?! some things about their tiles don't make any sense to me..

comment:78 Changed 6 years ago by shevek

Used 997 as a start. Got rid of the railway lines.

Clone named bewelcome.org (ID: 80898).

(And of course country names are part of the things you can't edit too...)

Last edited 6 years ago by shevek (previous) (diff)

comment:79 Changed 6 years ago by planetcruiser

weird, 80898 still has the thick uzbekistan border. will use 997 for this release

Note: See TracTickets for help on using tickets.