Opened 7 years ago

Closed 6 years ago

Last modified 6 years ago

#1644 closed bug (wontfix)

Update location: Sighişoara not found

Reported by: planetcruiser Owned by: planetcruiser
Priority: major Milestone: unassigned
Component: BW Profile Keywords:
Cc: toub

Description

Issue:

Solution:

  • Debug SQL query and display correct geonames_cache entry for Sighişoara

Clues:

  • I added "Sighişoara" manually to geonames_cache table, because it wasn't there, but still it's not found. This might have to do with the special "s" in the middle, or a step that I forgot when adding the city to the db

Related tickets:

Change History (13)

comment:1 Changed 6 years ago by TimLoal

  • Milestone changed from Future to 1.1

comment:2 Changed 6 years ago by TimLoal

  • Component changed from BW Geo to BW Profile

comment:3 Changed 6 years ago by TimLoal

Move to milestone 1.3 if not suitable on 1.1

LnP

comment:4 Changed 6 years ago by crumbking

  • Cc toub added

Still an issue.

comment:5 follow-up: Changed 6 years ago by crumbking

I tested here:

http://alpha.bewelcome.org/setlocation -> does not work.

and here:

http://alpha.bewelcome.org/blog/create ->works

So might be some difference between the code base.

comment:6 in reply to: ↑ 5 ; follow-up: Changed 6 years ago by globetrotter_tt

Replying to crumbking:

I tested here:

http://alpha.bewelcome.org/setlocation -> does not work.

and here:

http://alpha.bewelcome.org/blog/create ->works

So might be some difference between the code base.

I can confirm this. Somehow the mapsearch for blogs works better than in signup and setlocation

comment:7 Changed 6 years ago by crumbking

http://geotree.geonames.org/8334977/ That is what is found in blogs app:

<li onclick="javascript: setMap('8334977', '46.22816', '24.77927', '5', 'Municipiul%20Sighi%C5%9Foara', 'Romania', 'RO', 'Mure%C5%9F'); return false;" id="li_8334977"><a onclick="javascript: setMap('8334977', '46.22816', '24.77927', '5', 'Municipiul%20Sighi%C5%9Foara', 'Romania', 'RO', 'Mure%C5%9F'); return false;" id="href_8334977">Municipiul Sighişoara<br><img alt="Romania" src="images/icons/flags/ro.png"> <span class="small">Romania / Mureş</span></a></li>

I'm not sure if the following has something to do with this ticket but there seems to be something called only in the blog/trip app:

http://gitorious.org/bewelcome/rox/blobs/master/build/user/user.model.php#line440

comment:8 Changed 6 years ago by jsfan

I'd suggest to move this to the next milestone.

comment:9 in reply to: ↑ 6 Changed 6 years ago by planetcruiser

  • Owner set to planetcruiser
  • Status changed from new to accepted

Replying to globetrotter_tt:

I can confirm this. Somehow the mapsearch for blogs works better than in signup and setlocation

well, to me it looks like that blog post creation allows for non-city locations, like germany. makes sense.

with the example of Sighişoara the blog post search finds the district of Sighişoara (Municipiul Sighişoara), but not the city itself. it might be that simply the city is broken in our db, not the search. we had cases of this before. i think often a missing parent location was the reason.

looking into this now.

comment:10 Changed 6 years ago by planetcruiser

  • Milestone changed from 1.2 to unassigned

haha, the problem is upstream! http://www.geonames.org/search.html?q=sighisoara does not list the city.

i emailed the geonames embassador for romania (see http://www.geonames.org/team.html):

hello razvan,

check out http://www.geonames.org/search.html?q=sighisoara - the city itself 
is not found, just the "municipul".

in our local database we still have sighisoara as a PPL with the id 667223.
any idea why it was deleted on geonames.org?

our ticket for reference:
http://trac.bewelcome.org/ticket/1644

cheers, meinhard.

so, this will most likely not make it into this release. ;)

comment:11 Changed 6 years ago by shevek

Well according to Wikipedia the correct writing is Sighișoara and not Sighişoara (the nearly invisible difference is below the s in the middle). Anyway geonames doesn't find any of these writings.

comment:12 Changed 6 years ago by planetcruiser

  • Resolution set to wontfix
  • Status changed from accepted to closed

fun fact about ș/ş: correct here is s-comma indeed, but all romanians use s-cedilla (from turkish), because s-comma was not included in many fonts (source: http://en.wikipedia.org/wiki/S-comma). even on http://en.wikipedia.org/wiki/Sighi%C8%99oara it's all mixed. ;)

i will close this one, because it's an upstream problem. i just sent a reminder to razvan.

comment:13 Changed 6 years ago by planetcruiser

i signed up to geonames and added the city: http://www.geonames.org/maps/google_46.217_24.791.html

our map search now also finds it.

D.I.Y.! :)

Note: See TracTickets for help on using tickets.