Opened 7 years ago

Closed 6 years ago

#1666 closed bug (fixed)

Rox not PHP 5.3 compatible

Reported by: planetcruiser Owned by: jsfan
Priority: major Milestone: 0.8
Component: unknown Keywords:
Cc:

Description (last modified by planetcruiser)

Issue:

  • The current live server deer runs php-5.2.6, puma (upcoming new live server on Debian 6.0) will run php-5.3.3
  • Rox throws deprecation notices for eregi/eregi_replace in various places (i.e. forum)

Solution:

  • Rewrite eregi/eregi_replace usage, so no notices are shown

Clues:

Change History (14)

comment:1 Changed 7 years ago by planetcruiser

  • Description modified (diff)

comment:2 Changed 7 years ago by jsfan

  • Owner set to jsfan
  • Status changed from new to assigned

comment:3 Changed 7 years ago by jsfan

phpFlickr is currently version 2.2.0 which is not compatible with PHP 5.3, either. The current version would be version 3.1. This version is more than one year old already, as well, but hopefully works better.

Are there any reasons why we can't update to phpFlickr 3.1 or should I just try and see?

EDIT: The developer actually warns that the API has changed. So, we would probably need to assess where phpFlickr is currently used.

Last edited 7 years ago by jsfan (previous) (diff)

comment:4 Changed 6 years ago by planetcruiser

phpflickr? is that in use somewhere? i never knowingly came across it.

if yes, "try and see" sounds good to me.

comment:5 Changed 6 years ago by jsfan

I came across it in the tour. If you access /tour/meet, you'll see a bunch of error messages that all have to do with the value of new being assigned by reference.

comment:6 Changed 6 years ago by jsfan

I've just spent some time going through files and found that I might be wrong about how big a job this is. The problem is that not only Rox' core is affected but (as mentioned earlier) phpFlickr and ErfurtWiki? are as well.

phpFlickr could be updated which would fix the prolem with a bit of luck.

ErfurtWiki? does not seem to be developed any more. So far, I've only found issues with ereg(i)(_replace) which can be fixed quickly. However, I consider it a bit problematic to keep a component which has not had any updates for 7 years (cf. http://sourceforge.net/projects/erfurtwiki/files/ ).

I'll split phpFlickr and ErfurtWiki? out from this ticket into two of their own, so we can deal with them separately.

comment:7 Changed 6 years ago by planetcruiser

this looks like a huge task still. should we unlink it from the 0.8 milestone? i mean, the live site works fine on the new server. so pragmatically speaking i don't see need for action here any more.

comment:8 Changed 6 years ago by globetrotter_tt

+1 for postponing.

comment:9 Changed 6 years ago by jsfan

Well, I've pushed the changes for core code already. I tested locally and couldn't find any more errors. However, the diff contains a lot of files, so I might well have overlooked something.

I will not touch ErfurtWiki because we should replace it, anyway. I have locally updated SwiftMailer but haven't pushed those changes, yet, because I haven't had any chance to test at all.

I'm not generally opposing the suggestion to postpone. I think with our current PHP settings, we aren't clogging our logs with deprecation messages. However, if we do postpone, we definitely keep track of it because if it is forgotten altogether, things might stop working by the time the next major update of PHP comes along.

comment:10 Changed 6 years ago by globetrotter_tt

Ok, I did not know that you pushed already. So then better leave it in this milestone and move to alpha for testing. I also tested locally (PHP 5.4.4) and could not see any errors.

comment:11 Changed 6 years ago by crumbking

I found another one in admin member:

Deprecated: Function split() is deprecated in /home/crumb/webdev/bw/htdocs/bw/lib/swift/Swift.php on line 279

bw/admin/adminaccepter.php

comment:12 Changed 6 years ago by globetrotter_tt

There is already a ticket #1670 for swift mailer. How should we proceed with this ticket?

comment:13 Changed 6 years ago by crumbking

I guess close this one and go on with the swift mailer?

comment:14 Changed 6 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from assigned to closed

rox is running on the new live server since quite a while now, so i am closing this one.

please open individual tickets for incompatibilities discovered later and mention this ticket here as related ticket

Note: See TracTickets for help on using tickets.