Opened 6 years ago

Closed 5 years ago

#1670 closed bug (fixed)

SwiftMailer 4.0.3 needs update to current version

Reported by: jsfan Owned by: jsfan
Priority: critical Milestone: 2.0
Component: FrameWork Keywords:
Cc: shevek

Description

The version currently used contains some code which has been deprecated in PHP 5.3.

Change History (14)

comment:1 Changed 6 years ago by jsfan

  • Component changed from unknown to FrameWork

comment:2 Changed 6 years ago by crumbking

I just replaced with the new version locally but can't test it, yet.

Also what about htdocs/bw/lib/swift ? Seems like we have different versions on several places.

Lets merge them while touching it anyway.

comment:3 Changed 6 years ago by jsfan

I've been wondering about this SwiftMailer in /bw as well. It is an ancient version (3.1.2) and I agree that we should consolidate to one instance across all of Rox.

comment:4 Changed 6 years ago by jsfan

Merging those two instances will mean fixing (rewriting?) the forums model and finally migrating the admin pages. These two places seem to still use the instance in bw/.

comment:5 Changed 6 years ago by crumbking

What about replacing both instances without merging. I know it's kind of moving the pain to the future. ;-)

But we wanna move to PHP 5.3. that's part of this ticket. So I suggest:

A: replace both instances B: Test if everything still works fine.

For B: I replaced one instance locally but have no idea how to test that. How to I get BW mailing on ubuntu ??

comment:6 Changed 6 years ago by planetcruiser

jsfan: what do we do here? can we release 0.8 without completely fixing this?

to be honest, if the current code works apart from deprecation warnings (is this the case?) i would mark this as WONTFIX and focus on more urgent things.

crumbking: some, but not all mails can be tested by adding smtp data to the rox_local.ini. see https://gitorious.org/bewelcome/rox/blobs/master/rox_default.ini#line13 - i added this possibility a while ago

comment:7 Changed 6 years ago by jsfan

  • Resolution set to wontfix
  • Status changed from new to closed

comment:8 Changed 6 years ago by jsfan

I just tested my local version and it looks like it would need some more work. So, maybe let's go without. :)

comment:9 Changed 6 years ago by planetcruiser

just to make sure: no functionality is harmed by these outdated swiftmailer versions?

comment:10 Changed 6 years ago by jsfan

I can't guarantee it but I believe that there were only deprecation warnings but no problems with missing functionality as a consequence of outdated code.

comment:11 Changed 5 years ago by jsfan

  • Cc shevek added
  • Priority changed from major to critical
  • Resolution wontfix deleted
  • Status changed from closed to reopened

As an update to PHP 5.4 is imminent, this probably needs some attention once again. :(

comment:12 Changed 5 years ago by shevek

  • Status changed from reopened to to_alpha

Update the swift mailer to 5.0.1. Updated code to use only that one.

comment:13 Changed 5 years ago by shevek

  • Milestone changed from 0.8 to 2.0
  • Status changed from to_alpha to testing

comment:14 Changed 5 years ago by shevek

  • Resolution set to fixed
  • Status changed from testing to closed

Some adjustments made after release. All types of mails received now closing as fixed.

Note: See TracTickets for help on using tickets.