Opened 7 years ago

Closed 6 years ago

#1671 closed improve feature (fixed)

Make address fields in profile not mandatory

Reported by: globetrotter_tt Owned by: mahouni
Priority: major Milestone: 0.8
Component: BW Profile Keywords: profile, address, privacy
Cc: planetcruiser

Description

In the registration form all new members need to give his private address. This should be optional only and therefore following fields need to be removed from the signup form:

  • Street
  • Street number
  • Post code

Also we need to ensure that in the editprofile form no error message is shown we those fields are empty.

Todo for BV: Inform all existing members that their private address is now only optional and only needed when they want to be verified

Change History (13)

comment:1 Changed 6 years ago by planetcruiser

  • Milestone changed from unassigned to 0.8
  • Owner set to mahouni
  • Status changed from new to assigned

deployed to alpha, can be tested now

comment:2 Changed 6 years ago by planetcruiser

i can not add a street via http://alpha.bewelcome.org/editmyprofile any more. i am not sure if this could be a result of changes in https://gitorious.org/bewelcome/rox/commit/3e8e9b5f62d319aa596a669f0b6f2a3bb7a4f7a6 - please check

also to complete this ticket, the mandatory mark for the 3 fields needs to be removed on http://alpha.bewelcome.org/editmyprofile#!contactinfo

comment:3 Changed 6 years ago by mahouni

strange. editing the street was possible for older members, but not for new sign ups. However, it should work now. I just hope that it doesn't mess up other stuff... I don't know why set_StreetName() wasn't in members.entity.

I also removed the mandatory mark and allowed empty address fields.

comment:4 Changed 6 years ago by planetcruiser

deployed to alpha - please test.

i assume this bug was never discovered, because there was always content in the street field since user sign-up..

comment:5 Changed 6 years ago by globetrotter_tt

I have tested this successfully on alpha siging up with a profile "globetest_address". I was able to enter an adress in editmyprofile afterwards and also delete the address again.

comment:6 Changed 6 years ago by globetrotter_tt

When this is fixed, please read also #1688.

comment:7 Changed 6 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from assigned to closed

fix confirmed. i just signed up without address and added it later

comment:8 Changed 6 years ago by planetcruiser

  • Resolution fixed deleted
  • Status changed from closed to reopened

ah, one last thing: when using http://alpha.bewelcome.org/bw/updatemandatory.php?cid=<user name> to edit, ban or reject a user that didn't give an address, the form can not be submitted, because the script checks for an address. this needs to be fixed in the oldschool code (have fun, hehe). mahouni?

comment:9 Changed 6 years ago by globetrotter_tt

oh shit :( Before you dig in the old /bw code, better have a look at this ticket: #1645 When this is fixed we can dump updatemandatory.php

comment:10 follow-up: Changed 6 years ago by mahouni

back from the htdocs/bw adventure! So, let's see what kind of chain reaction the last commit will bring... ;) The empty address fields are ignored when using updatemandatory.php now. Banning a profile is still possible, anything else probably not (e.g. editing stuff), but I guess that applies to the current master too?

I don't have time to look at ticket #1645 this week.

comment:11 in reply to: ↑ 10 ; follow-up: Changed 6 years ago by globetrotter_tt

Replying to mahouni:

back from the htdocs/bw adventure! So, let's see what kind of chain reaction the last commit will bring... ;) The empty address fields are ignored when using updatemandatory.php now. Banning a profile is still possible, anything else probably not (e.g. editing stuff), but I guess that applies to the current master too?

Nice :) i could not test it on my computer, somehow my local git repo is broken - waiting until it's on alpha. We need only the field to change the member status in updatemandatory, though it would be more convenient to have it in the rox version of admineditprofile.

comment:12 in reply to: ↑ 11 Changed 6 years ago by planetcruiser

Replying to globetrotter_tt:

waiting until it's on alpha

done. sorry that i am still the bottleneck when it comes to deployments. the next time i have some solid bw hacking time (in 2 weeks?), i will implement an automated deployment for alpha.

comment:13 Changed 6 years ago by globetrotter_tt

  • Resolution set to fixed
  • Status changed from reopened to closed

cool :) http://alpha.bewelcome.org/bw/updatemandatory.php?cid=<user name> works. i tested it on "testingteam", changed the status to "banned" and then back to "activehidden"

Note: See TracTickets for help on using tickets.