Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#1693 closed task (fixed)

Turn off the "Accepter's report"

Reported by: globetrotter_tt Owned by: shevek
Priority: major Milestone: 1.9
Component: BW Mail Keywords: accepter, email, annoying
Cc: jeanyves, planetcruiser, jsfan, pablobd

Description

Volunteers with right "accepter" still receive a notification email every day.

This is not needed anymore.

Change History (25)

comment:1 Changed 6 years ago by jsfan

  • Milestone Future deleted

Milestone Future deleted

comment:2 Changed 6 years ago by shevek

  • Milestone set to unassigned

We could just remove the rights, couldn't we?

comment:3 Changed 6 years ago by crumbking

  • Owner set to pablobd
  • Status changed from new to assigned

yes, let's remove the right. Pablo?

comment:4 Changed 6 years ago by globetrotter_tt

I would be careful here. Some people still need the accepter rights for changing member status (mostly banning).

comment:5 Changed 6 years ago by pablobd

what do I have to do ?

comment:6 Changed 6 years ago by crumbking

  • Owner changed from pablobd to crumbking

@pablo: sorry for waking you up :-) nothing todo then ;-)

Okay so let's see how to disable the mail.

comment:7 Changed 6 years ago by shevek

We should know which people need this rights for banning? So we could remove the right for the others. I'd rather not touch the code for this to avoid breaking something else...

comment:8 Changed 6 years ago by pablobd

I checked, currently 32 users have admin accepter rights, with diferent scopes, there's also 4 "hidden" accounts with that right. One of them it was meant to be a Safety team account, but has no login in 4 years. Maybe they used this one to ban spammers? anyway i have no idea how the accepter tool is used to ban people, since you can't search for a member name and you can only see the last 50 active members

comment:9 Changed 6 years ago by globetrotter_tt

Pablo, could you please send me the list of all users with accepter rights, or alternatively give me rights to see them in the vol-menu.

changing the member status is done in bw/updatemandatory.php which should have been migrated to rox a long time ago: http://trac.bewelcome.org/ticket/1645

comment:10 Changed 6 years ago by crumbking

I can't get mails. Therefore if someone with a running mails could check if that works?

---------------------- htdocs/bw/admin/adminaccepter.php ----------------------
index f8092a3..3c03e07 100644
@@ -212,3 +212,3 @@ switch (GetParam("action")) {
 				   $text = wwinlang("SignupYouHaveBeenAccepted",$defaultlanguage, $m->Username, "http://".$_SYSHCVOL['SiteName'], $loginurl);
-				   bw_mail($Email, $subj, $text, "", $_SYSHCVOL['AccepterSenderMail'], $defLanguage, "yes", "", "");
+				   //bw_mail($Email, $subj, $text, "", $_SYSHCVOL['AccepterSenderMail'], $defLanguage, "yes", "", "");
 				   $StrAccept=$StrAccept.$m->Username." ";
@@ -233,3 +233,3 @@ switch (GetParam("action")) {
 				   $text = wwinlang("SignupYouHaveBeenRejected",$defaultlanguage, $m->Username,$_SYSHCVOL['SiteName']);
-				   bw_mail($Email,$subj, $text, "", $_SYSHCVOL['AccepterSenderMail'],0, "yes", "", "");
+				   //bw_mail($Email,$subj, $text, "", $_SYSHCVOL['AccepterSenderMail'],0, "yes", "", "");
 					 
@@ -249,3 +249,3 @@ switch (GetParam("action")) {
 				   $text = wwinlang("SignupNeedMoreText",$defaultlanguage, $m->Username,$_SYSHCVOL['SiteName'],$needmoretext,$urltoreply);
-				   bw_mail($Email,$subj, $text, "", $_SYSHCVOL['AccepterSenderMail'],0, "yes", "", "");
+				   //bw_mail($Email,$subj, $text, "", $_SYSHCVOL['AccepterSenderMail'],0, "yes", "", "");
 				   $StrNeedMore=$StrNeedMore.$m->Username." ";
@@ -286,3 +286,3 @@ switch (GetParam("action")) {
 		$text = ww("SignupYouHaveBeenAccepted", $m->Username, "http://".$_SYSHCVOL['SiteName'], $loginurl);
-		bw_mail($Email, $subj, $text, "", $_SYSHCVOL['AccepterSenderMail'], $defLanguage, "yes", "", "");
+		//bw_mail($Email, $subj, $text, "", $_SYSHCVOL['AccepterSenderMail'], $defLanguage, "yes", "", "");
 
@@ -302,3 +302,3 @@ switch (GetParam("action")) {
 //		bw_mail($Email,$subj,"text as test   ", "", $_SYSHCVOL['TestMail'], 0, "yes", "", "");
-		bw_mail($Email,$subj, $text, "", $_SYSHCVOL['AccepterSenderMail'],0, "yes", "", "");
+//		bw_mail($Email,$subj, $text, "", $_SYSHCVOL['AccepterSenderMail'],0, "yes", "", "");

comment:11 Changed 6 years ago by globetrotter_tt

  • Cc jeanyves pablobd added; jean-yves removed

Should we inform all people with accepter rights about this. Maybe there is someone who like to get the same notification every day for some reason?


  • Accepter's report
  • No confirmed signup
  • No accepted
  • No needmore in the period
  • 0 total members are waiting for accepting at 2012-12-29 09:00:02
  • Your accepting Scope is for all countries
  • No pending member you can accept
  • No member rejected in the period
  • No member who have left by themself in the period
  • No member who have Been TakenOut? by support team because they requested it in the period

BeWelcome site This is an automatic email. Do not answer it but accept the pending members !

comment:12 Changed 6 years ago by shevek

Plenty of time to do that as this will only happen after 1.3.

comment:13 Changed 6 years ago by pablobd

I just gave proper rights for globetrotter_tt

comment:14 Changed 5 years ago by pablobd

I set my accepter rights to zero (because rox does not actually let you "remove" a right) and I'm still getting the reports.

comment:15 Changed 5 years ago by pablobd

This is confirmed: there is no way to delete the rights from former volunteers, every one of thems get every day the "accepter report" even if the right is set to zero

comment:16 Changed 5 years ago by shevek

If that's the case we should probably cleanup the database.

comment:17 Changed 5 years ago by shevek

  • Milestone changed from unassigned to 1.9
  • Owner changed from crumbking to shevek

Allow to delete rights in the admin backend should fix this.

Added to milestone 1.9.

comment:18 Changed 5 years ago by shevek

  • Status changed from assigned to to_alpha

comment:19 Changed 5 years ago by pablobd

It seems deleting the rights works well, I will wait a couple of days to see if I still get the anoying message again

comment:20 Changed 5 years ago by shevek

  • Status changed from to_alpha to testing

comment:21 Changed 5 years ago by pablobd

Confirmed: after deleting the rights the report is no longer sent

comment:22 Changed 5 years ago by pablobd

one detail: after using the delete button for the rights I get the rights form with the same username I entered to search but the rights selector has selected the right I just deleted, a better behavior would be to have "all" selected by default since that user certainly does not have that right anymore, this way I can click find again and see the rest of the rights for that user.

comment:23 Changed 5 years ago by shevek

  • Resolution set to fixed
  • Status changed from testing to closed

As the current implementation solves the accepters report problem, I close this ticket and open a new one for a better delete rights behavior.

comment:24 Changed 5 years ago by pablobd

strangely I got the accepters report again in my mailbox 7 hours ago...

comment:25 Changed 5 years ago by shevek

Please let me know if it happens again. I checked the code but couldn't find a reason why you should have gotten it without that 'Accepter' right.

Note: See TracTickets for help on using tickets.