Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1701 closed bug (fixed)

OSM: "Zoom In" in markertext doesn't work

Reported by: midsch Owned by: planetcruiser
Priority: minor Milestone: 1.2
Component: BW Geo Keywords: OSM map marker
Cc:

Description

Again: Chromium 18.0.1025.168 (Entwickler-Build 134367 Linux) Ubuntu 12.04 Again: http://rox.mishk.org/searchmembers

Do a search, klick on a marker on the map and a text for the marker is displayed. While "Zoom Out" zooms the map out to maximum, "Zoom In" doesn't work at all.

java console: searchmembers.js:84Running text search (address='france', i=0)... BWGoogleMapReverseGeolocator.js:106Try to reverse geolocate address 'france'. BWGoogleMapReverseGeolocator.js:130Search places containing text "france". BWGoogleMapReverseGeolocator.js:133Search places containing text "france" returned 1 results. BWGoogleMapReverseGeolocator.js:16Building address point 'Frankreich' BWGoogleMapReverseGeolocator.js:40Location: BWGoogleMapReverseGeolocator.js:81Zoom level is 5 searchmembers.js:118Search by address point 'Frankreich': 46.227638,2.213749 OSMMapBuilder.js:148Center to (46.227638, 2.213749) with zoom level 5. searchmembers.js:145Loading map (0)... BWGeosearchMapBuilder.js:53Adding layer controls searchmembers.js:149Search members (varsOnLoad=, varSortOrder=, queries=) searchmembers.js:158Search success: processing the results... searchmembers.js:167Parsing results... BWMapSearchResult.js:25Parsing XML response... BWMapSearchResult.js:26 #document BWMapSearchResult.js:56Number of results:4 searchmembers.js:172Adding the pager... BWMapSearchResult.js:99Reading the 4 points... BWMapSearchResult.js:115Combine points summaries when coordinates and accomodation is the same... BWMapSearchResult.js:133Space markers that have the same geo-coordinates... BWMapSearchResult.js:1074 points have been read. searchmembers.js:198Adding the 4 markers... searchmembers.js:310Map succesfully loaded BWGeosearchMapBuilder.js:216Uncaught TypeError?: Cannot read property 'osmMapBuilder' of undefined OSMMapBuilder.js:171Zoom to level 1. 2 BWGeosearchMapBuilder.js:216Uncaught TypeError?: Cannot read property 'osmMapBuilder' of undefined

Change History (12)

comment:1 in reply to: ↑ description Changed 6 years ago by crumbking

Replying to midsch:

Do a search, klick on a marker on the map and a text for the marker is displayed. While "Zoom Out" zooms the map out to maximum, "Zoom In" doesn't work at all.

I could not reproduce this with chrome (21) on Ubuntu.

It works as expected. Anyone else? Maybe a specific chrome 18 issue?

comment:2 Changed 6 years ago by midsch

For me it also doesn't work with FF 14.0.1, Konqueror (Version 4.8.4 unter KDE 4.8.4) or Midori 0.4.3 on Ubuntu. Now I'm running out of browsers ... Konqueror (usually I never use this one!) reports: "Fehler: Node : TypeError?: Undefined value" while clicking on "zoom in"

comment:3 Changed 6 years ago by toub

This is a refactoring regression. I reproduced it and fixed it localy.

comment:4 Changed 6 years ago by toub

  • Owner changed from toub to planetcruiser
  • Status changed from new to assigned

Fixed, merged with develop branch, then pushed to a new temporary branch named "osm": https://gitorious.org/bewelcome/rox/commits/osm

Ready for tests and review.

comment:5 Changed 6 years ago by midsch

For me it works fine now with Chromium 18, Firefox 15, Midori 0.4.3 on a box with Ubuntu 12.04.

comment:6 Changed 6 years ago by crumbking

Tested locally on develop. Lets's move to alpha. No issue anymore.

comment:7 Changed 6 years ago by toub

ok in alpha

comment:8 Changed 6 years ago by midsch

Fine on alpha with Chromium Version 20.0.1132.47 Ubuntu 12.04 (144678)

comment:9 Changed 6 years ago by globetrotter_tt

  • Resolution set to fixed
  • Status changed from assigned to closed

It worked for me with Firefox 17, Chromium 22 and Opera 12. I am closing this one.

comment:10 follow-up: Changed 6 years ago by shevek

Zoom in centers on the location. The truncation of the profile summary is too long so that most of the times the close 'x' on the marker isn't visible anymore. Ugly.

Zoom out doesn't fix this. Additionally zoom out isn't going back to the same zoom level as before.

comment:11 in reply to: ↑ 10 Changed 6 years ago by planetcruiser

Replying to shevek:

Zoom in centers on the location. The truncation of the profile summary is too long so that most of the times the close 'x' on the marker isn't visible anymore. Ugly.

i agree, it's ugly. i don't know if the zoom buttons in the popup make any sense at all when markers are more or less randomly placed. all they do is causing problems. ;) i would be fine with simply removing them.

Zoom out doesn't fix this. Additionally zoom out isn't going back to the same zoom level as before.

this has to do with the zoom centre not being the marker, but the place coordinates. all markers should appear in the exact same spot, the centre of a place according to geonames, but because that doesn't make sense, someone decided to do this star-shaped placement around the centre. this should somehow be resolved later.

but both things are different bugs. the original issue of this ticket was fixed.

comment:12 Changed 6 years ago by shevek

Well, you probably only click on zoom in after a boundary search for the world, so not really needed... :)

@Zoom level: No, I meant something different. If you search for world boundaries select one of the markers click zoom in and after that zoom out I'd expect the map being back on world but that doesn't happen.

Note: See TracTickets for help on using tickets.