Opened 6 years ago

Closed 6 years ago

#1724 closed bug (fixed)

Reply button in forum threads, for Chrome, is not always displayed

Reported by: James_Oder_Dave Owned by: crumbking
Priority: critical Milestone: 1.3
Component: BW Forum Keywords: reply forums missing
Cc: crumbking

Description

The reply button on the forums is not always displayed.

A users first thought may be that the thread is either locked or that they cannot post in the group without joining it. However these do not seem to be the issue.

More information on the causes of the bug may be found here: http://lists.bewelcome.org/pipermail/bw-dev-discussion/2012-August/009024.html

http://lists.bewelcome.org/pipermail/bw-dev-discussion/2012-September/009098.html

A quick fix for this to tell users is to simply add /reply to the end of a url.

i.e http://www.bewelcome.org/forums/s2650-Tracking_where_new_users_have_come_from

To reply would become http://www.bewelcome.org/forums/s2650-Tracking_where_new_users_have_come_from/reply

Change History (16)

comment:1 Changed 6 years ago by James_Oder_Dave

I also have found that some posts do not seem to have an edit button.

This may be a separate issue, but may equally be related.

comment:2 Changed 6 years ago by TimLoal

I am now not getting either to or bottom reply buttons in Chrome.

This seems to be a rendering issue in Chrome and I suggest an investigation on a CSS level.

LnP

comment:3 Changed 6 years ago by TimLoal

  • Summary changed from Reply button on forums not always displayed to Reply button in forum threads, for Chrome, is not always displayed

comment:4 Changed 6 years ago by jsfan

  • Milestone Future deleted

Milestone Future deleted

comment:5 Changed 6 years ago by jsfan

  • Milestone set to unassigned

#1749 is duplicate of this.

comment:6 Changed 6 years ago by jsfan

The problem is an overflow:hidden on div.pages. Disabling that, the reply button becomes visible again. Not sure what it is needed for, anyway. Can anyone think of a reason why we need to have it?

comment:7 Changed 6 years ago by jsfan

  • Cc crumbking added

comment:8 Changed 6 years ago by crumbking

Mmmm... I have a different behaviour. Removing the overflow hidden shows the pagination again while not logged in.

While logged in I see the reply button. So I can't really reproduce the bug. Maybe someone could point me to a buggy thread?

comment:9 Changed 6 years ago by jsfan

Oops, sorry. I actually mixed up the two problems of missing pagination and missing reply button...

Both pagination and reply button disappear in pretty much any thread for me on Chromium. The pagination seems to vanish due to the overflow but not the reply button. You can verify this on any long thread e.g. on http://www.bewelcome.org/forums/s2927-profile_visitors_feature.

The reply button does NOT vanish due to an overflow. In fact the whole div seems to be invisible even if it has no styles attached to it. No matter how it is wrapped, it will fall behind the divs that form the thread and the bottom reply button will never be visible (you can see the top one).

comment:10 Changed 6 years ago by crumbking

Ouch, I realized that I had chromium installed. Now I installed chrome and yes I can reproduce the bug.

I guess I found a solution for both issues:

fix for the pagination (proper testing needed as used on all over the place)

-  div.pages {padding:1em 0; white-space: nowrap; overflow:hidden;  }
+  div.pages {padding:1em 0; white-space: nowrap; overflow:hidden; width:100%  }

fix for the hidden reply button

div#forumsthreadreplybottom {
+    overflow: hidden;
+    padding-top: 0.7em;
}

getting the pagination in line with the reply button, needs proper testing as used all over the place

-  div.pages li{ ..... padding: 0 0.2em; }
+  div.pages li{ ..... padding: 0 0 0 0.7em; }

and 

@@ -486,7 +486,7 @@ dl.list {
     color: #ff8800;
     height:18px !important;
     line-height:16px !important;
-    margin:.2em;
+    margin: 0;
....
}

comment:11 Changed 6 years ago by jsfan

I've just tried that on Chromium (which is where I had the problems!) and it fixes the issue for me. :)

comment:12 Changed 6 years ago by crumbking

  • Milestone changed from unassigned to 1.3
  • Owner set to crumbking
  • Status changed from new to assigned

comment:14 Changed 6 years ago by jsfan

Deployed on alpha.

comment:15 Changed 6 years ago by shevek

'Reply' button and paginator visible in Chrome 25.0.1364.5 dev-m (Windows).

comment:16 Changed 6 years ago by shevek

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.