Opened 10 years ago

Closed 5 years ago

Last modified 5 years ago

#173 closed bug (fixed)

wrong https redirects for bewelcome

Reported by: midsch Owned by:
Priority: minor Milestone: 0.8
Component: ServerSetup Keywords: redirect links, hot
Cc: Tobixen

Change History (18)

comment:1 Changed 10 years ago by philipp

  • Component changed from BW General to ServerSetup
  • Milestone changed from 0.1-outreach-release to unassigned

comment:2 Changed 10 years ago by micha

  • Cc Tobixen added
  • follow_up set to none
  • Milestone changed from unassigned to 0.1.2 - more improvements & bugfixing

maybe Tobias should have a look at this one. Will add it to 0.1.2

comment:3 Changed 9 years ago by philipp

  • freq_reported set to 5
  • Keywords hot added
  • Milestone changed from 0.1.4 - improving userinterface for members and volunteers and start work on big 0.2 tasks to 0.5.1-short cleanup I
  • Priority changed from major to blocker
  • show_on_bw set to 0

this is especially bad as https://www.bewelcome.org still redirects to joomla while http://bw.org forwards to https://bw.org - thus bookmarks will not work, please fix!!!!

comment:4 Changed 9 years ago by guaka

https://www.bewelcome.org/ is working now, but https://bewelcome.org/ is still redirecting to bevolunteer.org

Less important: https://alpha.bewelcome.org is doing weird stuff (good, but no css), and https://test.bewelcome.org is redirecting to bevolunteer.org

comment:5 Changed 9 years ago by guaka

  • Priority changed from blocker to minor

https://bewelcome.org is working now thanks to tobixen, alpha and test are not so important, so I'm downgrading the priority

comment:6 Changed 9 years ago by tobixen

  • follow_up changed from none to test

I have changed the IP of bewelcome.org to www.bewelcome.org, but I haven't figured out how to set up redirection in apache yet. In general, virtual hosts doesn't work well with SSL - but I've heard it should work as long as one uses the same certificate files for the virtual domain, though ... no luck so far. But who needs redirection anyway? https://bewelcome.org/ probably works well without symlink? Please test.

I've left all the alternative domain names (bwelcome.org and bewelcome.eu for instance) as for now - so they are all pointing to bevolunteer.

When it comes to test and alpha ... those are virtual domains, so same story as above. It should be possible to get it to work with SSL (though, using the www.bewelcome.org certificate, so that people will get warning messages), but I don't know how to do it.

I'll attach the current SSL configuration.

comment:7 Changed 9 years ago by tobixen

attaching it ... inline:

Listen 447
NameVirtualHost *:447

<VirtualHost *:447>

  DocumentRoot /home/bwrox/ssl
  <Directory /home/bwrox/ssl/> 
    Options Indexes FollowSymLinks MultiViews
    AllowOverride None
    Order allow,deny
    allow from all
  </Directory>

  SSLCertificateFile /home/bwrox/configs/apache2/ssl/www.bewelcome.org.crt
  SSLCertificateKeyFile /home/bwrox/configs/apache2/ssl/www.bewelcome.org.key
  SSLEngine On
  
</VirtualHost>


<VirtualHost *:447>
  ## I'd hope requests to https://bewelcome.org/ could be forwarded
  ## ... but seems like we're never getting here?
  RewriteEngine On
  RewriteRule /(.*) https://www.bewelcome.org/$1 [R=301,L]
  ServerName bewelcome.org
  SSLCertificateFile /home/bwrox/configs/apache2/ssl/www.bewelcome.org.crt
  SSLCertificateKeyFile /home/bwrox/configs/apache2/ssl/www.bewelcome.org.key
  SSLEngine On
</VirtualHost>

comment:8 follow-up: Changed 9 years ago by midsch

https://bewelcome.org/ and https://www.bewelcome.org/ is working (after login the first is turned into the second).

https://test.bewelcome.org/ and https://alpha.bewelcome.org/ kind of works, but there are no style sheet informations and probably some scripts missing.

comment:9 in reply to: ↑ 8 Changed 9 years ago by tobixen

Replying to midsch:

https://bewelcome.org/ and https://www.bewelcome.org/ is working (after login the first is turned into the second).

Yes, but the correct behavior is that https://bewelcome.org/ should redirect at once to https://www.bewelcome.org/ ... (hm, I think I know a way to fix it ...)

https://test.bewelcome.org/

No! It is not true ... test.bewelcome.org is currently pointing to our primary web server! What you see there is not what you should see. It appears test.bewelcome.org is a CNAME to bewelcome.org. Ok, fixed now ...

and https://alpha.bewelcome.org/ kind of works, but there are no style sheet informations and probably some scripts missing.

Kind of works? It will use same code as www.bewelcome.org, but not the same configuration ...

comment:10 Changed 9 years ago by midsch

https://bewelcome.org/ should redirect at once to https://www.bewelcome.org/ ..

that's even better ;)

https://test.bewelcome.org/ now redirects to http://www.bevolunteer.org/joomla/ (as original in this ticket)

for https://alpha.bewelcome.org/ the starting page looks like kind of working, but there are no style sheet informations and probably some scripts missing, but i. e. the gallery link leads to http://localhost/bw-trunk/htdocs/gallery

comment:11 Changed 9 years ago by tobixen

I think I managed to get https://bewelcome.org/ to redirect to https://www.bewelcome.org/.

I'm now working on getting https://alpha.bewelcome.org/ to work. What you see there now is production code, not alpha code, and some of the configuration is not working.

comment:12 Changed 9 years ago by tobixen

I found out of most of the mistakes I've done ;-)

bewelcome.org and www.bewelcome.org works as it should, both in https and http ...

alpha.bewelcome.org works as it should now, both in https and http ... it does indeed give a certificate warning - if anyone minds, it's easy to fix - pay for a new IP and cert ;-)

I don't care about test.bewelcome.org today ... and I neither don't care about old today.

I need to sleep ;-)

comment:13 Changed 9 years ago by tobixen

I had to break https://bewelcome.org/ ... mailman broke due to the IP change.

comment:14 Changed 9 years ago by feuerdaemon

  • follow_up changed from test to release

Seems fixed. All the links work fine now.

comment:15 Changed 9 years ago by guaka

  • follow_up changed from release to none
  • Resolution set to fixed
  • Status changed from new to closed

I think the ticket is fixed enough now to close it :)

https://test.bewelcome.org is not of vital importance.

comment:16 Changed 6 years ago by bikepunk

  • Milestone changed from 0.5.2-short cleanup and framework to unassigned
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:17 Changed 5 years ago by crumbking

  • Milestone changed from unassigned to 0.8
  • Resolution set to fixed
  • Status changed from reopened to closed

I can't reproduce that anymore so I guess it's fixed :-)

comment:18 Changed 5 years ago by planetcruiser

wow, i didn't know the bug is sooo old. yes, i fixed it a few days ago without knowing there was a ticket for it: http://lists.bewelcome.org/pipermail/bw-dev-discussion/2012-May/004234.html

Note: See TracTickets for help on using tickets.