Opened 5 years ago

Last modified 3 years ago

#1736 needs_work bug

Target field in Insert/Edit link, has no effect

Reported by: TimLoal Owned by: TimLoal
Priority: major Milestone: backlog
Component: BW Forum Keywords: Forum, Links, Target Field
Cc:

Description

Setting the Target field to open in a new window, has no effect on the resulting link and all links open in the same window.

While you're there if the default for this field could be open in a new window, that would be great for everyone.

LnP

Ps this is minor from a technical view, but a bigger issue from the members view, which is why I have set this to major.

Change History (12)

comment:1 Changed 5 years ago by TimLoal

  • Owner set to TimLoal
  • Status changed from new to assigned

This is related to the editor, so will be fixed in the improved editor.

LnP

comment:2 Changed 5 years ago by jsfan

  • Milestone Future deleted

Milestone Future deleted

comment:3 Changed 4 years ago by shevek

  • Milestone set to 2.1

The editor doesn't have anything to do with it. In fact the HTMLPurifier is configured to strip anything except the href attribute.

While I agree that it would be nice to have links pointing to a new window/tab I read different opinions as well.

Lets see what happens if we fix that :-)

comment:4 Changed 4 years ago by shevek

  • Status changed from assigned to local_testing

Updated HTMLpurifier to be able to use HTMLTarget.Blank for links that are pointing outside of bewelcome. (Note: That means all links that do use / or no http:// https:// no effort is taken to ensure that for links like http://www.bewelcome.org)

This change might affect mail sending (/htdocs/bw/lib/mailer.php use HTMLPurifier as well).

Commit: http://gitorious.org/bewelcome/rox/commit/cecddff6d596e8b323f6bb398b1fb375d8834f10

comment:5 Changed 4 years ago by shevek

  • Status changed from local_testing to to_alpha

comment:6 Changed 4 years ago by shevek

  • Status changed from to_alpha to testing

comment:7 Changed 4 years ago by sitatara

Works well but is not solving the reported issue.

comment:8 Changed 4 years ago by shevek

  • Milestone changed from 2.1 to 2.2

Actually I'm not sure if it works. Some links open in the same window which should open in a new one.

All links that I created using 'Open in new window' open in a new window. That would solve the reported issue.

I leave the ticket open and move it to 2.2 for observation.

comment:9 Changed 4 years ago by shevek

  • Milestone changed from 2.2 to 2.3
  • Status changed from testing to needs_work

Moved to 2.3.

comment:10 Changed 3 years ago by crumbking

what's the status here?

comment:11 Changed 3 years ago by crumbking

  • Milestone changed from 2.3 to 2.4

move into 2.4 to cleanup

comment:12 Changed 3 years ago by crumbking

  • Milestone changed from 2.4 to backlog

as nobody worked in 2.4 on it and it's on observation we move it back to backlog

Note: See TracTickets for help on using tickets.