Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1777 closed bug (fixed)

Verification icon not displayed

Reported by: jsfan Owned by: shevek
Priority: critical Milestone: 1.3
Component: BW Profile Keywords:
Cc:

Description (last modified by crumbking)

Issue:

  • Currently, only people who were verified by "super verifiers" seem to have the badge displayed in their profiles.

Solution:

  • Display badge as soon as someone has been verified by any ordinary member.

related:

Change History (14)

comment:1 Changed 6 years ago by beatnickgr

really? i have the badge, i verified with another non-verified user..

comment:2 Changed 6 years ago by shevek

@beatnickgr: Just checked your profile and for me it doesn't show the badge next to your username.

I vote that this is higher than minor as verification is about trust building and therefore essential to a hospex network.

comment:3 Changed 6 years ago by shevek

  • Priority changed from minor to critical

comment:4 Changed 6 years ago by beatnickgr

shevek, you're right, i confused the icons (they're not very obvious, or i'm a newbie)... anyway.

I think only already-verified members should verify new members. Else, anybody could open 2 profiles, verify one with the other, and vice versa.

comment:5 Changed 6 years ago by crumbking

If you check this page:

http://www.bewelcome.org/verifymembers/verifiersof/beatnickgr

it says not verified. So I guess that's why there is no badge.

comment:6 Changed 6 years ago by crumbking

  • Description modified (diff)

Added a related ticket.

Last edited 6 years ago by crumbking (previous) (diff)

comment:7 Changed 6 years ago by jsfan

Just for the sake of completeness... The related ticket is #1790. ;)

comment:8 Changed 6 years ago by shevek

  • Owner set to shevek
  • Status changed from new to assigned

I believe I found the culprit.

comment:9 Changed 6 years ago by shevek

Empty verification type in DB now interpreted as Normal (as intended).

Fixed a layout error on verification/XXXX/proceed when the address wasn't given completely (rough fix with   probably a CSS would be better).

(Commit https://gitorious.org/bewelcome/rox/commit/9088f2683f2b647168a829450a625f8eaded84d8 )

comment:10 Changed 6 years ago by shevek

  • Milestone changed from unassigned to 1.3
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:11 Changed 6 years ago by shevek

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:12 Changed 6 years ago by jsfan

Deployed on alpha.

comment:13 Changed 6 years ago by shevek

  • Resolution set to fixed
  • Status changed from reopened to closed

Went through a long list of candidates from an DB excerpt and all show a verification icon now.

Beatnick's profile now says verified by another member. Which should always have been the case with that number of verifications.

As there are still a number of profiles that don't show a badge I guess the fix wasn't just enabling the badge everywhere.

comment:14 Changed 6 years ago by jsfan

Deployed on alpha.

Note: See TracTickets for help on using tickets.