Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1778 closed bug (fixed)

problems with invitations and moderators

Reported by: beatnickgr Owned by: beatnickgr
Priority: major Milestone: 1.2
Component: BW Group Keywords:
Cc:

Description

When a group accessibility is set to "New members need to be approved by the group moderator" we have the following problems:

1) The admin gets no notification, unless he visits his group and clic "administrate members" (that's not something that the admin does everyday...)

=> there should be a notification on the main page of the admin, that <username> want to join <group>, with a link to http://alpha.bewelcome.org/groups/837/memberadministration

2) When this member is accepted, he's got a notification on front page that "You have been accepted by the group's founder." no more details.

=> there should be the groupname, and it should be clickable.

3) When the admin of this group tries to leave without resining, there's a message that "An error occured while leaving the group."

=> This should be replaced by "You cannot leave <groupname> because you're an administrator. PLease resign first and try again"

4) If you're a group admin and resign, it's impossible to have a new admin.

=> It should be forbiden to resign if you're the last admin. There should be a message "please promote a new admin before resining."

5) When admin invites a member to a private group, there'a a link on his frontpage that "You have been invited to the group <groupname>." but it's not clicable. When going to this group, the user gets a message "not public"

=> The member should have a link on his frontpage to "Accept/Decline?" because if he has been invited, he should be able to join and see the group.

Change History (10)

comment:1 follow-ups: Changed 6 years ago by jsfan

  1. not resolved yet (need to investigate why the notification is not sent)
  2. This is a problem with the translation string. The group's name is passed but not used in the string. The word GroupsAcceptedIntoGroup needs to be corrected.
  3. Displaying error message now and redirecting to member admin page
  4. Admin cannot resign if no other admins present
  5. I cannot reproduce this. I get a full message which includes the clickable links to accept or decline.
Last edited 6 years ago by jsfan (previous) (diff)

comment:2 in reply to: ↑ 1 Changed 6 years ago by jsfan

Replying to jsfan:

  1. I cannot reproduce this. I get a full message which includes the clickable links to accept or decline.

Got it now. You are referring to the notice on the home page while I was talking about the message. The message in the mailbox is ok and maybe the notice could be a link to that message. However, I suspect that the message ID might not be available at the time the notice is written.

comment:3 Changed 6 years ago by jsfan

beatnickgr, would you mind moving the two remaining issues to two separate new tickets and close this one once you are satisified everything works as expected?

comment:4 Changed 6 years ago by jsfan

  • Milestone changed from unassigned to 1.2

comment:5 Changed 6 years ago by jsfan

  • Owner changed from jsfan to beatnickgr
  • Status changed from new to assigned

comment:6 in reply to: ↑ 1 Changed 6 years ago by jsfan

Replying to jsfan:

  1. not resolved yet (need to investigate why the notification is not sent)

This should now be resolved as #1785.

I'd declare #5 a wontfix, so this ticket can be closed once tested.

comment:7 Changed 6 years ago by beatnickgr

  • Resolution set to fixed
  • Status changed from assigned to closed

most problems have been solved, i will open new tt for the remaining ones. thank you jsfan.

comment:8 Changed 6 years ago by mahouni

4) is kind of a feature. There are groups without admins, for instance the couchsurfing group.

comment:9 follow-up: Changed 6 years ago by jsfan

mahouni, you think I should allow it again? A BW admin can always re-appoint an admin, so possibly we could live with this. I would still leave the barring from leaving the group while admin, though.

comment:10 in reply to: ↑ 9 Changed 6 years ago by mahouni

Replying to jsfan:

mahouni, you think I should allow it again? A BW admin can always re-appoint an admin, so possibly we could live with this. I would still leave the barring from leaving the group while admin, though.

I don't know if the groups without admins really make sense.

I think it is okay if you disabled that the last admin leaves the boat. If needed and wanted, we could add that possibility later again.

Note: See TracTickets for help on using tickets.