Opened 6 years ago

Closed 5 years ago

#1782 closed bug (fixed)

Joining group fails with just one generic error message

Reported by: jsfan Owned by: Tsjoek
Priority: minor Milestone: 2.1
Component: BW Group Keywords:
Cc: planetcruiser

Description

Issue:

  • If joining a group fails because the member already have an affiliation with the group (member, waiting for approval or banned), only one generic error message is displayed (based on a boolean return value)

Solution:

  • There is no easy way to solve this other than duplication checks or having a generic error message that includes all possibilities.

Change History (6)

comment:1 Changed 6 years ago by jsfan

Maybe another possibility would be not to render the join form again if there is already a pending request.

comment:2 Changed 5 years ago by Tsjoek

  • Milestone changed from unassigned to 2.1
  • Owner set to Tsjoek
  • Status changed from new to assigned

comment:3 Changed 5 years ago by Tsjoek

  • Status changed from assigned to local_testing

https://gitorious.org/bewelcome/rox/commit/7f1d74ec29690ce7acc0bca01a0ed8a68f3dab74

used the suggestion from comment 1 for banned and waiting users, seemed also more friendly to me than a flashing red error message. If you are already a member the button becomes a leave button instead so no problem there. You still get the error if you join a second time by manipulating the url, which is just fine.

Added wordcodes: GroupsBanned, GroupsAlreadyApplied

comment:4 Changed 5 years ago by shevek

  • Status changed from local_testing to to_alpha

comment:5 Changed 5 years ago by shevek

  • Status changed from to_alpha to testing

comment:6 Changed 5 years ago by shevek

  • Resolution set to fixed
  • Status changed from testing to closed

The issue is fixed. Closed.

Note: See TracTickets for help on using tickets.