Opened 6 years ago

Closed 6 years ago

#1785 closed bug (fixed)

Notification about pending group join requests not sent

Reported by: jsfan Owned by: jsfan
Priority: major Milestone: 1.2
Component: BW Group Keywords:
Cc: planetcruiser, jeanyves, beatnickgr

Description

Issue:

  • When a member tries to join a group which requires approval, a notification to the group admin is stored but never sent. The problem is that the sender ID of the message is set to 0 which means that mailbot will ignore it (failing join). As a result, a group admin only finds out about pending members by checking the members administration page manually.

Solution:

  • The message can just be assigned the ID of the joining member.

Change History (11)

comment:1 follow-up: Changed 6 years ago by jsfan

I have fixed the bug and deployed the fix on alpha.

https://gitorious.org/bewelcome/rox/commit/239a90dc12eba59eddc307ccf964cc38346474e8/diffs/549e60d380a97803c00bd6a062d46e6e8be7353c

The problem is that we have more than 140 messages sitting in the live database (since Sep 2011) which will never be sent. Some of them might be obsolete but others still relevant. What do we do with them?

My suggestion for a workaround:

  • Run a query to set the sender to the receiver ID for all those messages and have Mailbot deliver them.
UPDATE messages SET IdSender=IdReceiver WHERE IdSender=0;

comment:2 Changed 6 years ago by jsfan

  • Cc beatnickgr added

comment:3 follow-up: Changed 6 years ago by jsfan

Also: Should we hotfix this in master?

comment:4 in reply to: ↑ 3 Changed 6 years ago by planetcruiser

Replying to jsfan:

Also: Should we hotfix this in master?

if this is not a result of the last release, is see no reason for a hotfix.

instead, we should make sure 1.2 is released as soon as possible.

comment:5 in reply to: ↑ 1 Changed 6 years ago by planetcruiser

Replying to jsfan:

The problem is that we have more than 140 messages sitting in the live database (since Sep 2011) which will never be sent. Some of them might be obsolete but others still relevant. What do we do with them?

My suggestion for a workaround:

  • Run a query to set the sender to the receiver ID for all those messages and have Mailbot deliver them.
UPDATE messages SET IdSender=IdReceiver WHERE IdSender=0;

we could do that. but only together with an announcement that explains the deferred delivery of those messages.

comment:6 Changed 6 years ago by jsfan

This should be fixed now. Happy to make an announcement and deliver stuck messages to flush them out.

comment:7 Changed 6 years ago by globetrotter_tt

Tested it on alpha and received a notification mail, though it looks a bit strange:

You have received a mail from testpending1327 Hello matthias,

You have received the following message from member testpending1327:
------------------------------------------------

Hi matthiastestpending1327 wants to join the group The hidden group. To administrate the group members click the following link: group member administration.Have a great timeBeWelcome
------------------------------------------------

What do you want to do next?

Reply to the message
Visit the profile of testpending1327
Check your BeWelcome inBox

Have a nice day!
Greetings from the volunteers

comment:8 Changed 6 years ago by crumbking

Seems not to read the br's.

Check groups.model.php line 838.

Ohh... and translatable mail would be great :-)

comment:9 Changed 6 years ago by jsfan

  • Resolution set to fixed
  • Status changed from new to closed

Moved this to a new ticket #1804. No need to fix the formatting problems in this milestone.

Closing.

comment:10 Changed 6 years ago by beatnickgr

  • Resolution fixed deleted
  • Status changed from closed to reopened

This is still not working, i reopen the tt.

Somebody tried to join the moderated group of which i'm administrator, i received no notification. http://alpha.bewelcome.org/groups/837/memberadministration

comment:11 Changed 6 years ago by jsfan

  • Resolution set to fixed
  • Status changed from reopened to closed

The notification is currently only sent if someone joins on alpha. Do you know that this was the case? If you do, please re-open again.

Note: See TracTickets for help on using tickets.