Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1821 closed unknown (fixed)

TinyMCE upgrade 3.5.8

Reported by: mahouni Owned by: mahouni
Priority: minor Milestone: 1.5
Component: FrameWork Keywords: editor
Cc:

Description

At the moment we are using TinyMCE 3.5.4. There was a release of TinyMCE 3.5.8 on 25th of November 2012 with bug-fixes an improved features. They also announced a new major Version 4, with massive changes (there is no release date yet).

I already tested a branch with TinyMCE 3.5.6. But would do the upgrade now to 3.5.8.
https://gitorious.org/~mahouni/bewelcome/mahouni-rox/commits/tinymce_upgrade

Additional possibilities:

Change History (51)

comment:1 Changed 6 years ago by guaka

Isn't it better to ditch wysiwyg?

In my experience it's always a big reason for trouble (not just inside BW).

We could just support something like markdown and it will be fine for the majority of users.

comment:2 Changed 6 years ago by guaka

Actually there was a whole thread about this with a somewhat vague conclusion to drop wysiwyg.

See http://lists.bewelcome.org/pipermail/bw-dev-discussion/2012-October/009434.html

comment:3 follow-up: Changed 6 years ago by jsfan

IMHO there should be a WYSIWYG editor which can be disabled and has a source view as well. This would allow everyone to make up their minds for themselves.

comment:4 Changed 6 years ago by planetcruiser

let's just upgrade tinymce for now and rethink w5g for welen?

comment:5 Changed 6 years ago by mahouni

This is about maintenance of current ROX code.

Not a big thing, just downloading the most recent stable release, replace htdocs/script/tiny_mce, git add and git commit all new and modified files, test if everything is still working.

We don't have have a completely outdated version running, so it is not on the top priority list, but it is still better to update in one of the next milestones.

comment:6 Changed 6 years ago by guaka

This requires some testing though. Things might improve, or they might be even worse...

comment:7 in reply to: ↑ 3 ; follow-up: Changed 6 years ago by globetrotter_tt

Replying to jsfan:

IMHO there should be a WYSIWYG editor which can be disabled and has a source view as well. This would allow everyone to make up their minds for themselves.

We can have this option for TinyMCE. It's only adding one line of code.

comment:8 Changed 6 years ago by guaka

An option to turn off WYSIWYG would be excellent. (And it will make me a much happier BW forum poster ;)

(Even better if this settings was saved somehow but that would extend the scope of this. It could however quickly store the setting in a cookie somewhere, so there's no need to store it in the database.)

comment:9 Changed 6 years ago by mahouni

ugrade to 3.5.8:
http://gitorious.org/~mahouni/bewelcome/mahouni-rox/commits/tinymce_358

I tested it locally for forum posts. Works for me..

there is a lot of additional customizing possible (or decostumizing: do we need the preview and fullscreen button?), just add or remove one keyword in the script where tinymce is loaded.

e.g allow for browser spell checkers: add to tinyMCE.init(

 gecko_spellcheck : true

in the forums editcreateform

comment:10 Changed 6 years ago by mahouni

  • Priority changed from major to minor

comment:11 Changed 6 years ago by planetcruiser

@mahouni: i am not sure what the preview button does, but i think we can safely drop the fullscreen one. +1 for spell-check on

comment:12 Changed 6 years ago by guaka

What about the possibility to completely disable wysiwyg? Every time I use anything wysiwyg on BW I get highly annoyed by it.

Last edited 6 years ago by guaka (previous) (diff)

comment:13 Changed 6 years ago by shevek

I also vote for a possibility to disable WYSIWYG entirely.

I always thougth preferences are very difficult to handle because of the HTML in EvalString? but as we've seen now that you don't need that at all, I'd go for a preference.

But no fancy Wiki syntax if WYSIWYG is off. That would be to much for maintenance.

comment:14 Changed 6 years ago by shevek

We also should consolidate the used settings for the two timyMCEs we're using. The one for blog has several additional buttons.

comment:15 Changed 6 years ago by planetcruiser

+1 preference for "tinymce off". i think #1880 covers this

comment:16 Changed 6 years ago by jsfan

  • Milestone changed from unassigned to 1.5

comment:17 in reply to: ↑ 7 ; follow-up: Changed 6 years ago by mahouni

Replying to globetrotter_tt:

Replying to jsfan:

IMHO there should be a WYSIWYG editor which can be disabled and has a source view as well. This would allow everyone to make up their minds for themselves.

We can have this option for TinyMCE. It's only adding one line of code.

@globetrotter: would that be a TinyMCE setting? or some ROX code in php/js?

comment:18 in reply to: ↑ 17 Changed 6 years ago by globetrotter_tt

Replying to mahouni:

@globetrotter: would that be a TinyMCE setting? or some ROX code in php/js?

you need to add following line below the texarea in /build/forums/templates/editcreateform.php (line 131)

<a href="javascript:;" onclick="tinymce.execCommand('mceToggleEditor',false,'topic_text');"><?php echo $words->getFormatted("forum_toggleTinyMCE"); ?></a>

comment:19 Changed 6 years ago by shevek

Just tried that. While the switch works fine the text entered into the simple textarea isn't saved into the database. Switching TinyMCE on befare saving works.

Additionally I suggest to put that into a small javascript that writes the line out to document to avoid that it's visible even when it is not necessary (when scripts are disabled).

comment:20 Changed 6 years ago by mahouni

  • Status changed from new to local_testing

Update to TinyMCE 3.5.8:
local_testing on the mileston 1.5 branch:
https://gitorious.org/~mahouni/bewelcome/mahouni-rox/commits/ms15_develop_20130129

Don't forget the Database update for ticket #1892 and #1858.
Check: http://trac.bewelcome.org/wiki/DatabaseChanges

Last edited 6 years ago by mahouni (previous) (diff)

comment:21 Changed 6 years ago by jsfan

Wasn't this also supposed to come with an off switch?

comment:22 Changed 6 years ago by jsfan

And what happened to the autosave?

comment:23 Changed 6 years ago by mahouni

This ticket is just about the maintenance upgrade.

The rest is mainly configuration setting, and should be done later, in a different ticket,

I tried the switch off: it works, but I got the same result as shevek: the text is not correctly saved to the database. I don't think it is needed. You can also just disable javascript. In general tinymce works and problems are probably caused by ROX processing, not by the the editor.

The big problem with people losing content because of automatically being logged out is solved. So autosave is not needed urgently. It would be a 3rd party plugin and could help, if someone clicks on a link on the page or the page back. But you would still have to know about that button first,

comment:24 Changed 6 years ago by jsfan

Ok. I agree that everything else could go onto a new ticket.

Otherwise, this looks ok to me. Anyone seconding?

comment:25 Changed 6 years ago by shevek

The font size got a lot smaller. Don't know why but that should be changed.

comment:26 Changed 6 years ago by guaka

Would it be possible to remove formatting when pasting? This is one of the most annoying things about the wysiwyg.

It's also still very bad at dealing with URLs. If you paste in a URL you can't create any new lines or new characters after the URL anymore.

And I would be less unhappy if it were possible to disable the thing and just have a textarea.

Of course I still maintain that BW would be much better without a wysiwyg. It could still just be ditched.

comment:27 Changed 6 years ago by jsfan

@guaka: My understanding is that this ticket is only the upgrade. Any fixing on top of that is addition configuration, just as mahouni stated in comment 23.

comment:28 Changed 6 years ago by jsfan

  • Status changed from local_testing to to_alpha

comment:29 Changed 6 years ago by jsfan

  • Status changed from to_alpha to testing

comment:30 Changed 6 years ago by jsfan

I get a blank window when trying to insert a link in Chromium. Can anyone confirm that?

comment:31 Changed 6 years ago by shevek

Works fine in Chrome 24.0.1312.57 m.

Could you post the link? Maybe it is specific?

comment:32 Changed 6 years ago by crumbking

works for me in chrome

comment:33 Changed 6 years ago by crumbking

But the font-size in the editor is really small on firefox and chrome. There is something wrong...

comment:34 Changed 6 years ago by guaka

Font size looks fine in latest FF and Chrome on OSX.

And I have to admit some of the other annoyances seem to have disappeared as well somehow, e.g. issues with pasting and http links at the end of the editor.

comment:35 follow-up: Changed 6 years ago by jsfan

I get a blank window (source is there) with this browser:

Chromium 25.0.1364.58 (Developer Build 179520) OS Linux WebKit 537.22 (Unknown URL@0) JavaScript V8 3.15.11.13

Still works fine in FF 18.0.1 (Linux). Also have a rather small sans-serif font there now. Font is no problem in Chromium.

Last edited 6 years ago by jsfan (previous) (diff)

comment:36 Changed 6 years ago by mahouni

  • Status changed from testing to needs_work

The font-size issue should be fixed with that commit:
https://gitorious.org/bewelcome/rox/commit/f98b0d085d8375360d402b4723d9f0b80067f03f

I have just downloaded chromium and will test the blank window issue.

comment:37 Changed 6 years ago by shevek

Chrome 25 shows the text in a readable size now.

comment:38 in reply to: ↑ 35 Changed 6 years ago by mahouni

  • Status changed from needs_work to to_alpha

Replying to jsfan:

I get a blank window (source is there) with this browser:

Chromium 25.0.1364.58 (Developer Build 179520) OS Linux WebKit 537.22 (Unknown URL@0) JavaScript V8 3.15.11.13

I could not install the developer build, but it works with Chromium 24.0.1312.56. Won't do anything for now, because 25 is a developer version.

The above fix for text size is already on alpha. So I'll set the ticket to testing again.

comment:39 Changed 6 years ago by mahouni

  • Status changed from to_alpha to testing

comment:40 Changed 6 years ago by shevek

Closed as fixed? Worked for me with Chrome 25 by the way.

comment:41 Changed 6 years ago by crumbking

  • Resolution set to fixed
  • Status changed from testing to closed

works for me on alpha.

comment:42 Changed 6 years ago by crumbking

  • Resolution fixed deleted
  • Status changed from closed to reopened

font size issue: It does not work on alpha on the blog and trip forms. Still very small fonts.

comment:43 Changed 6 years ago by crumbking

Also if you use bulleted /numbered lists the font is really small on all forms (groups, forums, trip, blogs)

comment:44 Changed 6 years ago by jsfan

Any chance of closing this in the next 24h? As we are already overdue on this release, I'd really like to release in no more than 24h.

comment:45 Changed 6 years ago by shevek

Fix should be the same as for the first font-size problem mentioned in comment 36.

Add the name of the tinyMCEBodyContent tag on the blogs and trip page (should be the same if I recall correctly) and remove the p in the CSS.

Can't fix it myself as I'm still away from my main computer.

comment:46 Changed 6 years ago by mahouni

I'll submit that fix in a few minutes (if it works ;)

comment:47 Changed 6 years ago by mahouni

  • Status changed from reopened to local_testing

comment:48 Changed 6 years ago by crumbking

  • Status changed from local_testing to to_alpha

seems to work locally

comment:49 Changed 6 years ago by jsfan

  • Status changed from to_alpha to testing

Deployed.

comment:50 Changed 6 years ago by crumbking

  • Component changed from unknown to FrameWork
  • Resolution set to fixed
  • Status changed from testing to closed

works on alpha

comment:51 Changed 6 years ago by mahouni

I moved the other ideas and suggestion to new separate tickets: #1960 - #1963

Note: See TracTickets for help on using tickets.