Opened 6 years ago

Closed 5 years ago

#1829 closed bug (fixed)

Country search lists the americas with errors

Reported by: pablobd Owned by:
Priority: minor Milestone: 2.0
Component: BW Geo Keywords: americas
Cc:

Description

http://alpha.bewelcome.org/places I noticed that the North America header is actually including central america & caribean countries wich is plain wrong. One option would be to just list "Americas" and put all the countries togheter. Current layout neglects south america to the bottom of the page, while the rest is on top.

Change History (24)

comment:1 Changed 6 years ago by beatnickgr

the current layout is definetely wrong. indeed one option is to merge americas.

the second option is to separate north america and latin america, and latin america should be in a separated column.

the third option is to have no continents, but only one list of all countries in alphabetical order, because some countries, like turkey and russia, are in 2 continents.

comment:2 Changed 6 years ago by beatnickgr

i think this is related http://trac.bewelcome.org/ticket/1773

comment:3 Changed 6 years ago by pablobd

Is the continent separation also coming from geonames?

comment:4 Changed 6 years ago by shevek

According to Wikipedia South America as a continent does not include Middle America. Continents are pretty strange creatures anyway. So based on tectonics that is probably right. Based on languages it probably isn't. On a political scale neither. That is even worse for Europe and Asia as there isn't even clear tectonics.

Geonames doesn't offer hierachy that reflects the association with the continent. That info is taken from a table in the DB geonames_contries (which probably was created using this info from geonames: http://download.geonames.org/export/dump/countryInfo.txt)

comment:5 Changed 6 years ago by pablobd

Is it possible to change the DB to gather all countries under "Americas"? or is there some coding required?

comment:6 Changed 6 years ago by shevek

The DB change wouldn't be enough. Anyway it is easier to just collect all countries for NA and SA into one A :-) The coding required shouldn't be more than 5 minutes.

comment:7 Changed 6 years ago by shevek

You can have a look here: www.blafaselblubb.de/places

To authenticate against the site use bla/blafaselblubb.

I still don't like the change as it will break the auto translation that would come with the migration to geonames and every one would expect a South America there.

comment:8 Changed 6 years ago by pablobd

I like the five colmuns there, the only thing missing is renaming the North America column to Americas and put it in first place (I see the columns are alphabetical ordered?).

comment:9 Changed 6 years ago by shevek

The five columns are something that I like to see as well. There is enough space for them so use it.

The list is not sorted Otherwise Antartica wouldn't be beneath Ocenania. Additionally the problem is that now you would need to translate America while everything else comes from geonames. Switch to Greek to see what I mean.

I think we can put South America next to North America and push Antartica below North America.

As already said I can't find an indication that South America equals Latin America.

@beatnickgr: At least on blafaselblubb Turkey shows up only once (in Asia).

Last edited 6 years ago by shevek (previous) (diff)

comment:10 Changed 6 years ago by pablobd

I can see that all the continent names are translatable under words, they don't come from geonames right?

about continents: south america is not equal latin america for sure, indeed "Americas" is a rather ample compromise since from a tectonic point of view the americas are four tectonic plates (the caribean ant the southern antilles having their own plate) but i think we are ignoring the tectonics or we should include part of Russia in the americas :D (see http://en.wikipedia.org/wiki/File:Plates_tect2_en.svg)

I think the list should be: Africa, Americas, Asia, Europe, Oceania Since you probably can't host travellers in antarctica I find it very odd to have it, there's only scientific stations with temporary staff.

comment:11 Changed 6 years ago by shevek

I know at least one couchsurfer who spent some time in one of the scientific stations. So she might never host you there but still should show up. We show the world on the map so that should be true for the list of countires/territories as well.

The proposed change will include that all names including the headers for the continents from geonames. That includes translating all the countries names with out effort for the community. Bow adding a new word to get some random header seems odd to me.

As already said: as long as we can't find a good reason for Americas as opposed to South and North America I'd don't touch that.

I update the implementation later today to give visuals for North next to South America.

Last edited 6 years ago by shevek (previous) (diff)

comment:12 Changed 6 years ago by pablobd

If we put central & north america togheter then Europe and Asia should be toghter too. The separation of Eurasia into Europe and Asia is viewed by some as a residue of Eurocentrism See http://en.wikipedia.org/wiki/Continent#Separation_of_continents

comment:13 Changed 6 years ago by shevek

If we start that we can just put everything together as the Australians might complain that they're part of Oceania and not a continent of its own.

So I took the idea of beatnickgr and just drop all continents... Have a look, please.

comment:14 Changed 6 years ago by crumbking

No continents might help us to get rid of such questions like "if a country is under asia or not" but hey this is just a plain list with some structure.

In such long list you have a hard time to find what you need. You need to scroll down than up again ;-) So in short: Don't really like that :-)

Last edited 6 years ago by crumbking (previous) (diff)

comment:15 Changed 6 years ago by shevek

Don't like it either :)

But honestly who searches without a search field?

comment:16 Changed 6 years ago by pablobd

I would settle for no continents

comment:17 Changed 6 years ago by beatnickgr

It looks like we have a consensus for no continents.

So all the countries should be listed in what order?

-Alphabetical (Afghanistan first)? the alphabetical order is changing when the country names are translated. Is it technically possible to have alphabetical order independently of the language?

-ISO codes? that doesnt mean alphabetical order, confusing...

-Size (France first)? It will be difficult to find small countries...

-Other?

comment:18 Changed 6 years ago by shevek

Beatnickgr: How do you define consensus? crumbking and I don't like it. Pablo and you prefer it. I'd call that a tie ;-)

comment:19 Changed 5 years ago by sitatara

  • Component changed from unknown to BW Geo

comment:20 Changed 5 years ago by Tsjoek

  • Resolution set to invalid
  • Status changed from new to closed

Trac doesn't allow me to say fixed, but the original issue has been fixed in 2.0, by using the suggested solution. Let's see how usable this solution is and have the continent discussion on the forum if necessary.

comment:21 Changed 5 years ago by shevek

  • Milestone changed from unassigned to 2.0
  • Resolution invalid deleted
  • Status changed from closed to reopened

Didn't know this ticket exist. So assigning it to 2.0 for completeness.

comment:22 Changed 5 years ago by shevek

  • Status changed from reopened to to_alpha

comment:23 Changed 5 years ago by shevek

  • Status changed from to_alpha to testing

comment:24 Changed 5 years ago by shevek

  • Resolution set to fixed
  • Status changed from testing to closed

Closed as fixed based on comment 20.

Note: See TracTickets for help on using tickets.