Opened 6 years ago

Closed 6 years ago

#1838 closed improve feature (fixed)

Set "group only" as default visibility for new forum posts

Reported by: pablobd Owned by: shevek
Priority: major Milestone: 1.4
Component: BW Forum Keywords: forum group 1.4 1.5
Cc:

Description

In order to keep it cleaner in the forum homepage, and considering most people don't care to select a visibility, we could do this quick fix (probably one line of code?) just changing the default visibility of posts to "group only"

I'm not sure what would happen if you post under the main forum (outside a group) and visibility is "group only" (I just checked this is posible in the new topic form

Change History (34)

comment:1 Changed 6 years ago by pablobd

Please, at least set this for the groups that don't have an admin (such as this one http://www.bewelcome.org/groups/16 ) This is urgent in order to avoid general forum cluttering and perceived "offtopicness" and crosspostings

comment:2 Changed 6 years ago by shevek

  • Keywords forum 1.4 1.5 added; only removed
  • Owner set to shevek
  • Status changed from new to assigned

I have a fix ready for this. Default would be 'Members Only' for forum posts and 'Group Only' for Group post.

For groups the visibility can be set to 'World', 'Members Only' or 'Group Only' depending on the group visibility setting only 'Group Only' might be possible. While for forum only 'World' or 'Members Only' is possible.

comment:3 Changed 6 years ago by mahouni

  • Milestone changed from unassigned to 1.4
  • Status changed from assigned to local_testing

comment:4 Changed 6 years ago by shevek

Commit worked fine. Default are given as stated above.

comment:5 Changed 6 years ago by crumbking

On forums/edit/m.....

I get the following:

Notice: Undefined variable: IdGroup? in /home/crumb/webdev/bw/build/forums/forums.view.php on line 134

Might be related to the forum/group switch?

comment:6 Changed 6 years ago by shevek

There is a $IdGroup? = 0 in line 125 missing after cleaning up a duplicate assignment. I fixed that locally already.

This should fix that: https://gitorious.org/bewelcome/rox/commit/82b1982d02bd33822b8bcf729b3274be7df7aafc

comment:7 Changed 6 years ago by crumbking

I tested locally the notice is gone...

But still this issue: http://trac.bewelcome.org/ticket/1882#comment:5

comment:8 Changed 6 years ago by shevek

  • Status changed from local_testing to to_alpha

Deployed to alpha. Please test.

comment:9 Changed 6 years ago by shevek

  • Status changed from to_alpha to testing

comment:10 follow-up: Changed 6 years ago by crumbking

If I hit reply on this thread as not group member:

http://alpha.bewelcome.org/forums/s4600-How_to_improve_BeWelcomer_profile_content/reply

I would expect the jsfan's post be shown there with the same info "you can't see that thread because no group member"

But this is really minor.

It's already impressive how good it works now ;-)

comment:11 Changed 6 years ago by shevek

If I get another day I might be able to find out why a reply only shows up to 4 posts and why the group information is always 0 for these...

comment:12 follow-up: Changed 6 years ago by shevek

Problem was a missing ',' (and some nasty SQL syntax).

Adding this fixes the visibility of group only posts in a reply.

Commit: https://gitorious.org/bewelcome/rox/commit/8fccf11c4074c40c4746ddc1930464d881561d74

Last edited 6 years ago by shevek (previous) (diff)

comment:13 Changed 6 years ago by shevek

  • Status changed from testing to needs_work

comment:14 Changed 6 years ago by shevek

  • Status changed from needs_work to local_testing

comment:15 Changed 6 years ago by pablobd

I replied in the forum in alpha and group only was default for group threads, even in all "world" threads, that's great! :D Members only was default in non-group threads. Seems fine to me!!! make it alive!!!!

Last edited 6 years ago by pablobd (previous) (diff)

comment:16 in reply to: ↑ 12 Changed 6 years ago by mahouni

  • Status changed from local_testing to to_alpha

Replying to shevek:

Problem was a missing ',' (and some nasty SQL syntax).

Adding this fixes the visibility of group only posts in a reply.

Commit: https://gitorious.org/bewelcome/rox/commit/8fccf11c4074c40c4746ddc1930464d881561d74

works!

comment:17 in reply to: ↑ 10 Changed 6 years ago by shevek

Replying to crumbking:

I would expect the jsfan's post be shown there with the same info "you can't see that thread because no group member"

Sorry that would have been too much work :-) During reply all messages that you can't see are stripped from the list (they would only provide clutter anyway) and I didn't want to change that so that the display is the same as on the forum list.

comment:18 Changed 6 years ago by jsfan

  • Status changed from to_alpha to testing

comment:19 follow-up: Changed 6 years ago by sitatara

I tested this and found the following "behavior":

  • When I start a thread in the forum default visibility is "members only" but I can still choose world if I wish. That's fine.
  • When I reply to a thread in the forum the default visibility is inherited from the thread - so that can still be world. Not sure if that's intentional or if even here the default should be "members only". The only change here is that I can now immediatly edit my personal visibility setting (see #1849).
  • When I start a thread in a group it depends on the group settings which choice I have regarding visibility. If the group setting is "Forum threads are accessible only to group members by default" then I can ONLY make a "group only" post. I have no other choices! Is this really intended? If yes, the setting has to be renamed! It should be something like: "All (new) forum posts in this group are only visible to group members." If the group setting is "Forum threads are accessible to everyone by default (including Google)" the default is now "group only" but I can still choose "world" or "members only". So this setting needs renaming too. e.g. to: "Forum posts are only visible to group members by default but can individually be changed to "members only" (i.e. all BeWelcome members) or "world" (including Google) as preferred."
  • If I reply to a group post, the group setting plays a role again. If the setting is "Forum threads are accessible only to group members by default" I can only make "group only" posts, no matter what the thread visibility was before. If the group setting is "Forum threads are accessible to everyone by default (including Google)" the default visibility is NOT inherited by the thread (as in the forum) but is always "group only" (and I can choose to change it to wolrd or members only).

Conclusion: These changes need to be explained to group admins (that their settings mean something different now! - as said above the wording for the setting has to be updated too). And I would recommend that forum and groups show the same behavior when it comes to inheriting the thread visibility (either yes or no but it should be the same! Otherwise, it's really confusing.)

comment:20 in reply to: ↑ 19 Changed 6 years ago by shevek

Replying to sitatara:

  • [...] If the group setting is "Forum threads are accessible to everyone by default (including Google)" the default visibility is NOT inherited by the thread (as in the forum) but is always "group only" (and I can choose to change it to world or members only).

This is a bug and I submitted a fix for that (see #1849 which deals with reply visibility).

Conclusion: These changes need to be explained to group admins (that their settings mean something different now! - as said above the wording for the setting has to be updated too).

Shouldn't be too problematic: We just add a line to the community news ;-)

Last edited 6 years ago by shevek (previous) (diff)

comment:21 Changed 6 years ago by shevek

  • Resolution set to fixed
  • Status changed from testing to closed

Informed the group admins via general forum post. Closing ticket.

comment:22 Changed 6 years ago by planetcruiser

  • Resolution fixed deleted
  • Status changed from closed to reopened

something here is inconsistent:

  1. in the group settings (e.g. http://alpha.bewelcome.org/groups/93/groupsettings) i select "Forum threads are accessible to everyone by default (including Google)"
  2. when creating a new post the default visibility is set to "Group only"

so the "default" in the group settings is not respected. this is a clear bug.

also, why can i not select default visibility "bewelcome members only" in the group settings?

wording is confusing here in general. i suggest the following:

group settings:


  == Discussion settings ==

  Default visibility for new threads
    (*) Everyone on the internet
    ( ) BeWelcome members
    ( ) Group members

  Default visibility for replies
    (*) Same as thread
    ( ) Everyone on the internet
    ( ) BeWelcome members
    ( ) Group members

post settings (this should become radio buttons, because selects don't make much sense for less than 5 options):


  Visibility
    (*) Everyone on the internet
    ( ) BeWelcome members
    ( ) Group members

more things (maybe worth new tickets):

  • we are alternating between "topic" and "thread" in the interface. this needs to be unified. i suggest to say "thread" everywhere, because "topic" is ambiguous.
  • we are alternating between "forum" and "discussion" in the group navigation and settings. i recommend to use "discussion" everywhere, because a "forum" is a section of a website dedicated to discussion, not part of another section.
  • there should be a flash message "Settings updated" after pressing "Update group settings"

comment:23 Changed 6 years ago by shevek

  • Resolution set to wontfix
  • Status changed from reopened to closed

@planetcruiser: An alternate wording was already suggested and the changes were publicly announced to the group admins in the forum.

The goal of this ticket was to remove clutter from the forums and not to provide a clean interface for the users that they didn't have yet (and never complained about).

The reason there is a drop down is that there was a dropdown. If you want to get that removed open a ticket and assign a milestone (but not 1.4).

Regarding your proposed discussion settings: I agree that we should change these which isn't really part of the ticket but a translation issue.

But we don't need an additional setting for replies. Especially not a 'Same as thread' as a user clicking on reply might never have see the first post. And the thread supersedes any other setting so that a thread started as members only can't contain a world posting.

And no the default should never be World.

comment:24 Changed 6 years ago by planetcruiser

  • Resolution wontfix deleted
  • Status changed from closed to reopened

ok, let's disregard the drop-down and the other interface improvements for now. the top part of my comment was more important:

not respecting the "default" setting in the group settings is a clear bug which needs to be fixed before this ticket can be closed. please don't close the ticket again before we have an agreement on this.

comment:25 Changed 6 years ago by shevek

The 'default' changes with 1.4. So that isn't the issue.

We shouldn't introduce a members only visibility for groups as we have the forum for that.

Regarding wording: We could either use the suggestion by sitatara in comment 19 or if that's too wordy (she deals with support questions a lot ;-)) say something along the lines:

  • All posts to this group are group only
  • A group member might choose to change to visibility so that non-group members can see a post

The only real question I see is do we introduce a new word code? The current codes are GroupsVisiblePosts? and GroupsInvisiblePosts? which seems fine.

PS: The associated table column is VisiblePosts? based on which name I changed the behaviour ;-)

comment:26 Changed 6 years ago by planetcruiser

ok, let's focus on the bug:

  1. in the group settings (e.g. http://alpha.bewelcome.org/groups/93/groupsettings) i select "Forum threads are accessible to everyone by default (including Google)"
  2. when creating a new post the preselected visibility is "Group only"

so the selected "default" in the group settings is not respected. how is this not a bug?

expected behaviour:

  1. i select "Forum threads are accessible to everyone by default (including Google)" in the group settings
  2. when creating a new group forum post the preselected visibility is "World"
  3. when selecting "Forum threads are accessible only to group members by default" in the group settings, the preselected option when starting a new thread is "Group only"

We shouldn't introduce a members only visibility for groups as we have the forum for that.

that's another bug then, right? because when creating a new topic in a group discussions, i can select "World"/"members only"/"Group only". so either the option needs to be removed when creating a post, or it needs to be added to the group settings.

comment:27 follow-up: Changed 6 years ago by shevek

Please read my comments.

We already agreed on that the wording needs to be changed. After that is done there is no bug any more.

Members only is accepatble as a visibility but not as a default setting for a group post.

Off to work next answer in 8 hours earliest.

comment:28 in reply to: ↑ 27 ; follow-up: Changed 6 years ago by planetcruiser

hm, i think we don't really understand each other.

Replying to shevek:

Please read my comments.

We already agreed on that the wording needs to be changed. After that is done there is no bug any more.

which of the 2 bugs i wrote about in comment:26 are you referring to? let's discuss one by one. "not respecting default" first please.

Members only is accepatble as a visibility but not as a default setting for a group post.

why is that?

if not even i as an experienced rox coder can understand the privacy paradigm here, even after a good look at the subject, how can we expect a user to grasp and correctly use it? it should be dead simple.

as i understand your commits and comments you changed more behaviour than initially described in the ticket description. as a result we need to broaden the discussion in this ticket or split it into more tickets.

comment:29 Changed 6 years ago by jsfan

My understanding is that the idea of this ticket is to create real separation between groups and forums by making groups pretty much self-contained. Forums should probably be visible to the world but because people don't get the difference between forum and group, it's probably better to got with members only.

comment:30 Changed 6 years ago by pablobd

The settings of the group will not affect the default visibility but instead they will limit how open a post visibility can be set by the user. Group post must be group only by default, otherwise they should behive just like any other tag. The only problem is those threads that are already started as world or members, in those cases we might respect the original visibility but then people will be confused, I guess the better is to just do Default 'Members Only' for forum posts and 'Group Only' for Group, the most private by default.

comment:31 in reply to: ↑ 28 Changed 6 years ago by shevek

Replying to planetcruiser:

hm, i think we don't really understand each other.

Seems like it. Unfortunately.

We already agreed on that the wording needs to be changed. After that is done there is no bug any more.

which of the 2 bugs i wrote about in comment:26 are you referring to? let's discuss one by one. "not respecting default" first please.

That was not respecting the default: How else could one interpret the summary of this ticket. No default visibility world. New post should be group only. I took the liberty to extend that to forum posts as well. (As I find it annoying as hell, that I have to edit all of my posts to the forum as I don't want them to be visible to the world and I believe most people agree on that.)

That said the forum visibility items in group settings don't match the software anymore so they need to be updated. I proposed wordings for that. Do you still see a bug after the wording was adapted?

Members only is accepatble as a visibility but not as a default setting for a group post.

why is that?

Do we need a group if anyway everybody can see the post? Or wouldn't that be a tag?

if not even i as an experienced rox coder can understand the privacy paradigm here, even after a good look at the subject, how can we expect a user to grasp and correctly use it? it should be dead simple.

I'm not sure how coding gets into the mix here but I believe it is dead simple. You either say all posts are group only or you say if the members of this group like to post something with a higher visibility you let them.

as i understand your commits and comments you changed more behaviour than initially described in the ticket description. as a result we need to broaden the discussion in this ticket or split it into more tickets.

So the ticket clearly says all post have to be 'Group only'. Because of that I used the existing setting and reinterpreted it in the outlined way. I can't see why that would be a new ticket at all.

comment:32 Changed 6 years ago by planetcruiser

  • Status changed from reopened to to_alpha

ok, for personal reasons i just don't care about this topic any more right now. i trust your judgement that the current behaviour somehow is an improvement.

comment:33 Changed 6 years ago by planetcruiser

  • Status changed from to_alpha to testing

comment:34 Changed 6 years ago by planetcruiser

  • Resolution set to fixed
  • Status changed from testing to closed

hm, this workflow does not work too well for reopened tickets.

Note: See TracTickets for help on using tickets.