Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1852 closed bug (fixed)

Languages lists (for preferences)

Reported by: beatnickgr Owned by: shevek
Priority: minor Milestone: 1.6
Component: BW Internationalization Keywords: norsk norvegian language
Cc:

Description (last modified by sitatara)

Issue: In preferences, i found in the list of languages "norsk" and "norsk bokmal". Talking with my norwegian guest i conclude that in norway there are 2 dialects "norsk bokmal" (formal norwegian) that is teached at school and is used in websites, and "ni-norsk" (new norwegian) which is not to be used on a website. When we refer to norsk without specifying, it's the norsk bokmal.

Solution: there should be only "norsk" in the list. the translator (when we have one), will translate to norsk bokmal.


Related tickets #1809, #1748

Change History (29)

comment:1 Changed 6 years ago by shevek

The drop down in preferences should probably show the same list as the languages list at the bottom. To select a preferred language for the UI interface that can't be shown as no translaton exists doesn't really make sense to me.

comment:2 Changed 6 years ago by sitatara

Another user reported the same problem with Serbian: "I wanted to add Serbian to my languages... and it is on your list something like FIVE times... both as "Serbian", "srpski", "srpski jezik", "Serbocroatian" and then again "srpisk jezik", but in cyrillic...."

comment:3 Changed 6 years ago by sitatara

By the way, since the list of languages is not only used for preferences but also for the languages a user speaks, we shouldn't limit it to the languages the website is translated to. Or rather we should seperate those two lists. For preferences you should only be able to select the ones which are available on the website. For the languages you speak, you should be able to select from "all" languages.

comment:4 Changed 6 years ago by shevek

Languages are obviously a difficult topic. The Iso 639-1 has entries for historic languages as well as for living languages and some languages are marked as macrolanguages. Like Norsk for Norsk Bokmal and Norsk Nynorsk.

Sometimes one would prefer the macro language (like Norsk) but sometimes likely not (Malay/Indonese/Malayalam?). A programmatic nightmare ;-)

Last edited 6 years ago by shevek (previous) (diff)

comment:5 Changed 6 years ago by mikael

@Shevek: that's why it's better to speak about "internationalization" and "localization", as those terms include also date formats and location of the spoken language etc. So no pt, but pt_BR and pt_PT.

For example in Moldova and Romania or in Russia and Belarus people speak pretty much the same language, but it's seen as a good practise to have these listed seperatelly.

Anyway, about Norwegian: both nynorsk and bokmål are official written and spoken languages in Norway. They've got their own language codes in most of the systems. Usually you'd see programs/sites translated either to bokmål only or to both seperatelly. Never just Norsk. If you ask native norwegian, you must always be aware that you might be speaking with language activist of some sort.

Btw Lukc says Slovenian is missing from the list...

comment:6 Changed 6 years ago by shevek

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

I think we can close this issue as we have #1809 to cover all language related topics.

Luckily enough we can sort out different language by just not translating 'WelcomeToSignup?'...

Last edited 6 years ago by shevek (previous) (diff)

comment:7 Changed 6 years ago by shevek

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Summary changed from Norsk to Languages lists

Reopened as this wasn't only about norsk. Changed summary accordingly.

comment:8 Changed 6 years ago by sitatara

  • Description modified (diff)

comment:9 Changed 6 years ago by shevek

  • Summary changed from Languages lists to Languages lists (for preferences)

Update summary again as we have a ticket for the language chooser for the profile editor as well.

comment:10 Changed 6 years ago by shevek

  • Milestone changed from unassigned to 1.6-proposed

comment:11 Changed 6 years ago by shevek

  • Owner set to shevek
  • Status changed from reopened to assigned

comment:12 Changed 6 years ago by shevek

Only show UI languages in the drop down of preferred language. Show language names translated and in there native script.

Commit: https://gitorious.org/bewelcome/rox/commit/64f5daf330732f0531519273b3ae891b7c98c443

comment:13 Changed 6 years ago by shevek

  • Status changed from assigned to local_testing

comment:14 Changed 6 years ago by midsch

There is a usability flaw, that similar but less worse than the real life system (in a way it is fixing the existing issue):

  • online: if you open "my preference" the browser language is active in the pulldown NOT the stored preferred one! Changing any other setting on the page will save an unwanted language as well.
  • local test: if you open "my preference" for the first time (new member) the language pulldown in alphabetical order (= arabic), so changing other preferences will set the language from default english to arabic. Some people will have trouble dealing with it ...

Also, there are some possible settings on my local install (i. e. stylesheet), that are not on the real site - a matter of bwbuntu?

comment:15 Changed 6 years ago by shevek

Fixed the default setting for the language preference if that preference was never set: https://gitorious.org/bewelcome/rox/commit/194afc6fe20b0b4543ba3abd531bc90766f8dee6

Regarding the strange settings you see: check the http://trac.bewelcome.org/attachment/ticket/1763/preferences.sql

comment:16 Changed 6 years ago by midsch

Ok, fine here now, except the other pulldown on mypreferences for "Choose your time zone". It works, but is to wide and not very accesible - collateral damage of layouting the other pulldown? (The life system looks good.)

comment:17 Changed 6 years ago by shevek

The timezone dropdown looks ugly as one word isn't translated. Download and import http://downloads.bewelcome.org/for_developers/rox_test_db/words.sql.bz2 should fix that.

The other pull down needs to be checked for width in different languages. We might want to push the descriptive text below it.

comment:18 Changed 6 years ago by midsch

The timezone dropdown is fine now. Switching the preferred language to "Korean" kills the width. It kind of works but it's ugly and not very usable.

comment:19 follow-up: Changed 6 years ago by shevek

We could use the whole space for the language drop down and rename 'Preferred Language' to 'Preferred Site Language' or 'Show site in Language'. And get rid of the 'Default language'. That should prevent any language to kill the form ;-)

comment:20 in reply to: ↑ 19 Changed 6 years ago by crumbking

Replying to shevek:

We could use the whole space for the language drop down and rename 'Preferred Language' to 'Preferred Site Language' or 'Show site in Language'. And get rid of the 'Default language'. That should prevent any language to kill the form ;-)

+1

Oh and works for me.

comment:21 Changed 6 years ago by crumbking

  • Status changed from local_testing to to_alpha

comment:22 Changed 6 years ago by shevek

  • Status changed from to_alpha to testing

comment:23 Changed 6 years ago by midsch

As mentioned in #1828 on http://alpha.bewelcome.org/mypreferences the pulldown is always set to browser language instead of the choosen standard. So my german browser always sets it to german and if I change any other preference I end up on the german bw-page instead of the preferred english one.

Chinese Traditional and Portugues BR are listed twice.

comment:24 Changed 6 years ago by shevek

I can't reproduce this. I set the preferred language to 'Chinese (Traditional)' and it remained such.

Did you ever set the preference? (For a test user that preference might be empty and then the browser language is used.) But after you changed any preference that shouldn't be the case anymore.

comment:25 Changed 6 years ago by midsch

As described I can reproduce it, but only with my own profile not with another (test)profile. Saving my preferences, with whatever language doesn't change it. I'm able to save the preference, I've set it to polish last night and now I got a polish surface. But when I go to mypreferences the pulldown is still set to "niemiecki (deutsch)". I also tried to find a similar profile in the test database. No luck. So I guess, I'm just special ... (additional checks with firefox, midori and another computer doesn't help as well.) So if it's just me, I'd say it's ready.

The two redundant languages are gone.

comment:26 Changed 6 years ago by shevek

As a database query revealed that the issue midsch is facing due to the content of the database and the problem could be reproduced on www.

Does anyone see a language that uses more than the space provided?

Otherwise this could be closed as fixed.

comment:27 Changed 6 years ago by midsch

I've got my "own" ticket #1984

I switched to all different kinds of languages, especially with non latin characters. and the pulldown works for me all the time. So I'd say, it's fixed.

A minor (and not related?) issue, probably due to a wrong translation (or html in words): In Greek the text of the page becomes bold after the WYSIWG sequence and the submit button is located in the middle not left. This doesn't happen in other languages.

comment:28 Changed 6 years ago by sitatara

  • Resolution set to fixed
  • Status changed from testing to closed

I couldn't find any language which uses more space than provided, therefore closing the ticket. @ midsch: I assume the problem with the bold text in the greek version is really just a problem with a html tag which wasn't closed. I will post this in the translation group. As for the position of the submit button: The same is true in the Italian and French version - any idea what's the cause for that?

comment:29 Changed 6 years ago by sitatara

PS: On www the submit button in the Greek and Italian version is correctly positioned but it's wrong for French and Lithuianian (also on alpha). Is this connected to this ticket? Should I reopen it?

Last edited 6 years ago by sitatara (previous) (diff)
Note: See TracTickets for help on using tickets.