Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#1856 closed bug (fixed)

kick member from group wrong error message

Reported by: pablobd Owned by: mahouni
Priority: major Milestone: 1.4
Component: BW Group Keywords: kick, groups
Cc: mahouni

Description

When trying to kick a member for the group http://www.bewelcome.org/groups/79 There is an error message and the users stays there

Change History (35)

comment:1 Changed 6 years ago by crumbking

  • Cc mahouni added

@mahouni: Could you look into this?

@pablo: What is the error message? And does it only happen to this user or others, too, You can kick me if you want :-)

comment:2 Changed 6 years ago by pablobd

@crumbking I will try to find out the error but I suspect it was an empty Wordcode

comment:3 Changed 6 years ago by pablobd

I have another probably relatad bug: I tried to change settings of this group: http://www.bewelcome.org/groups/21/groupsettings and i get an error aswell: GroupsChangeFailed? this seems to happen with old groups, shall i fill another ticket for this?

comment:4 Changed 6 years ago by pablobd

OK this is the error mesasge: Sorry :( BeWelcome has just suffered an error of some magnitude (i.e. we cannot show you the page you were looking for and something went wrong as we looked for it), which is why you are looking at this error message. We apologise for the inconvenience many times, and humbly request that you send the address of this page to us through the feedback (and hopefully that is not the page that brings up this error ...).

comment:5 Changed 6 years ago by crumbking

What is the difference between kick and ban anyway? I was able to reproduce it locally while kicking a member.

comment:6 Changed 6 years ago by mahouni

kick: kick member, member can join group again
ban: kick member, member can't join group again

I can reproduce (locally) the following: i get an error message when the group overview page reloads after kicking a member. Kicking the member works fine, but there is an error when loading the forum stuff. -> Invalid Continent...pffff

Exception log:
Session data: IdMember=107 Username=lupo-test MemberStatus=Active
* Request url: /bewelcome/htdocs/groups/73/kickmember/89
* Exception message: Invalid Continent
* Exception class: PException
* Exception code: 0
* Exception line: 437
* Exception file: myPATH/build/forums/forums.model.php
Last edited 6 years ago by mahouni (previous) (diff)

comment:7 Changed 6 years ago by beatnickgr

can't reproduce it, yesterday i successfully kicked a member from a moderated group of which i'm moderator...

comment:8 follow-up: Changed 6 years ago by pablobd

I think this only happens with old groups that got an admin after being created

comment:9 in reply to: ↑ 8 Changed 6 years ago by mahouni

Replying to pablobd:

I think this only happens with old groups that got an admin after being created

Has this been tested for other old groups too?

Another explanation might be some interference of different admin rights.

comment:10 Changed 6 years ago by planetcruiser

  • Priority changed from blocker to critical

hardly a blocker, is it?

comment:11 Changed 6 years ago by pablobd

We are currently in the need of updating all the volunteer teams, therefore this function is needed to have only the present active volunteers in the groups, until this is fixed we are blocked from doing our volunteer work, that's why it was labeled as blocker, like literally. But it might be a wrong priority, is there a page with some guidelines on how to clasify priority of a bug?

comment:12 Changed 6 years ago by crumbking

pablo could you assign my as a co-admin of that group?

comment:13 Changed 6 years ago by pablobd

I cannot do it since i'm not an admin on that group. Neither I can using the bwadmin2 account :( you should contact one of the current admins of the group

comment:14 Changed 6 years ago by planetcruiser

pablo: so should this be scheduled for the next release then? i lost overview a bit, if not done yet, maybe suggest this ticket for 1.4 on the dev list.

comment:15 Changed 6 years ago by pablobd

yes please

comment:16 Changed 6 years ago by planetcruiser

pablo: sorry, i meant if you could suggest it to the dev list. i am already up to my ears in other things ;)

comment:17 Changed 6 years ago by mahouni

  • Milestone set to 1.4
  • Owner set to mahouni
  • Status changed from new to assigned

I added it to 1.4

comment:18 Changed 6 years ago by mahouni

this should fix the problem with the kick member bug:
http://gitorious.org/bewelcome/rox/commit/e83cb449b447da0a742ed5a75ea0b17ada7eb929

Not yet on alpha, test locally for now.

Can someone of the translators please check if the wordcode for GroupsChangeFailed exists and create it if not.

comment:19 Changed 6 years ago by pablobd

It seems the kicking works but instead of getting a successfull message you get an error message

comment:20 Changed 6 years ago by pablobd

  • Priority changed from critical to major

comment:21 Changed 6 years ago by mahouni

The members are kicked, but there was an error message and the forum board would not load because of an url conflict: After kicking the url is www.bewelcome.org/groups/2000000/kickmember/7000000 k is the signal for the continent board, but there is no continent ickmember...

fixed locally. works for me

comment:22 Changed 6 years ago by jsfan

Deployed on alpha.

comment:23 Changed 6 years ago by mahouni

  • Status changed from assigned to testing

comment:24 follow-up: Changed 6 years ago by crumbking

If I reload the page or come back via browser I get the following:

Fatal error: Call to a member function memberLeave() on a non-object in /home/crumb/webdev/bw/build/groups/groups.model.php on line 648

comment:25 Changed 6 years ago by pablobd

  • Summary changed from Not possible to kick member from group to kick member from group wrong error message

comment:26 Changed 6 years ago by mahouni

  • Status changed from testing to needs_work

comment:27 in reply to: ↑ 24 Changed 6 years ago by mahouni

  • Status changed from needs_work to local_testing

Replying to crumbking:

If I reload the page or come back via browser I get the following:

Fatal error: Call to a member function memberLeave() on a non-object in /home/crumb/webdev/bw/build/groups/groups.model.php on line 648

fixed with:
http://gitorious.org/bewelcome/rox/commit/cf1a285a7d86718769450ab77e776b934dbeb045

comment:28 Changed 6 years ago by shevek

  • Status changed from local_testing to to_alpha

comment:29 Changed 6 years ago by shevek

  • Status changed from to_alpha to testing

comment:30 Changed 6 years ago by shevek

Made it with the last pull to alpha.

Last edited 6 years ago by shevek (previous) (diff)

comment:31 Changed 6 years ago by crumbking

  • Resolution set to fixed
  • Status changed from testing to closed

Okay kicked Shevek with success out of Klöden ;-)

comment:32 follow-up: Changed 6 years ago by shevek

Right, I'm no longer a member of the group Klöden. That I didn't get informed about the fact that I had to leave the group is a bit sad, though.

comment:33 in reply to: ↑ 32 Changed 6 years ago by crumbking

Replying to shevek:

Right, I'm no longer a member of the group Klöden. That I didn't get informed about the fact that I had to leave the group is a bit sad, though.

New Ticket?

comment:34 Changed 6 years ago by shevek

Created: #1925

comment:35 Changed 6 years ago by planetcruiser

tested ok. kicked meinhard_test from anarchist group and got "Successfully kicked member from the group."

Note: See TracTickets for help on using tickets.