Opened 6 years ago

Closed 6 years ago

#1865 closed bug (fixed)

cannot reply in group forum

Reported by: pablobd Owned by: shevek
Priority: blocker Milestone: 1.3
Component: unknown Keywords:
Cc:

Change History (13)

comment:1 Changed 6 years ago by shevek

If you want to reply you need to click on the reply button on the first page.

Apparently only happens in groups that have more than one page. Forum threads with more than one page can be replied to.

Last edited 6 years ago by shevek (previous) (diff)

comment:2 Changed 6 years ago by shevek

Likely fixed with https://gitorious.org/bewelcome/rox/commit/821959d7e4b1487d3649bed054dd79cb14ca4bb4

Please test on alpha as soon as deployed there.

comment:3 Changed 6 years ago by shevek

  • Milestone changed from unassigned to 1.3
  • Owner set to shevek
  • Status changed from new to assigned

comment:4 Changed 6 years ago by jsfan

Deployed on alpha.

comment:5 Changed 6 years ago by mahouni

on alpha: http://alpha.bewelcome.org/forums/s4202-New_year_s_inspirations_ (same for other forum posts) I got this warning in the forums posts after the forum title and group name:

Warning: preg_replace(): Delimiter must not be alphanumeric or backslash in /var/rox/deployment/alpha.bewelcome.org-7164528/build/forums/templates/topic.php on line 94

Last edited 6 years ago by mahouni (previous) (diff)

comment:6 Changed 6 years ago by shevek

That fix obviously doesn't work. It breaks all reply links. Back to start.

comment:8 Changed 6 years ago by jsfan

Deployed on alpha.

comment:9 Changed 6 years ago by shevek

Arrggh. Left a debug output in the code. Fixed with this: https://gitorious.org/bewelcome/rox/commit/c80fb9392483c9c45071585ed9f39bfd3010b19b

comment:10 Changed 6 years ago by jsfan

Was just about to leave a comment about that... ;)

Deployed on alpha.

comment:11 Changed 6 years ago by shevek

Found another problem: http://www.bewelcome.org/forums/s2770-Improved_Search_Results_page___A_Mock_up__for_discussion

The regexp matches with

page___A_.../

and deletes that. Rendering the reply uri to http://alpha.bewelcome.org/forums/s2770-Improved_Search_Results_reply which isn't really useful.

Changing the regexp to #/page.{1,3}/# and replacing anything found with / fixes this (and keeps the other URLs alive as well).

Commit: http://gitorious.org/bewelcome/rox/commit/9f34ce1fdc041aff6b7a2fc21b574c75125a027a

Last edited 6 years ago by shevek (previous) (diff)

comment:12 Changed 6 years ago by jsfan

Commit refers to #1869 :(

Deployed on alpha.

comment:13 in reply to: ↑ description Changed 6 years ago by crumbking

  • Resolution set to fixed
  • Status changed from assigned to closed

Replying to pablobd:

I hit reply in http://www.bewelcome.org/groups/60/forum/s806-Joining_the_translation_team__Introduce_yourself_/page2/ And i get the groups page (as in http://www.bewelcome.org/groups) instead of the reply form

I tested the link on alpha. Seems to work now.

Note: See TracTickets for help on using tickets.