Opened 6 years ago

Closed 6 years ago

#1869 closed bug (fixed)

Forum threads/posts set to ModeratorOnly become inaccessible

Reported by: jsfan Owned by: jsfan
Priority: major Milestone: 1.4
Component: BW Forum Keywords: forum administrator administration lock thread
Cc: mahouni

Description

If a forum moderator sets a thread or post to "visible only to moderator", the thread or post becomes inaccessible and invisible to everyone including forum administrators.

Change History (45)

comment:1 Changed 6 years ago by jsfan

Pushed to develop. Please test locally for deployment on alpha.

comment:2 Changed 6 years ago by jsfan

  • Milestone changed from unassigned to 1.4

comment:3 Changed 6 years ago by mahouni

  • Cc mahouni added

comment:4 Changed 6 years ago by mahouni

tested locally with ForumModerator? "thorgal67". Seems to work...

Code reviewed, looks good :)

comment:5 Changed 6 years ago by jsfan

Deployed on alpha.

comment:6 Changed 6 years ago by jsfan

  • Status changed from new to assigned

comment:7 Changed 6 years ago by jsfan

  • Status changed from assigned to testing

comment:8 Changed 6 years ago by jsfan

  • Status changed from testing to needs_work

comment:9 Changed 6 years ago by jsfan

  • Status changed from needs_work to testing

comment:10 Changed 6 years ago by jsfan

  • Status changed from testing to needs_work

comment:11 Changed 6 years ago by jsfan

  • Status changed from needs_work to testing

comment:12 Changed 6 years ago by jsfan

  • Status changed from testing to needs_work

comment:13 Changed 6 years ago by jsfan

  • Status changed from needs_work to testing

comment:14 Changed 6 years ago by crumbking

tested locally, too but wonder if the only way to reach "moderator only" threads is via forums. if we have high activity in the forum these threads are lost in nirvana one day.

anyway this bug seems fixed...

comment:15 Changed 6 years ago by jsfan

I thought it was an established fact that none of our forum code was suited for a busy forum, anyway. The moderator tools are most definitely no exception. :(

comment:16 Changed 6 years ago by shevek

  • Resolution set to fixed
  • Status changed from testing to closed

OctoberTales? was so nice to test this on alpha. Works as expected. Closed.

comment:17 Changed 6 years ago by shevek

  • Resolution fixed deleted
  • Status changed from closed to reopened

OctoberTales? mentioned in an message that a thread that is set to 'moderator only' still shows the post visibility.

Commit: https://gitorious.org/bewelcome/rox/commit/9899d4eda9d680de02215dbca923b22d037a1457

Last edited 6 years ago by shevek (previous) (diff)

comment:18 Changed 6 years ago by shevek

  • Status changed from reopened to local_testing

comment:19 Changed 6 years ago by mahouni

  • Status changed from local_testing to to_alpha

tested locally. Works

comment:20 Changed 6 years ago by jsfan

  • Status changed from to_alpha to testing

comment:21 Changed 6 years ago by shevek

  • Resolution set to fixed
  • Status changed from testing to closed

Octobertales checked and says the '[ModOnly?]' is visible on alpha. Closed as fixed.

comment:22 Changed 6 years ago by jsfan

Actually, OctoberTales did mention that it is not shown in overviews but just in open threads. I've now added it everywhere where [Deleted] would be shown as well.

https://gitorious.org/bewelcome/rox/commit/e73986edd730e2ab0c4ae5990757f0b6b05da30f

Last edited 6 years ago by jsfan (previous) (diff)

comment:23 Changed 6 years ago by jsfan

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:24 Changed 6 years ago by jsfan

  • Status changed from reopened to to_alpha

comment:25 Changed 6 years ago by jsfan

  • Status changed from to_alpha to testing

comment:26 Changed 6 years ago by shevek

So he obviously send different messages ;-)

Unfortunately I can't check if the fix works. Maybe you can ask Octobertales to check again or as in this case you can't really influence the behaviour anyway just check yourself and close if working?

comment:27 Changed 6 years ago by jsfan

What I read is a post in the moderators group. I'll check myself and close but also ask the other moderators to confirm. Nothing urgent if not fully fixed. We'll open a new ticket and keep it for a later release.

comment:28 Changed 6 years ago by jsfan

  • Resolution set to fixed
  • Status changed from testing to closed

comment:29 Changed 6 years ago by shevek

  • Resolution fixed deleted
  • Status changed from closed to reopened

Now [ModOnly?] threads are visible to everyone (check http://alpha.bewelcome.org/forums/s4883-This_is_just_a_test).

Can't see a reason, why the commit from comment 22 would cause that, though. Maybe the last commit regarding sub groups (#1695) caused it?

comment:30 Changed 6 years ago by shevek

  • Status changed from reopened to to_alpha

Definitely wasn't this commit and wasn't #1695 either. Problem is caused by #1823. Mod only posts are only visible if 'Show only my group posts' is active.

comment:31 Changed 6 years ago by shevek

  • Status changed from to_alpha to testing

comment:32 Changed 6 years ago by shevek

  • Resolution set to fixed
  • Status changed from testing to closed

Closing again. Status fixed.

comment:33 Changed 6 years ago by jsfan

  • Resolution fixed deleted
  • Status changed from closed to reopened

Actually, I reckon I didn't "unbreak" this well enough. I've added additional checks and it all looks good now. I suspect we can then also close #1823.

comment:34 Changed 6 years ago by jsfan

  • Status changed from reopened to to_alpha

comment:35 Changed 6 years ago by jsfan

  • Status changed from to_alpha to testing

Works locally for me, so I've deployed it. :)

comment:36 Changed 6 years ago by shevek

  • Resolution set to fixed
  • Status changed from testing to closed

Agreed. Closed as fixed.

comment:37 Changed 6 years ago by mahouni

  • Resolution fixed deleted
  • Status changed from closed to reopened

Posts to deleted threads with visibility "Moderator only" are still visible at ./forums/member/*annoyingmember*

Not sure if that is related to this ticket, might be something else. But that's something we have to fix.

comment:38 Changed 6 years ago by mahouni

I don't have more time to work on this today. Here is what I have tried:
http://gitorious.org/~mahouni/bewelcome/mahouni-rox/commit/8d6f5f5ae31812381db99171b2c1c2ae74eacc65

Please someone has a look at it and test and improve..

comment:39 Changed 6 years ago by shevek

Can't confirm. I can only see deleted thread posts if I'm logged in as a forum moderator.

comment:40 Changed 6 years ago by jsfan

Confirmed here. If I revoke my ForumModerator privileges I can still see OctoberTales' "moderator only" threads as long as the posts are not "group only" or I am in the group. There is also no prefix on the post even when browsing as moderator. The click through to the post does not work (it shouldn't!).

Last edited 6 years ago by jsfan (previous) (diff)

comment:41 Changed 6 years ago by jsfan

  • Status changed from reopened to to_alpha

I have committed a fix for this which solves the problem locally and on alpha as far as I can tell.

I have NOT worried about checking the post count on the profile page. Most likely it is not adjusted.

https://gitorious.org/bewelcome/rox/commit/79a5a145c5e760bd70b250008052d0c368a66cb8

comment:42 Changed 6 years ago by jsfan

  • Status changed from to_alpha to testing

comment:43 Changed 6 years ago by jsfan

I checked and I'm convinced now that the post count on the profile does not care about visibility at all. It is a count of all posts the member has written, no matter if they are still available or not.

Nice side effect: The difference between the figure displayed and the actual count in the list is probably a good troll factor indicator ;)

comment:44 Changed 6 years ago by shevek

So count was never accurate as the list also doesn't show your post to groups that are moderated or you're not a member of. So no troll indicator but maybe a volunteer indicator ;-)

comment:45 Changed 6 years ago by shevek

  • Resolution set to fixed
  • Status changed from testing to closed

I checked one profile to see if there are moderated posts visible. They weren't. Closing.

(And yes I know there should have been at least one.)

Note: See TracTickets for help on using tickets.