Opened 6 years ago

Closed 6 years ago

#1875 closed unknown (fixed)

settings for show my forum posts link on profile

Reported by: mahouni Owned by: mahouni
Priority: major Milestone: 1.7
Component: BW Forum Keywords:
Cc: shevek

Description

Users forum posts on www.bewelcome.org/forums/member/username should be only accessible for the user itself and admins/ForumModerator. But there will be a preference setting to allow other BW members to see this page too.

Attachments (1)

myforumposts.sql (3.4 KB) - added by shevek 6 years ago.
Translations of word codes for my forum posts preference

Download all attachments as: .zip

Change History (19)

comment:1 Changed 6 years ago by mahouni

  • Component changed from unknown to BW Forum

code can be reviewed here: http://gitorious.org/~mahouni/bewelcome/mahouni-rox/commit/0df08f79885a15946ecc48a4135a8db20ad83f62

It needs a new entry in the db table "preferences":

INSERT INTO preferences( codeName, position, codeDescription, Description, DefaultValue, PossibleValues, Status) VALUES ('MyForumPostsPagePublic', 46, 'MyForumPostsPagePublicDes', 'MyForumPostsPagePublic description', 'No', 'No;Yes', 'Normal');
Last edited 6 years ago by mahouni (previous) (diff)

comment:2 Changed 6 years ago by mahouni

updated to latest develop: https://gitorious.org/~mahouni/bewelcome/mahouni-rox/commit/b1dec6f6a10a3c25f547cd5083d32a68d7baac80

The sql might need an a small change (position column) and the code does not yet adhere the programming guidelines everywhere.

comment:3 Changed 6 years ago by mahouni

  • Cc shevek added
  • Milestone changed from unassigned to 1.7
  • Owner set to mahouni
  • Status changed from new to accepted

I could contribute this ticket to milestone 1.7, if that's okay.

comment:4 Changed 6 years ago by shevek

Appreciated. Please update the query to add a position on the preference page.

Last edited 6 years ago by shevek (previous) (diff)

comment:5 Changed 6 years ago by mahouni

  • Status changed from accepted to local_testing

Which position number shall it be?

I submitted the patch to develop. Please test locally and write a "comming soon" translation word for the preference text before deploying on alpha.

https://gitorious.org/bewelcome/rox/commit/ec29fdaed80f9f7e28287e2e3158cf047afced7e

Last edited 6 years ago by mahouni (previous) (diff)

comment:6 Changed 6 years ago by shevek

I assume the best would be directly after the option for group or forum posts. That would be position 46.

Changed 6 years ago by shevek

Translations of word codes for my forum posts preference

comment:7 follow-up: Changed 6 years ago by shevek

  • Status changed from local_testing to to_alpha

If you access /forums/member/username directly after disabling the display you get a rather empty page. Would be good to show there that this is because the member decided to hide the list.

comment:8 Changed 6 years ago by shevek

  • Status changed from to_alpha to testing

The default value is wrong. It needs to be yes.

comment:9 Changed 6 years ago by shevek

  • Status changed from testing to needs_work

comment:10 in reply to: ↑ 7 Changed 6 years ago by mahouni

  • Resolution set to worksforme
  • Status changed from needs_work to closed

Replying to shevek:

If you access /forums/member/username directly after disabling the display you get a rather empty page. Would be good to show there that this is because the member decided to hide the list.

It is okay if that page is empty. It was no problem so far and it won't be a problem in the future. The page is just not meant to be visited in case that the list of post is hidden, or the user has not yet written a post or the visitor is not logged in or the username does not exist.

Replying to shevek:

The default value is wrong. It needs to be yes.

Can't reproduce. The default value for Visibility of 'Forum Posts' for profile visitors: "no" is correct. The suggestion was to set that list visible only for the profile owner and admins. I added an additional option for those people who want to show that list to others too. But that is not going to be the default.

comment:11 Changed 6 years ago by shevek

  • Resolution worksforme deleted
  • Status changed from closed to reopened

@mahouni: As we don't disable the link if you have no forum posts and the rpeference is set to 'Yes' we should really add a line that there are no posts.

Regarding default: If an existing member is fine with the display of his/her posts at the moment the forum posts list would be turned off as soon as he/she changes another preference and does not enable it explicitly. This shouldn't happen.

comment:12 Changed 6 years ago by crumbking

  • error while on a public profile on alpha:
Fatal error: Call to a member function getPKValue() on a non-object in /var/rox/deployment/alpha.bewelcome.org-0e1ad161/build/members/pages/member.page.php on line 76 

comment:13 Changed 6 years ago by mahouni

  • Status changed from reopened to local_testing

the error should be fixed now.

Default value: The display of all of the users forum posts is problematic. It will be turned off. If an existing member is not fine with having his forum post list turned off, he will have to change the setting. It is a question of who you care more: members who explicitly want their forums posts list accessible for all bw members, but don't know about the preference setting. Or users who explicitly don't want that list accessible, but don't know about the preference setting.

comment:14 Changed 6 years ago by shevek

I didn't see the implication that the default value would also affect the display of the forum posts list in the first place.

I make sure to add a note to the release notes then.

comment:15 Changed 6 years ago by shevek

  • Status changed from local_testing to to_alpha

Error message on public profiles gone. Locally tested and works fine. Mods still see all posts.

Ready for a second turn on alpha.

comment:16 Changed 6 years ago by shevek

  • Status changed from to_alpha to testing

comment:17 Changed 6 years ago by crumbking

Okay I set my pref to be visible by all on alpha. Could someone check if you see them?

Might need to be tested with a public profile. Anyone?

comment:18 Changed 6 years ago by crumbking

  • Resolution set to fixed
  • Status changed from testing to closed
Note: See TracTickets for help on using tickets.