Opened 6 years ago

Closed 6 years ago

#1896 closed improve feature (fixed)

Missing time zone

Reported by: sitatara Owned by: shevek
Priority: minor Milestone: 1.5
Component: unknown Keywords: time zone
Cc: pablobd

Description

From a support ticket: "Please add Honolulu as a time zone."

That's UTC-10; I couldn't find any city in the list of time zones which is in that zone, so it really seems to be missing.

Attachments (1)

patch1896.diff (7.6 KB) - added by shevek 6 years ago.
Add translation for cities and cleanup

Download all attachments as: .zip

Change History (28)

comment:1 Changed 6 years ago by shevek

The list starts with UTC -8. Add missing timezones UTC-11 to UTC-9.

Additionally add a text in brackets telling you the time difference to UTC.

comment:2 Changed 6 years ago by shevek

  • Owner set to shevek
  • Status changed from new to assigned

comment:3 Changed 6 years ago by shevek

  • Milestone changed from unassigned to 1.5

comment:4 Changed 6 years ago by shevek

  • Status changed from assigned to local_testing

comment:5 Changed 6 years ago by mahouni

local_testing on the mileston 1.5 branch:
https://gitorious.org/~mahouni/bewelcome/mahouni-rox/commits/ms15_develop_20130129

Don't forget the Database update for ticket #1892 and #1858.
Check: http://trac.bewelcome.org/wiki/DatabaseChanges

Last edited 6 years ago by mahouni (previous) (diff)

comment:6 Changed 6 years ago by mahouni

tested locally, seems to work:

in the preferences I can now select Fairbanks, Honolulu and Pago Pago. And the cities have a +/- diff.

I posted with UTC London setting at 2013/02/08 22:45

then I changed the setting to Pago Pago (UTC -11), when I log out and log in again the time of the post is 2013/02/08 11:45

I havent't looked at the code and I guess the UTC diffs for the cities are correct.

comment:7 follow-up: Changed 6 years ago by jsfan

I can select the Honolulu time zone but at least in my tests it is 1h off against the correct time. I presume that's #1835.

comment:8 in reply to: ↑ 7 Changed 6 years ago by dima42

looks good.

comment:9 Changed 6 years ago by jsfan

  • Status changed from local_testing to to_alpha

comment:10 Changed 6 years ago by jsfan

  • Status changed from to_alpha to testing

comment:11 Changed 6 years ago by crumbking

  • Status changed from testing to needs_work

Diff seems to work. But it's really not straight forward that you have to logout and login again. I would say either we inform the member that his change will be affected after a logout/login or we change it in a way it works straight away after hitting the save button.

But if I set it to Berlin I get 19:22 (should be 17:22). Setting to Cape Verde, save pref., logout/login it sets times to 17:22. So the diff works but the initial times seems to be incorrect.

comment:12 Changed 6 years ago by crumbking

+ let's add translations for the dropdown

comment:13 Changed 6 years ago by jsfan

This ticket is only about the extra time zones. I don't think much of the time stuff is working, anyway.

comment:14 Changed 6 years ago by shevek

Does this really need rework? The missing time zones are added. That you have to login/logout was the case before the change as well (we had a discussion about that in the bugs groups).

Which translation would you like to add? For the cities or for UTC?

comment:15 Changed 6 years ago by crumbking

I would say one translation for both. I could imagine you don't say UTC in Chinese ;-)

Okay if we don't want invest some more time into it. What about a simple flash message after saving?

Changed 6 years ago by shevek

Add translation for cities and cleanup

comment:16 Changed 6 years ago by shevek

The attached patch adds translation and also cleans up the messy code for the timezones. Please test locally.

Notes:

  • The comments on the array in mypreferences.column_col3.helper.php are there to enable automatic detection of new word codes.
  • London might up as Londres (as it seems to be translated) :-)
Last edited 6 years ago by shevek (previous) (diff)

comment:17 Changed 6 years ago by shevek

  • Status changed from needs_work to local_testing

comment:18 follow-up: Changed 6 years ago by dima42

Am I supposed to manually input "PreferenceLocalTimeUTC" into the 'words' database? I'm missing a few other words too (not from this commit), so this might just be an issue on my end.

comment:19 in reply to: ↑ 18 Changed 6 years ago by shevek

Replying to dima42:

Am I supposed to manually input "PreferenceLocalTimeUTC" into the 'words' database? I'm missing a few other words too (not from this commit), so this might just be an issue on my end.

No. You just give yourself Translator rights for 'en' and afterwards you can translate :-)

The way our translation works is good for translators but a little awkward during development.

comment:20 Changed 6 years ago by shevek

  • Status changed from local_testing to to_alpha

Change status to testing as obviously deployed on alpha.

comment:21 Changed 6 years ago by shevek

  • Status changed from to_alpha to testing

comment:22 Changed 6 years ago by dima42

Ok, I see, thanks.

Still playing with it locally because I don't have translation rights on alpha.

Calgary is spelled with a y.

The translation bar under the timezone scrolldown menu allows me to translate all the city names except for London. I can still translate London through other places.

Is it intended behavior to not allow translations other than English as the first one?

comment:23 Changed 6 years ago by shevek

Edit only shows untranslated objects. You can see all translatable objects when you select browse.

Calgari fixed through translation.

Last edited 6 years ago by shevek (previous) (diff)

comment:24 Changed 6 years ago by dima42

i see, thanks.

the hover text is not referring correctly when there is no english translation

see https://docs.google.com/file/d/0B7aUK8En6x3pU09VVW9pb21NcWM/edit?usp=sharing

comment:25 Changed 6 years ago by shevek

English 'translation' is done now. Should be fine therefore.

Please check and modify the ticket to 'passes as fixed' afterwards (if applicable).

comment:26 Changed 6 years ago by jsfan

  • Cc pablobd added

I can confirm that I can translate to German now. Next person to test, please close ticket if test was successful.

comment:27 Changed 6 years ago by sitatara

  • Resolution set to fixed
  • Status changed from testing to closed

I finished the German translations. Everything seems to work fine. Therefore closing ticket now.

Note: See TracTickets for help on using tickets.