Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1913 closed bug (invalid)

Nasty message to comments bugs

Reported by: pablobd Owned by:
Priority: critical Milestone: unassigned
Component: unknown Keywords: privacy
Cc: planetcruiser, jsfan

Description

This is really weird. I sent a message to a volunteer
http://www.bewelcome.org/messages/89080 date 2013/01/15 16:24

but the text of that message also apeared as a comment on the profile of the recipient with same date & time Tue Jan 15 16:24:21

it was later marked as spam so it doesnt appear anymore

I wonder if this is related to a known bug where info on some profile got moved to other profiles

this is really serious, imagine a sensitive private message gets published on a member public profile, it's a privacy mess!!!

Change History (12)

comment:1 Changed 5 years ago by shevek

@pablobd: Really as a comment? Because that is a completely different table than the messages. If that's the case something is really out of order.

comment:2 Changed 5 years ago by pablobd

cleary as a comment, I see the comments reported as spam and I found mine there!!!
The text looked familiar so i went to my sent messages and it was there, word by word, with the quoting and everything, then i checked timestamps an it was posted at the same time i sent the message

comment:3 Changed 5 years ago by shevek

  • Cc planetcruiser jsfan added

I have no idea how that can happen. I add jsfan and planetcruiser to cc maybe they can check some logs.

comment:4 Changed 5 years ago by jsfan

I can't think of any log that would help with this and I can't imagine that this can be fixed based on a one off. We will have to wait and see if it reoccurs.

comment:5 Changed 5 years ago by pablobd

Maybe it happens one in a thousand messages, but we never had a user that sent so many messages, until last week.

comment:6 Changed 5 years ago by globetrotter_tt

Yesterday I saw a message from you marked as spam in the reported messages (not reported comments). I have removed the "mark as spam" info and ticked the "i have processed it" checkmark.

I haven't seen a comment report though.

Is this message still visible on the other member's profile?

comment:7 Changed 5 years ago by pablobd

I think there is a chance I mistaken reported comment with reported message

comment:8 Changed 5 years ago by pablobd

  • Resolution set to invalid
  • Status changed from new to closed

Confirmed with logs, My mistake

comment:9 follow-up: Changed 5 years ago by planetcruiser

hehe, nice one. very entertaining. :-P

comment:10 in reply to: ↑ 9 Changed 5 years ago by globetrotter_tt

Replying to planetcruiser:

hehe, nice one. very entertaining. :-P

and all because someone renamed the links :-P :-P

comment:11 Changed 5 years ago by planetcruiser

pablo: uh, yeah, i renamed the volunteer links into something more meaningful. i hoped! is it confusing, shall the new names be reviewed?

comment:12 Changed 5 years ago by pablobd

fine for me! I'm taking a break from spam verification, too much stuff makes you make mistakes :D

Note: See TracTickets for help on using tickets.