Opened 5 years ago

Closed 4 years ago

#1943 closed bug (duplicate)

Include successor states of Nethelands Antilles in list of countries

Reported by: sitatara Owned by:
Priority: minor Milestone: unassigned
Component: BW Geo Keywords:
Cc:

Description (last modified by sitatara)

"Three new countries came into being after the dissolution of the Netherlands Antilles in October 2010. Curaçao and Sint Maarten became countries within the Kingdom of the Netherlands whereas Bonaire, Saba, and Sint Eustatius became special municipalities of the Netherlands proper." (http://geonames.wordpress.com/2010/12/20/curacao-sint-maarten-bonaire-saint-eustatius-saba/)

Therefore, we should replace the Netherlands Antilles in our list of countries here: http://www.bewelcome.org/places/ (in the list of North American countries) with the 3 new countries.

Currently, no member seems to be listed in the Netherlands Antilles. At sign-up the correct new countries can be selected and the Netherlands Antilles are not listed.


Related tickets: #1773, #1921

Change History (9)

comment:1 Changed 5 years ago by beatnickgr

This is already mentioned here http://trac.bewelcome.org/ticket/1773

Maybe we should close this ticket?

comment:2 Changed 5 years ago by sitatara

  • Description modified (diff)

comment:3 Changed 5 years ago by sitatara

Indeed the issue is mentioned in #1773 and also in #1921. In the latter ticket, planetcruiser asked specifically for a new ticket about the Netherlands Antilles (see comments there).

comment:4 Changed 4 years ago by Tsjoek

The three new countries have been added to the places list. But Bonaire still shows up. Sint Eustatius and Saba on the other hand don't. We import the list straight from geonames I assume? So they're not following their own guideline, that is quoted in the ticket-description? Or is there something else going on?

comment:5 Changed 4 years ago by shevek

That Bonaire shows up is fine I'd say. Everything with its own iso code is shown in the countries list (which should be renamed to something like Countries, Territories, Dependencies, Occupied Areas :-)).

comment:6 Changed 4 years ago by Tsjoek

The least thing is that Bonaire should be treated the same as Sint Eustatius and Saba, because their status is exactly the same. So or all three in, or all three out.
I'd say out, but I see that we are listing f.e. Martinique as well, so to be consquent with that they should be in.

Regarding the ISO, see the link to the geonames blog above. They share 1 ISO code, so 1 entry with three names is another option.

comment:7 Changed 4 years ago by shevek

It seems that the short name for 'Bonaire, St. Eustatius and Saba' is 'Bonaire'. So we either drop the short name preference or we leave it as is.

comment:8 Changed 4 years ago by Tsjoek

haha, well they're only 800 km apart.
Ok, so another inconsistency of geonames. So we leave it.

comment:9 Changed 4 years ago by sitatara

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.