Opened 6 years ago

Closed 5 years ago

#2006 closed bug (fixed)

Piwik: Empty "urlref"

Reported by: planetcruiser Owned by:
Priority: major Milestone: 1.8
Component: FrameWork Keywords:
Cc: guaka, jsfan

Description

Issue:

  • Piwik stats show thousands of hits with "Page URL not defined"
  • This is probably related to missing data in the counter image URL (currently http://www.bewelcome.org/piwik/piwik.php?idsite=1&rec=1&urlref=)

Solution:

  1. Properly fill urlref parameter
  2. Test if stats work better

Priority:

  • In order to decide which features should receive more love we need to know what is used the most. Piwik can help here, so we should fix this soon(ish)

Related:

Change History (8)

comment:1 Changed 6 years ago by shevek

The code looks like this

    if (isset($_SERVER['HTTP_REFERER'])) {
        $urlref = urlencode($_SERVER['HTTP_REFERER']);
    } else {
        $urlref = '';
    }

So code looks fine. Has to be a conf issue.

Last edited 6 years ago by shevek (previous) (diff)

comment:2 Changed 6 years ago by guaka

We replaced piwik code with normal JS and things are working!

No more "Page URL not defined".

(And JS tracking from the same domain is actually easier to block than an img bug from the same domain! Ghostery handles the former, not the latter.)

comment:3 Changed 6 years ago by guaka

  • Status changed from new to to_alpha

comment:4 Changed 6 years ago by guaka

(I'm not sure about these statuses. It's already on alpha.)

comment:5 Changed 6 years ago by shevek

  • Status changed from to_alpha to testing

comment:6 Changed 6 years ago by shevek

  • Milestone changed from unassigned to 1.8

comment:7 Changed 5 years ago by shevek

@guaka: Could you please check if you get statistics as intended?

comment:8 Changed 5 years ago by guaka

  • Resolution set to fixed
  • Status changed from testing to closed

Looks like it's fixed!

Note: See TracTickets for help on using tickets.