Opened 9 years ago

Closed 9 years ago

#201 closed bug (duplicate)

Signup problem

Reported by: jeanyves Owned by: steinwinde
Priority: blocker Milestone: 0.1-outreach-release
Component: BV Forum Keywords: signup user constraint
Cc:

Description

I have a problem when submitting a signup on test environment
it result is a constraint problem (see message below)

I fear that some hidden trick kill the database consistence but I can't figure wich one. I think it is critical

#0 debug( query problem with INSERT INTO user ( id , auth_id , handle , email , pw , active , lastlogin , location ) VALUES (142, NULL , , 'jyhegron@…', , '1', NULL , 2988507) mysql_error: Cannot add or update a child row: a foreign key constraint fails (hcvoltest/user, CONSTRAINT user_ibfk_2 FOREIGN KEY (location) REFERENCES geonames_cache (geonameid)) ) called at var/www/test_html/htdocs/bw/lib/bwdb.php:123 #1 sql_query(INSERT INTO user ( id , auth_id , handle , email , pw , active , lastlogin , location ) VALUES (142, NULL , , 'jyhegron@…', , '1', NULL , 2988507)) called at var/www/test_html/htdocs/bw/signup.php:168 query problem with INSERT INTO user ( id , auth_id , handle , email , pw , active , lastlogin , location ) VALUES (142, NULL , , 'jyhegron@…', , '1', NULL , 2988507) mysql_error: Cannot add or update a child row: a foreign key constraint fails (hcvoltest/user, CONSTRAINT user_ibfk_2 FOREIGN KEY (location) REFERENCES geonames_cache (geonameid))
query problem 86.65.189.10 December 3, 2007, 4:57 pm

Change History (2)

comment:1 Changed 9 years ago by steinwinde

  • Owner set to steinwinde
  • Status changed from new to assigned

comment:2 Changed 9 years ago by steinwinde

  • Resolution set to duplicate
  • Status changed from assigned to closed

This is a duplicate of ticket #59. I already wrote an e-mail trying to clarify the problem, but obviously in vain.

Subject: [BW-dev-discussion] trac, geonames, signup
Date: Fri, 23 Nov 2007 00:44:12 +0100
From: Felix van Hove <fvanhove@gmx.de>
Reply-To: BeWelcome Developers Team <bw-dev-discussion@bewelcome.org>
To: bw-dev-discussion@bewelcome.org
[...]
If you want to create a new user on your local BW 
platform by simply filling in the signup form, you absolutely need to 
import these data files into your database:

geonames_admincodes.sql
geonames_cache.sql
[...]
Of course these files are mandatory for the database of 
test.bewelcome.org too. Could someone with mysql command line access 
import these into hcvoltest? (phpmyadmin doesn't accept such big files 
as import.)
[...]
Note: See TracTickets for help on using tickets.