Opened 4 years ago

Last modified 4 years ago

#2062 new bug

Posts not displaying when moderators post in a group they don't belong to

Reported by: railslide Owned by:
Priority: minor Milestone: unassigned
Component: BW Forum Keywords:
Cc:

Description (last modified by railslide)

Where a moderator try to post in a thread that has visibility "group only" in a group she/he's not a member of, after submitting the reply no post nor error message are displayed.

Tabs "Discussion" and "Overview" tab display as there actually is a last post by the moderator, but when clicking on the green arrow or on the discussion there is not.

Example: https://www.bewelcome.org/groups/1014 (thread "bla")


Workaround: joining the group before posting

Change History (4)

comment:1 Changed 4 years ago by railslide

  • Description modified (diff)

comment:2 Changed 4 years ago by railslide

  • Type changed from unknown to bug

comment:3 Changed 4 years ago by shevek

I can see the post as a member of the group.

If the moderator isn't a member of the group the visibility of the post is unclear. To edit the visibility using the mod tools might fix that.

comment:4 Changed 4 years ago by railslide

I joined the group, but I still cannot see my own post, so I can't use admin edit on that and change visibility to the thread doesn't work (at least not on the old posts, I have no idea about what will be the visibility of those posted after my change)

Last edited 4 years ago by railslide (previous) (diff)
Note: See TracTickets for help on using tickets.